#!/usr/bin/make -f
include /usr/share/quilt/quilt.make
+QUILT = QUILT_PATCHES=$(QUILT_PATCH_DIR) quilt --quiltrc /dev/null
###################### user serviceable parts ######################
###
# header cache backend
# HCACHE_DB := bdb
-HCACHE_DB := gdbm
+# HCACHE_DB := gdbm
# HCACHE_DB := qdbm
+HCACHE_DB := tokyocabinet
###
# GPGME backend
-# GPGME := --enable-gpgme
+GPGME := --enable-gpgme
###
###################### variables ######################
ifeq ($(HCACHE_DB),qdbm)
hcache_db := --without-gdbm --without-bdb --without-tokyocabinet
endif
+ifeq ($(HCACHE_DB),tokyocabinet)
+ hcache_db := --without-gdbm --without-bdb --without-qdbm
+ ifeq ($(shell dpkg --print-architecture),hurd-i386)
+ hcache_db := --without-bdb --without-qdbm
+ endif
+endif
confflags = --prefix=/usr \
--sysconfdir=/etc \
ifeq ($(BUILD_PATCHED),yes)
###################### building mutt-patched ######################
+ $(QUILT) applied > PATCHES
autoreconf --install --include=m4
cd $(objdir)-patched && \
env CFLAGS="$(CFLAGS)" CPPFLAGS="$(CPPFLAGS)" \
build build-arch: $(objdir)/build-stamp
$(objdir)/build-stamp: $(objdir)-patched/build-stamp
###################### building mutt ######################
- QUILT_PATCHES=$(QUILT_PATCH_DIR) quilt --quiltrc /dev/null pop mutt.org
+ $(QUILT) pop mutt.org
+ $(QUILT) applied > PATCHES
autoreconf --install --include=m4
-mkdir $(objdir)
grep '^set' contrib/gpg.rc; \
echo ) > debian/tmp/gpg.rc
+ dh_install
+
+ # prepare files for update-alternatives
+ mv debian/mutt/usr/bin/mutt debian/mutt/usr/bin/mutt-org
ifeq ($(BUILD_PATCHED),yes)
- # temporarily call the binary mutt-patched so dh_strip gets the debug file name right
install -D $(objdir)-patched/mutt debian/mutt-patched/usr/bin/mutt-patched
endif
binary binary-arch: install
###################### binary ######################
- dh_install
dh_installman
dh_installmenu
dh_installmime
dh_strip --dbg-package=mutt-dbg
rm -rf $(CURDIR)/debian/mutt-dbg/usr/share/doc/mutt-dbg \
$(CURDIR)/debian/mutt-patched/usr/share/doc/mutt-patched
-ifeq ($(BUILD_PATCHED),yes)
- mv debian/mutt-patched/usr/bin/mutt-patched debian/mutt-patched/usr/bin/mutt
-endif
dh_link
dh_compress --exclude usr/share/doc/mutt/README.Patches
# please dpkg-source
rm -f po/*.gmo
- touch PATCHES
+ echo -n > PATCHES
# remove build trees
rm -rf $(objdir) $(objdir)-patched
rm -f configure config.h.in
rm -f Makefile.in contrib/Makefile.in imap/Makefile.in doc/Makefile.in m4/Makefile.in
- # clean PATCHES hunks (blame quilt refresh)
- for p in `grep -rl PATCHES debian/patches` ; do perl -wi debian/fix-PATCHES.pl $$p ; done
-
dh_clean
.PHONY: configure build build-arch build-indep clean install binary binary-arch binary-indep patch