]> git.llucax.com Git - software/mutt-debian.git/blobdiff - debian/rules
Instead of trying to maintain the PATCHES file, put "quilt applied" output there.
[software/mutt-debian.git] / debian / rules
index e6f67448477f708278dbce8f5667e8368c3d24bb..7db0d8fc32a793c8e39635d935c2616f7344e85e 100755 (executable)
@@ -1,6 +1,7 @@
 #!/usr/bin/make -f
 
 include /usr/share/quilt/quilt.make
+QUILT = QUILT_PATCHES=$(QUILT_PATCH_DIR) quilt --quiltrc /dev/null
 
 ###################### user serviceable parts ######################
 
@@ -96,6 +97,7 @@ $(objdir)-patched/build-stamp: $(QUILT_STAMPFN)
        
 ifeq ($(BUILD_PATCHED),yes)
        ###################### building mutt-patched ######################
+       $(QUILT) applied > PATCHES
        autoreconf --install --include=m4
        cd $(objdir)-patched && \
        env CFLAGS="$(CFLAGS)" CPPFLAGS="$(CPPFLAGS)" \
@@ -112,7 +114,8 @@ endif
 build build-arch: $(objdir)/build-stamp
 $(objdir)/build-stamp: $(objdir)-patched/build-stamp
        ###################### building mutt ######################
-       QUILT_PATCHES=$(QUILT_PATCH_DIR) quilt --quiltrc /dev/null pop mutt.org
+       $(QUILT) pop mutt.org
+       $(QUILT) applied > PATCHES
        
        autoreconf --install --include=m4
        -mkdir $(objdir)
@@ -197,7 +200,7 @@ clean: unpatch
        
        # please dpkg-source
        rm -f po/*.gmo
-       touch PATCHES
+       echo -n > PATCHES
        
        # remove build trees
        rm -rf $(objdir) $(objdir)-patched
@@ -206,9 +209,6 @@ clean: unpatch
        rm -f configure config.h.in
        rm -f Makefile.in contrib/Makefile.in imap/Makefile.in doc/Makefile.in m4/Makefile.in
        
-       # clean PATCHES hunks (blame quilt refresh)
-       for p in `grep -rl PATCHES debian/patches` ; do perl -wi debian/fix-PATCHES.pl $$p ; done
-       
        dh_clean
 
 .PHONY: configure build build-arch build-indep clean install binary binary-arch binary-indep patch