]> git.llucax.com Git - software/mutt-debian.git/blobdiff - debian/patches/mutt-patched/sidebar-sorted
sidebar-sorted: use strcoll() to sort the sidebar using the locale settings of the...
[software/mutt-debian.git] / debian / patches / mutt-patched / sidebar-sorted
index 6e5aa4eea1bd0f5c044bb7bdfa50ff094c30d7a9..c5211b8ff84c69dcdae5fe148960ce032ae17a7e 100644 (file)
@@ -26,7 +26,7 @@ should be easy to adopt it to a vanilla mutt.
 +                      needsort=0;
 +                      tmp = Incoming;
 +                      for ( ; tmp ; tmp=tmp->next ) {
 +                      needsort=0;
 +                      tmp = Incoming;
 +                      for ( ; tmp ; tmp=tmp->next ) {
-+                              if (tmp->next != NULL && strcmp(tmp->path, tmp->next->path) > 0) {
++                              if (tmp->next != NULL && strcoll(tmp->path, tmp->next->path) > 0) {
 +                                      needsort=1;
 +                                      prev = tmp->prev;
 +                                      next = tmp->next;
 +                                      needsort=1;
 +                                      prev = tmp->prev;
 +                                      next = tmp->next;