X-Git-Url: https://git.llucax.com/software/mutt-debian.git/blobdiff_plain/78077051deed41adf786e1f5f4397dadf3012956..3324c6858ba6891531d8bb2e3e0d15f5b413c441:/debian/patches/features/compressed-folders
diff --git a/debian/patches/features/compressed-folders b/debian/patches/features/compressed-folders
index 355d84b..dc2c38e 100644
--- a/debian/patches/features/compressed-folders
+++ b/debian/patches/features/compressed-folders
@@ -7,11 +7,14 @@ The home page for this patch is:
http://www.spinnaker.de/mutt/compressed/
* Patch last synced with upstream:
- - Date: 2007-06-14
- - File: http://www.spinnaker.de/mutt/compressed/patch-1.5.16.rr.compressed.1.gz
+ - Date: 2008-05-20
+ - File: http://www.spinnaker.de/mutt/compressed/patch-1.5.18.rr.compressed.1.gz
* Changes made:
- - 2007-06-14 myon: remove hunks for Muttrc*
+ - 2008-05-20 myon: refreshed to remove hunks in auto* files
+ - 2009-09-15 myon: refreshed for mutt-1.5.19
+ status.c:103: add sizeof (tmp) to mutt_pretty_mailbox
+ - 2009-09-15 scotton: removed doc/Muttrc for mutt-1.5.19 (only patch doc/Muttrc.head)
== END PATCH
--- /dev/null
@@ -223,7 +226,7 @@ The home page for this patch is:
+static char *get_compression_cmd (const char* cmd, const CONTEXT* ctx)
+{
+ char expanded[_POSIX_PATH_MAX];
-+ mutt_FormatString (expanded, sizeof (expanded), 0, cmd,
++ mutt_FormatString (expanded, sizeof (expanded), 0, cmd,
+ compresshook_format_str, (unsigned long) ctx, 0);
+ return safe_strdup (expanded);
+}
@@ -363,8 +366,8 @@ The home page for this patch is:
+ fclose (ctx->fp);
+ ctx->fp = NULL;
+ /* if the folder was removed, remove the gzipped folder too */
-+ if ((ctx->magic > 0)
-+ && (access (ctx->path, F_OK) != 0)
++ if ((ctx->magic > 0)
++ && (access (ctx->path, F_OK) != 0)
+ && ! option (OPTSAVEEMPTY))
+ remove (ctx->realpath);
+ else
@@ -443,7 +446,7 @@ The home page for this patch is:
+ if (! (ctx->append
+ && ((append = get_append_command (ctx->realpath, ctx))
+ || (append = ci->close))))
-+ {
++ {
+ /* if we can not or should not append, we only have to remove the */
+ /* compressed info, because sync was already called */
+ mutt_fast_close_compressed (ctx);
@@ -548,7 +551,7 @@ The home page for this patch is:
+void mutt_fast_close_compressed (CONTEXT *);
--- a/configure.ac
+++ b/configure.ac
-@@ -804,6 +804,11 @@ AC_ARG_ENABLE(locales-fix, AC_HELP_STRIN
+@@ -805,6 +805,11 @@
AC_DEFINE(LOCALES_HACK,1,[ Define if the result of isprint() is unreliable. ])
fi])
@@ -562,7 +565,7 @@ The home page for this patch is:
AC_DEFINE_UNQUOTED(EXECSHELL, "$withval",
--- a/curs_main.c
+++ b/curs_main.c
-@@ -1116,6 +1116,11 @@ int mutt_index_menu (void)
+@@ -1135,6 +1135,11 @@
{
int check;
@@ -576,7 +579,7 @@ The home page for this patch is:
--- a/doc/manual.xml.head
+++ b/doc/manual.xml.head
-@@ -4932,6 +4932,205 @@ becomes an issue as mutt will silently f
+@@ -5678,6 +5678,205 @@
@@ -609,9 +612,9 @@ The home page for this patch is:
+For example:
+
+
-+open-hook \\.gz$ "gzip -cd %f > %t"
++open-hook \\.gz$ "gzip -cd %f > %t"
+close-hook \\.gz$ "gzip -c %t > %f"
-+append-hook \\.gz$ "gzip -c %t >> %f"
++append-hook \\.gz$ "gzip -c %t >> %f"
+
+
+You do not have to specify all of the commands. If you omit
-+open-hook \\.gz$ "gzip -cd %f > %t"
++open-hook \\.gz$ "gzip -cd %f > %t"
+
+
+If the command is empty, this operation is
@@ -725,7 +728,7 @@ The home page for this patch is:
+Example:
+
+
-+append-hook \\.gz$ "gzip -c %t >> %f"
++append-hook \\.gz$ "gzip -c %t >> %f"
+
+
+When append-hook is used, the folder
@@ -782,9 +785,23 @@ The home page for this patch is:
Mutt's MIME Support
+--- a/doc/Muttrc.head
++++ b/doc/Muttrc.head
+@@ -29,6 +29,11 @@
+ macro index,pager y "?" "show incoming mailboxes list"
+ bind browser y exit
+
++# Use folders which match on \\.gz$ as gzipped folders:
++# open-hook \\.gz$ "gzip -cd %f > %t"
++# close-hook \\.gz$ "gzip -c %t > %f"
++# append-hook \\.gz$ "gzip -c %t >> %f"
++
+ # If Mutt is unable to determine your site's domain name correctly, you can
+ # set the default here.
+ #
--- a/doc/muttrc.man.head
+++ b/doc/muttrc.man.head
-@@ -345,6 +345,24 @@ specify the ID of the public key to be u
+@@ -345,6 +345,24 @@
to a certain recipient. The meaning of "key ID" is to be taken
broadly: This can be a different e-mail address, a numerical key ID,
or even just an arbitrary search string.
@@ -800,7 +817,7 @@ The home page for this patch is:
+"\fI\\\\.gz$\fP"). The commands tell Mutt how to uncompress a folder
+(\fBopen-hook\fP), compress a folder (\fBclose-hook\fP) or append a
+compressed mail to a compressed folder (\fBappend-hook\fP). The
-+\fIcommand\fP string is the
++\fIcommand\fP string is the
+.BR printf (3)
+like format string, and it should accept two parameters: \fB%f\fP,
+which is replaced with the (compressed) folder name, and \fB%t\fP
@@ -822,7 +839,7 @@ The home page for this patch is:
#include
#include
#include
-@@ -92,6 +96,16 @@ int mutt_parse_hook (BUFFER *buf, BUFFER
+@@ -92,6 +96,16 @@
memset (&pattern, 0, sizeof (pattern));
pattern.data = safe_strdup (path);
}
@@ -841,7 +858,7 @@ The home page for this patch is:
)
--- a/init.h
+++ b/init.h
-@@ -3172,6 +3172,11 @@ struct command_t Commands[] = {
+@@ -3514,6 +3514,11 @@
{ "fcc-hook", mutt_parse_hook, M_FCCHOOK },
{ "fcc-save-hook", mutt_parse_hook, M_FCCHOOK | M_SAVEHOOK },
{ "folder-hook", mutt_parse_hook, M_FOLDERHOOK },
@@ -855,7 +872,7 @@ The home page for this patch is:
{ "hdr_order", parse_list, UL &HeaderOrderList },
--- a/main.c
+++ b/main.c
-@@ -400,6 +400,12 @@ static void show_version (void)
+@@ -402,6 +402,12 @@
#else
"-LOCALES_HACK "
#endif
@@ -870,17 +887,17 @@ The home page for this patch is:
"+HAVE_WC_FUNCS "
--- a/Makefile.am
+++ b/Makefile.am
-@@ -18,7 +18,7 @@ BUILT_SOURCES = keymap_defs.h patchlist.
+@@ -18,7 +18,7 @@
bin_PROGRAMS = mutt @DOTLOCK_TARGET@ @PGPAUX_TARGET@
- mutt_SOURCES = $(BUILT_SOURCES) \
+ mutt_SOURCES = \
addrbook.c alias.c attach.c base64.c browser.c buffy.c color.c \
- crypt.c cryptglue.c \
+ crypt.c cryptglue.c compress.c \
commands.c complete.c compose.c copy.c curs_lib.c curs_main.c date.c \
edit.c enter.c flags.c init.c filter.c from.c \
getdomain.c group.c \
-@@ -66,7 +66,7 @@ EXTRA_mutt_SOURCES = account.c md5c.c mu
- utf8.c wcwidth.c
+@@ -57,7 +57,7 @@
+ bcache.h browser.h hcache.h mbyte.h mutt_idna.h remailer.h url.h
EXTRA_DIST = COPYRIGHT GPL OPS OPS.PGP OPS.CRYPT OPS.SMIME TODO UPDATING \
- configure account.h \
@@ -901,7 +918,7 @@ The home page for this patch is:
#include
#include
#include
-@@ -1026,6 +1030,12 @@ bail: /* Come here in case of disaster
+@@ -1048,6 +1052,12 @@
int mbox_close_mailbox (CONTEXT *ctx)
{
mx_unlock_file (ctx->path, fileno (ctx->fp), 1);
@@ -916,7 +933,7 @@ The home page for this patch is:
return 0;
--- a/mutt.h
+++ b/mutt.h
-@@ -160,6 +160,11 @@ typedef enum
+@@ -146,6 +146,11 @@
#define M_ACCOUNTHOOK (1<<9)
#define M_REPLYHOOK (1<<10)
#define M_SEND2HOOK (1<<11)
@@ -928,7 +945,7 @@ The home page for this patch is:
/* tree characters for linearize_tree and print_enriched_string */
#define M_TREE_LLCORNER 1
-@@ -889,6 +894,11 @@ typedef struct _context
+@@ -883,6 +888,11 @@
int flagged; /* how many flagged messages */
int msgnotreadyet; /* which msg "new" in pager, -1 if none */
@@ -953,7 +970,7 @@ The home page for this patch is:
#ifdef USE_IMAP
#include "imap.h"
#endif
-@@ -450,6 +454,10 @@ int mx_get_magic (const char *path)
+@@ -415,6 +419,10 @@
return (-1);
}
@@ -964,7 +981,7 @@ The home page for this patch is:
return (magic);
}
-@@ -489,6 +497,13 @@ static int mx_open_mailbox_append (CONTE
+@@ -454,6 +462,13 @@
{
struct stat sb;
@@ -978,7 +995,7 @@ The home page for this patch is:
ctx->append = 1;
#ifdef USE_IMAP
-@@ -652,7 +667,12 @@ CONTEXT *mx_open_mailbox (const char *pa
+@@ -617,7 +632,12 @@
}
ctx->magic = mx_get_magic (path);
@@ -992,7 +1009,7 @@ The home page for this patch is:
if(ctx->magic == 0)
mutt_error (_("%s is not a mailbox."), path);
-@@ -753,6 +773,10 @@ void mx_fastclose_mailbox (CONTEXT *ctx)
+@@ -718,6 +738,10 @@
mutt_free_header (&ctx->hdrs[i]);
FREE (&ctx->hdrs);
FREE (&ctx->v2r);
@@ -1003,7 +1020,7 @@ The home page for this patch is:
FREE (&ctx->path);
FREE (&ctx->pattern);
if (ctx->limit_pattern)
-@@ -805,6 +829,12 @@ static int sync_mailbox (CONTEXT *ctx, i
+@@ -770,6 +794,12 @@
if (tmp && tmp->new == 0)
mutt_update_mailbox (tmp);
@@ -1016,7 +1033,7 @@ The home page for this patch is:
return rc;
}
-@@ -1063,6 +1093,11 @@ int mx_close_mailbox (CONTEXT *ctx, int
+@@ -1033,6 +1063,11 @@
!mutt_is_spool(ctx->path) && !option (OPTSAVEEMPTY))
mx_unlink_empty (ctx->path);
@@ -1028,7 +1045,7 @@ The home page for this patch is:
mx_fastclose_mailbox (ctx);
return 0;
-@@ -1378,6 +1413,11 @@ int mx_check_mailbox (CONTEXT *ctx, int
+@@ -1355,6 +1390,11 @@
{
int rc;
@@ -1042,7 +1059,7 @@ The home page for this patch is:
if (ctx->locked) lock = 0;
--- a/mx.h
+++ b/mx.h
-@@ -40,6 +40,9 @@ enum
+@@ -40,6 +40,9 @@
#ifdef USE_POP
, M_POP
#endif
@@ -1052,28 +1069,24 @@ The home page for this patch is:
};
WHERE short DefaultMagic INITVAL (M_MBOX);
---- a/PATCHES
-+++ b/PATCHES
-@@ -5,3 +5,4 @@ patch-1.5.13.nt+ab.xtitles.4
- patch-1.5.6.dw.maildir-mtime.1
- patch-1.5.13.cd.ifdef.2
- patch-1.5.8.hr.sensible_browser_position.3
-+patch-1.5.16.rr.compressed.1
--- a/po/de.po
+++ b/po/de.po
-@@ -3,7 +3,7 @@ msgstr ""
- "Project-Id-Version: 1.5.14\n"
- "Report-Msgid-Bugs-To: \n"
- "POT-Creation-Date: 2007-02-23 09:18-0800\n"
--"PO-Revision-Date: 2007-02-25 12:33+0100\n"
-+"PO-Revision-Date: 2007-09-08 20:55+0200\n"
- "Last-Translator: Roland Rosenfeld \n"
- "Language-Team: German \n"
- "MIME-Version: 1.0\n"
-@@ -1266,6 +1266,48 @@ msgstr "Prüfung des Absenders fehlgeschl
- msgid "Failed to figure out sender"
- msgstr "Kann Absender nicht ermitteln"
+@@ -2005,6 +2005,10 @@
+ msgid "Bad history file format (line %d)"
+ msgstr "Falsches Format der Datei früherer Eingaben (Zeile %d)"
+
++#: hook.c:96
++msgid "badly formatted command string"
++msgstr "Hook enthält nicht die Muster %f und %t"
++
+ #: hook.c:251
+ #, c-format
+ msgid "unhook: Can't do unhook * from within a hook."
+@@ -5378,3 +5382,45 @@
+ #~ msgid "Authentication method is unknown."
+ #~ msgstr "Authentifizierungsmethode unbekannt."
++
+#: compress.c:203 mbox.c:661
+msgid "Mailbox was corrupted!"
+msgstr "Mailbox wurde zerstört!"
@@ -1115,43 +1128,9 @@ The home page for this patch is:
+#, c-format
+msgid " %s: Error compressing mailbox! Uncompressed one kept!\n"
+msgstr " %s: Fehler beim packen der Mailbox! Entpackte Mailbox gespeichert!\n"
-+
- #: crypt.c:69
- #, c-format
- msgid " (current time: %c)"
-@@ -1926,6 +1968,10 @@ msgstr ""
- msgid "Help for %s"
- msgstr "Hilfe für %s"
-
-+#: hook.c:96
-+msgid "badly formatted command string"
-+msgstr "Hook enthält nicht die Muster %f und %t"
-+
- #: hook.c:246
- #, c-format
- msgid "unhook: Can't do unhook * from within a hook."
-@@ -3428,18 +3474,10 @@ msgstr "Lese %s..."
- msgid "Mailbox is corrupt!"
- msgstr "Mailbox fehlerhaft!"
-
--#: mbox.c:670
--msgid "Mailbox was corrupted!"
--msgstr "Mailbox wurde zerstört!"
--
- #: mbox.c:711 mbox.c:964
- msgid "Fatal error! Could not reopen mailbox!"
- msgstr "Fataler Fehler, konnte Mailbox nicht erneut öffnen!"
-
--#: mbox.c:720
--msgid "Unable to lock mailbox!"
--msgstr "Kann Mailbox nicht für exklusiven Zugriff sperren!"
--
- #. this means ctx->changed or ctx->deleted was set, but no
- #. * messages were found to be changed or deleted. This should
- #. * never happen, is we presume it is a bug in mutt.
--- a/po/POTFILES.in
+++ b/po/POTFILES.in
-@@ -8,6 +8,7 @@ charset.c
+@@ -8,6 +8,7 @@
color.c
commands.c
compose.c
@@ -1161,7 +1140,7 @@ The home page for this patch is:
cryptglue.c
--- a/status.c
+++ b/status.c
-@@ -97,6 +97,14 @@ status_format_str (char *buf, size_t buf
+@@ -96,6 +96,14 @@
case 'f':
snprintf (fmt, sizeof(fmt), "%%%ss", prefix);
@@ -1169,10 +1148,15 @@ The home page for this patch is:
+ if (Context && Context->compressinfo && Context->realpath)
+ {
+ strfcpy (tmp, Context->realpath, sizeof (tmp));
-+ mutt_pretty_mailbox (tmp);
++ mutt_pretty_mailbox (tmp, sizeof (tmp));
+ }
+ else
+#endif
if (Context && Context->path)
{
strfcpy (tmp, Context->path, sizeof (tmp));
+--- a/PATCHES
++++ b/PATCHES
+@@ -1 +1,2 @@
++patch-1.5.18.rr.compressed.1
+ patch-1.5.13.cd.ifdef.2