]> git.llucax.com Git - software/mutt-debian.git/blobdiff - debian/patches/features/xtitles
fix a missing hyphen
[software/mutt-debian.git] / debian / patches / features / xtitles
index 6419282fa94d7f0e4dc37d210be890ef207d428a..76cd81ec377fabbb1129407cbd5df7c217f74574 100644 (file)
@@ -12,7 +12,7 @@ This is the xterm title patch as found on the mutt mailing lists.
 == END PATCH
 --- a/curs_main.c
 +++ b/curs_main.c
-@@ -112,6 +112,19 @@ static const char *No_visible = N_("No v
+@@ -110,6 +110,19 @@
  
  extern size_t UngetCount;
  
@@ -32,7 +32,7 @@ This is the xterm title patch as found on the mutt mailing lists.
  void index_make_entry (char *s, size_t l, MUTTMENU *menu, int num)
  {
    format_flag flag = M_FORMAT_MAKEPRINT | M_FORMAT_ARROWCURSOR | M_FORMAT_INDEX;
-@@ -574,6 +587,13 @@ int mutt_index_menu (void)
+@@ -566,6 +579,13 @@
        SETCOLOR (MT_COLOR_NORMAL);
          BKGDSET (MT_COLOR_NORMAL);
        menu->redraw &= ~REDRAW_STATUS;
@@ -48,7 +48,7 @@ This is the xterm title patch as found on the mutt mailing lists.
        menu->redraw = 0;
 --- a/globals.h
 +++ b/globals.h
-@@ -145,6 +145,8 @@ WHERE char *Tempdir;
+@@ -140,6 +140,8 @@
  WHERE char *Tochars;
  WHERE char *Username;
  WHERE char *Visual;
@@ -59,7 +59,7 @@ This is the xterm title patch as found on the mutt mailing lists.
  WHERE char *LastFolder;
 --- a/init.c
 +++ b/init.c
-@@ -1870,6 +1870,26 @@ static int parse_set (BUFFER *tmp, BUFFE
+@@ -1892,6 +1892,26 @@
        toggle_option (MuttVars[idx].data);
        else
        set_option (MuttVars[idx].data);
@@ -88,8 +88,8 @@ This is the xterm title patch as found on the mutt mailing lists.
             DTYPE (MuttVars[idx].type) == DT_PATH ||
 --- a/init.h
 +++ b/init.h
-@@ -3104,6 +3104,27 @@ struct option_t MuttVars[] = {
-   ** option does nothing: mutt will never write out the BCC header
+@@ -3285,6 +3285,27 @@
+   ** option does nothing: mutt will never write out the ``Bcc:'' header
    ** in this case.
    */
 +  {"xterm_icon",       DT_STR,   R_BOTH, UL &XtermIcon,  UL "M%?n?AIL&ail?"},
@@ -118,7 +118,7 @@ This is the xterm title patch as found on the mutt mailing lists.
  };
 --- a/mutt.h
 +++ b/mutt.h
-@@ -458,6 +458,7 @@ enum
+@@ -438,6 +438,7 @@
    OPTWRAPSEARCH,
    OPTWRITEBCC,                /* write out a bcc header? */
    OPTXMAILER,
@@ -128,7 +128,7 @@ This is the xterm title patch as found on the mutt mailing lists.
    OPTCRYPTUSEPKA,
 --- a/pager.c
 +++ b/pager.c
-@@ -1767,6 +1767,13 @@ mutt_pager (const char *banner, const ch
+@@ -1761,6 +1761,13 @@
        mutt_paddstr (COLS, IsHeader (extra) || IsMsgAttach (extra) ?  buffer : banner);
        BKGDSET (MT_COLOR_NORMAL);
        SETCOLOR (MT_COLOR_NORMAL);
@@ -144,7 +144,7 @@ This is the xterm title patch as found on the mutt mailing lists.
      if ((redraw & REDRAW_INDEX) && index)
 --- a/status.c
 +++ b/status.c
-@@ -195,6 +195,8 @@ status_format_str (char *buf, size_t buf
+@@ -195,6 +195,8 @@
        break;
  
      case 'P':
@@ -155,16 +155,12 @@ This is the xterm title patch as found on the mutt mailing lists.
        else
 --- a/mutt_menu.h
 +++ b/mutt_menu.h
-@@ -103,6 +103,8 @@ void menu_current_middle (MUTTMENU *);
+@@ -103,6 +103,8 @@
  void menu_current_bottom (MUTTMENU *);
  void menu_check_recenter (MUTTMENU *);
  void menu_status_line (char *, size_t, MUTTMENU *, const char *);
 +void set_xterm_title_bar (char *title);
 +void set_xterm_icon_name (char *name);
  
- MUTTMENU *mutt_new_menu (void);
+ MUTTMENU *mutt_new_menu (int);
  void mutt_menuDestroy (MUTTMENU **);
---- a/PATCHES
-+++ b/PATCHES
-@@ -0,0 +1 @@
-+patch-1.5.13.nt+ab.xtitles.4