]> git.llucax.com Git - software/mutt-debian.git/blobdiff - debian/patches/upstream/530887-dovecot-imap.patch
remove bogus file .pc/.version
[software/mutt-debian.git] / debian / patches / upstream / 530887-dovecot-imap.patch
index 3b67a18221d9149f8c1b4c68fce9ac015935b6a9..793f049e4fb481296d5d3ba12ad3e95cf86648ae 100644 (file)
@@ -1,3 +1,14 @@
+This patch fixes the following two bugs:
+*) http://bugs.debian.org/530887 
+   mutt: fails to move read messages even with move=yes
+
+*) http://bugs.debian.org/530671
+   mutt: does not want to open dot subdirs via imap anymore
+
+the second one happens with dovecot which uses / as a delimeter for mailbox,
+so without this patch is not possible to access subdirs on imap accounts
+hosted on dovecot
+
 --- a/imap/util.c
 +++ b/imap/util.c
 @@ -393,19 +393,19 @@
 --- a/imap/util.c
 +++ b/imap/util.c
 @@ -393,19 +393,19 @@
    while (mailbox && *mailbox && i < plen - 1)
    {
 -    if (strchr(ImapDelimChars, *mailbox) || *mailbox == delim)
    while (mailbox && *mailbox && i < plen - 1)
    {
 -    if (strchr(ImapDelimChars, *mailbox) || *mailbox == delim)
-+    if ((ImapDelimChars && strchr(ImapDelimChars, *mailbox)) 
++    if ((ImapDelimChars && strchr(ImapDelimChars, *mailbox))
 +        || *mailbox == delim)
      {
 +      /* use connection delimiter if known. Otherwise use user delimiter */
 +      if (!idata)
 +        || *mailbox == delim)
      {
 +      /* use connection delimiter if known. Otherwise use user delimiter */
 +      if (!idata)
-+        delim = *mailbox; 
++        delim = *mailbox;
        while (*mailbox &&
             (strchr(ImapDelimChars, *mailbox) || *mailbox == delim))
          mailbox++;
        while (*mailbox &&
             (strchr(ImapDelimChars, *mailbox) || *mailbox == delim))
          mailbox++;