]> git.llucax.com Git - software/mutt-debian.git/blobdiff - debian/patches/features/compressed-folders
refresh compressed-folders patch
[software/mutt-debian.git] / debian / patches / features / compressed-folders
index cae3fb3b3cf4b3e143505fd6ee42f0138e2600f5..d08371f3af9f8d436c3a0cc38b3d9e8890ff74a2 100644 (file)
@@ -7,21 +7,15 @@ The home page for this patch is:
   http://www.spinnaker.de/mutt/compressed/
 
 * Patch last synced with upstream:
-  - Date: 2007-03-13
-  - File: http://www.spinnaker.de/mutt/compressed/patch-1.5.14.rr.compressed.1.gz
+  - Date: 2007-06-14
+  - File: http://www.spinnaker.de/mutt/compressed/patch-1.5.16.rr.compressed.1.gz
 
 * Changes made:
-  - filterdiff -p1 \
-    $(for f in Makefile.in config.h.in configure 'Muttrc*' doc/manual.txt \
-      doc/manual.sgml 'doc/manual*.html' doc/muttrc.man; do echo "-x $f"; done)
-  - 2007-03-13 myon: update for 1.5.14+tip (conflict in hook.c)
-  - 2007-03-20 myon: conflict in mx.c resolved (BUFFY_SIZE is gone)
+  - 2007-06-14 myon: remove hunks for Muttrc*
 
 == END PATCH
-Index: debian-mutt/compress.c
-===================================================================
---- /dev/null  1970-01-01 00:00:00.000000000 +0000
-+++ debian-mutt/compress.c     2007-03-21 21:28:21.000000000 +0100
+--- /dev/null
++++ b/compress.c
 @@ -0,0 +1,499 @@
 +/*
 + * Copyright (C) 1997 Alain Penders <Alain@Finale-Dev.com>
@@ -195,10 +189,10 @@ Index: debian-mutt/compress.c
 +}
 +
 +static const char *
-+compresshook_format_str (char *dest, size_t destlen, char op, const char *src,
-+                       const char *fmt, const char *ifstring,
-+                       const char *elsestring, unsigned long data,
-+                       format_flag flags)
++compresshook_format_str (char *dest, size_t destlen, size_t col, char op,
++                       const char *src, const char *fmt,
++                       const char *ifstring, const char *elsestring,
++                       unsigned long data, format_flag flags)
 +{
 +  char tmp[SHORT_STRING];
 +
@@ -229,8 +223,8 @@ Index: debian-mutt/compress.c
 +static char *get_compression_cmd (const char* cmd, const CONTEXT* ctx)
 +{
 +  char expanded[_POSIX_PATH_MAX];
-+  mutt_FormatString (expanded, sizeof (expanded), cmd, compresshook_format_str,
-+                   (unsigned long) ctx, 0);
++  mutt_FormatString (expanded, sizeof (expanded), 0, cmd, 
++                   compresshook_format_str, (unsigned long) ctx, 0);
 +  return safe_strdup (expanded);
 +}
 +
@@ -256,7 +250,7 @@ Index: debian-mutt/compress.c
 +  COMPRESS_INFO *ci = set_compress_info (ctx);
 +  if (!ci->open) {
 +    ctx->magic = 0;
-+    FREE (ctx->compressinfo);
++    FREE (&ctx->compressinfo);
 +    return (-1);
 +  }
 +  if (!ci->close || access (ctx->path, W_OK) != 0)
@@ -301,7 +295,7 @@ Index: debian-mutt/compress.c
 +  {
 +    mutt_any_key_to_continue (NULL);
 +    ctx->magic = 0;
-+    FREE (ctx->compressinfo);
++    FREE (&ctx->compressinfo);
 +    mutt_error (_("Error executing: %s : unable to open the mailbox!\n"), cmd);
 +  }
 +  FREE (&cmd);
@@ -522,10 +516,8 @@ Index: debian-mutt/compress.c
 +}
 +
 +#endif /* USE_COMPRESSED */
-Index: debian-mutt/compress.h
-===================================================================
---- /dev/null  1970-01-01 00:00:00.000000000 +0000
-+++ debian-mutt/compress.h     2007-03-21 21:28:21.000000000 +0100
+--- /dev/null
++++ b/compress.h
 @@ -0,0 +1,27 @@
 +/*
 + * Copyright (C) 1997 Alain Penders <Alain@Finale-Dev.com>
@@ -554,11 +546,9 @@ Index: debian-mutt/compress.h
 +int mutt_test_compress_command (const char *);
 +int mutt_check_mailbox_compressed (CONTEXT *);
 +void mutt_fast_close_compressed (CONTEXT *);
-Index: debian-mutt/configure.ac
-===================================================================
---- debian-mutt.orig/configure.ac      2007-03-21 21:25:18.000000000 +0100
-+++ debian-mutt/configure.ac   2007-03-21 21:28:21.000000000 +0100
-@@ -803,6 +803,11 @@ AC_ARG_ENABLE(locales-fix, AC_HELP_STRIN
+--- a/configure.ac
++++ b/configure.ac
+@@ -792,6 +792,11 @@ AC_ARG_ENABLE(locales-fix, AC_HELP_STRIN
                  AC_DEFINE(LOCALES_HACK,1,[ Define if the result of isprint() is unreliable. ])
          fi])
  
@@ -570,11 +560,9 @@ Index: debian-mutt/configure.ac
  AC_ARG_WITH(exec-shell, AC_HELP_STRING([--with-exec-shell=SHELL], [Specify alternate shell (ONLY if /bin/sh is broken)]),
          [if test $withval != yes; then
                  AC_DEFINE_UNQUOTED(EXECSHELL, "$withval",
-Index: debian-mutt/curs_main.c
-===================================================================
---- debian-mutt.orig/curs_main.c       2007-03-20 22:52:50.000000000 +0100
-+++ debian-mutt/curs_main.c    2007-03-21 21:28:21.000000000 +0100
-@@ -1090,6 +1090,11 @@ int mutt_index_menu (void)
+--- a/curs_main.c
++++ b/curs_main.c
+@@ -1131,6 +1131,11 @@ int mutt_index_menu (void)
          {
          int check;
  
@@ -586,11 +574,9 @@ Index: debian-mutt/curs_main.c
          mutt_str_replace (&LastFolder, Context->path);
          oldcount = Context ? Context->msgcount : 0;
  
-Index: debian-mutt/doc/manual.xml.head
-===================================================================
---- debian-mutt.orig/doc/manual.xml.head       2007-03-20 22:31:20.000000000 +0100
-+++ debian-mutt/doc/manual.xml.head    2007-03-21 21:28:21.000000000 +0100
-@@ -4910,6 +4910,205 @@ becomes an issue as mutt will silently f
+--- a/doc/manual.xml.head
++++ b/doc/manual.xml.head
+@@ -4676,6 +4676,205 @@ macro pager \cb |urlview\n
  
  </chapter>
  
@@ -796,10 +782,8 @@ Index: debian-mutt/doc/manual.xml.head
  <chapter id="mimesupport">
  <title>Mutt's MIME Support</title>
  
-Index: debian-mutt/doc/muttrc.man.head
-===================================================================
---- debian-mutt.orig/doc/muttrc.man.head       2007-03-20 22:31:20.000000000 +0100
-+++ debian-mutt/doc/muttrc.man.head    2007-03-21 21:28:21.000000000 +0100
+--- a/doc/muttrc.man.head
++++ b/doc/muttrc.man.head
 @@ -345,6 +345,24 @@ specify the ID of the public key to be u
  to a certain recipient.  The meaning of "key ID" is to be taken
  broadly: This can be a different e-mail address, a numerical key ID,
@@ -825,10 +809,8 @@ Index: debian-mutt/doc/muttrc.man.head
  .TP
  \fBpush\fP \fIstring\fP
  This command adds the named \fIstring\fP to the keyboard buffer.
-Index: debian-mutt/hook.c
-===================================================================
---- debian-mutt.orig/hook.c    2007-03-20 22:31:20.000000000 +0100
-+++ debian-mutt/hook.c 2007-03-21 21:28:21.000000000 +0100
+--- a/hook.c
++++ b/hook.c
 @@ -24,6 +24,10 @@
  #include "mailbox.h"
  #include "mutt_crypt.h"
@@ -849,7 +831,7 @@ Index: debian-mutt/hook.c
 +  {
 +    if (mutt_test_compress_command (command.data))
 +    {
-+      strfcpy (err->data, _("bad formatted command string"), err->dsize);
++      strfcpy (err->data, _("badly formatted command string"), err->dsize);
 +      return (-1);
 +    }
 +  }
@@ -857,11 +839,9 @@ Index: debian-mutt/hook.c
    else if (DefaultHook && !(data & (M_CHARSETHOOK | M_ICONVHOOK | M_ACCOUNTHOOK))
             && (!WithCrypto || !(data & M_CRYPTHOOK))
        )
-Index: debian-mutt/init.h
-===================================================================
---- debian-mutt.orig/init.h    2007-03-21 21:26:23.000000000 +0100
-+++ debian-mutt/init.h 2007-03-21 21:28:21.000000000 +0100
-@@ -3115,6 +3115,11 @@ struct command_t Commands[] = {
+--- a/init.h
++++ b/init.h
+@@ -3210,6 +3210,11 @@ struct command_t Commands[] = {
    { "fcc-hook",               mutt_parse_hook,        M_FCCHOOK },
    { "fcc-save-hook",  mutt_parse_hook,        M_FCCHOOK | M_SAVEHOOK },
    { "folder-hook",    mutt_parse_hook,        M_FOLDERHOOK },
@@ -873,11 +853,9 @@ Index: debian-mutt/init.h
    { "group",          parse_group,            0 },
    { "ungroup",                parse_ungroup,          0 },
    { "hdr_order",      parse_list,             UL &HeaderOrderList },
-Index: debian-mutt/main.c
-===================================================================
---- debian-mutt.orig/main.c    2007-03-20 22:52:50.000000000 +0100
-+++ debian-mutt/main.c 2007-03-21 21:28:21.000000000 +0100
-@@ -400,6 +400,12 @@ static void show_version (void)
+--- a/main.c
++++ b/main.c
+@@ -409,6 +409,12 @@ static void show_version (void)
  #else
        "-LOCALES_HACK  "
  #endif
@@ -890,10 +868,8 @@ Index: debian-mutt/main.c
              
  #ifdef HAVE_WC_FUNCS
        "+HAVE_WC_FUNCS  "
-Index: debian-mutt/Makefile.am
-===================================================================
---- debian-mutt.orig/Makefile.am       2007-03-21 21:25:18.000000000 +0100
-+++ debian-mutt/Makefile.am    2007-03-21 21:28:21.000000000 +0100
+--- a/Makefile.am
++++ b/Makefile.am
 @@ -18,7 +18,7 @@ BUILT_SOURCES = keymap_defs.h patchlist.
  bin_PROGRAMS = mutt @DOTLOCK_TARGET@ @PGPAUX_TARGET@
  mutt_SOURCES = $(BUILT_SOURCES) \
@@ -903,7 +879,7 @@ Index: debian-mutt/Makefile.am
        commands.c complete.c compose.c copy.c curs_lib.c curs_main.c date.c \
        edit.c enter.c flags.c init.c filter.c from.c \
        getdomain.c group.c \
-@@ -66,7 +66,7 @@ EXTRA_mutt_SOURCES = account.c md5c.c mu
+@@ -66,7 +66,7 @@ EXTRA_mutt_SOURCES = account.c md5.c mut
        utf8.c wcwidth.c 
  
  EXTRA_DIST = COPYRIGHT GPL OPS OPS.PGP OPS.CRYPT OPS.SMIME TODO UPDATING \
@@ -912,10 +888,8 @@ Index: debian-mutt/Makefile.am
        attach.h buffy.h charset.h copy.h crypthash.h dotlock.h functions.h gen_defs \
        globals.h hash.h history.h init.h keymap.h mutt_crypt.h \
        mailbox.h mapping.h md5.h mime.h mutt.h mutt_curses.h mutt_menu.h \
-Index: debian-mutt/mbox.c
-===================================================================
---- debian-mutt.orig/mbox.c    2007-03-20 22:31:20.000000000 +0100
-+++ debian-mutt/mbox.c 2007-03-21 21:28:21.000000000 +0100
+--- a/mbox.c
++++ b/mbox.c
 @@ -29,6 +29,10 @@
  #include "copy.h"
  #include "mutt_curses.h"
@@ -940,10 +914,8 @@ Index: debian-mutt/mbox.c
    mutt_unblock_signals ();
    mx_fastclose_mailbox (ctx);
    return 0;
-Index: debian-mutt/mutt.h
-===================================================================
---- debian-mutt.orig/mutt.h    2007-03-20 22:52:50.000000000 +0100
-+++ debian-mutt/mutt.h 2007-03-21 21:28:21.000000000 +0100
+--- a/mutt.h
++++ b/mutt.h
 @@ -160,6 +160,11 @@ typedef enum
  #define M_ACCOUNTHOOK (1<<9)
  #define M_REPLYHOOK   (1<<10)
@@ -956,9 +928,9 @@ Index: debian-mutt/mutt.h
  
  /* tree characters for linearize_tree and print_enriched_string */
  #define M_TREE_LLCORNER               1
-@@ -886,6 +891,11 @@ typedef struct
-   void *data;                 /* driver specific data */
#endif /* USE_IMAP */
+@@ -892,6 +897,11 @@ typedef struct _context
+   int flagged;                        /* how many flagged messages */
  int msgnotreadyet;          /* which msg "new" in pager, -1 if none */
  
 +#ifdef USE_COMPRESSED
 +  void *compressinfo;         /* compressed mbox module private data */
@@ -968,10 +940,8 @@ Index: debian-mutt/mutt.h
    short magic;                        /* mailbox type */
  
    unsigned char rights[(RIGHTSMAX + 7)/8];    /* ACL bits */
-Index: debian-mutt/mx.c
-===================================================================
---- debian-mutt.orig/mx.c      2007-03-21 21:25:18.000000000 +0100
-+++ debian-mutt/mx.c   2007-03-21 21:29:55.000000000 +0100
+--- a/mx.c
++++ b/mx.c
 @@ -30,6 +30,10 @@
  #include "keymap.h"
  #include "url.h"
@@ -983,7 +953,7 @@ Index: debian-mutt/mx.c
  #ifdef USE_IMAP
  #include "imap.h"
  #endif
-@@ -450,6 +454,10 @@ int mx_get_magic (const char *path)
+@@ -445,6 +449,10 @@ int mx_get_magic (const char *path)
      return (-1);
    }
  
@@ -994,7 +964,7 @@ Index: debian-mutt/mx.c
    return (magic);
  }
  
-@@ -489,6 +497,13 @@ static int mx_open_mailbox_append (CONTE
+@@ -484,6 +492,13 @@ static int mx_open_mailbox_append (CONTE
  {
    struct stat sb;
  
@@ -1008,7 +978,7 @@ Index: debian-mutt/mx.c
    ctx->append = 1;
  
  #ifdef USE_IMAP
-@@ -652,7 +667,12 @@ CONTEXT *mx_open_mailbox (const char *pa
+@@ -647,7 +662,12 @@ CONTEXT *mx_open_mailbox (const char *pa
    }
  
    ctx->magic = mx_get_magic (path);
@@ -1022,7 +992,7 @@ Index: debian-mutt/mx.c
    if(ctx->magic == 0)
      mutt_error (_("%s is not a mailbox."), path);
  
-@@ -758,6 +778,10 @@ void mx_fastclose_mailbox (CONTEXT *ctx)
+@@ -748,6 +768,10 @@ void mx_fastclose_mailbox (CONTEXT *ctx)
      mutt_free_header (&ctx->hdrs[i]);
    FREE (&ctx->hdrs);
    FREE (&ctx->v2r);
@@ -1033,7 +1003,7 @@ Index: debian-mutt/mx.c
    FREE (&ctx->path);
    FREE (&ctx->pattern);
    if (ctx->limit_pattern) 
-@@ -810,6 +834,12 @@ static int sync_mailbox (CONTEXT *ctx, i
+@@ -800,6 +824,12 @@ static int sync_mailbox (CONTEXT *ctx, i
    
    if (tmp && tmp->new == 0)
      mutt_update_mailbox (tmp);
@@ -1046,7 +1016,7 @@ Index: debian-mutt/mx.c
    return rc;
  }
  
-@@ -1011,6 +1041,11 @@ int mx_close_mailbox (CONTEXT *ctx, int 
+@@ -1058,6 +1088,11 @@ int mx_close_mailbox (CONTEXT *ctx, int 
        !mutt_is_spool(ctx->path) && !option (OPTSAVEEMPTY))
      mx_unlink_empty (ctx->path);
  
@@ -1058,7 +1028,7 @@ Index: debian-mutt/mx.c
    mx_fastclose_mailbox (ctx);
  
    return 0;
-@@ -1320,6 +1355,11 @@ int mx_check_mailbox (CONTEXT *ctx, int 
+@@ -1373,6 +1408,11 @@ int mx_check_mailbox (CONTEXT *ctx, int 
  {
    int rc;
  
@@ -1070,10 +1040,8 @@ Index: debian-mutt/mx.c
    if (ctx)
    {
      if (ctx->locked) lock = 0;
-Index: debian-mutt/mx.h
-===================================================================
---- debian-mutt.orig/mx.h      2007-03-20 22:31:20.000000000 +0100
-+++ debian-mutt/mx.h   2007-03-21 21:28:21.000000000 +0100
+--- a/mx.h
++++ b/mx.h
 @@ -40,6 +40,9 @@ enum
  #ifdef USE_POP
    , M_POP
@@ -1084,17 +1052,9 @@ Index: debian-mutt/mx.h
  };
  
  WHERE short DefaultMagic INITVAL (M_MBOX);
-Index: debian-mutt/PATCHES
-===================================================================
---- /dev/null  1970-01-01 00:00:00.000000000 +0000
-+++ debian-mutt/PATCHES        2007-03-21 21:28:21.000000000 +0100
-@@ -0,0 +1 @@
-+patch-1.5.14.rr.compressed.1
-Index: debian-mutt/po/de.po
-===================================================================
---- debian-mutt.orig/po/de.po  2007-03-20 22:31:20.000000000 +0100
-+++ debian-mutt/po/de.po       2007-03-21 21:28:21.000000000 +0100
-@@ -1266,6 +1266,48 @@ msgstr "Prüfung des Absenders fehlgeschl
+--- a/po/de.po
++++ b/po/de.po
+@@ -1279,6 +1279,48 @@ msgstr "Prüfung des Absenders fehlgeschl
  msgid "Failed to figure out sender"
  msgstr "Kann Absender nicht ermitteln"
  
@@ -1143,18 +1103,18 @@ Index: debian-mutt/po/de.po
  #: crypt.c:69
  #, c-format
  msgid " (current time: %c)"
-@@ -1926,6 +1968,10 @@ msgstr ""
- msgid "Help for %s"
- msgstr "Hilfe für %s"
+@@ -1948,6 +1990,10 @@ msgstr "Hilfe für %s"
+ msgid "Bad history file format (line %d)"
+ msgstr "Falsches Format der Datei früherer Eingaben (Zeile %d)"
  
 +#: hook.c:96
-+msgid "bad formatted command string"
++msgid "badly formatted command string"
 +msgstr "Hook enthält nicht die Muster %f und %t"
 +
- #: hook.c:246
+ #: hook.c:251
  #, c-format
  msgid "unhook: Can't do unhook * from within a hook."
-@@ -3428,18 +3474,10 @@ msgstr "Lese %s..."
+@@ -3463,18 +3509,10 @@ msgstr "Lese %s..."
  msgid "Mailbox is corrupt!"
  msgstr "Mailbox fehlerhaft!"
  
@@ -1173,10 +1133,8 @@ Index: debian-mutt/po/de.po
  #. this means ctx->changed or ctx->deleted was set, but no
  #. * messages were found to be changed or deleted.  This should
  #. * never happen, is we presume it is a bug in mutt.
-Index: debian-mutt/po/POTFILES.in
-===================================================================
---- debian-mutt.orig/po/POTFILES.in    2007-03-20 22:31:20.000000000 +0100
-+++ debian-mutt/po/POTFILES.in 2007-03-21 21:28:21.000000000 +0100
+--- a/po/POTFILES.in
++++ b/po/POTFILES.in
 @@ -8,6 +8,7 @@ charset.c
  color.c
  commands.c
@@ -1185,11 +1143,9 @@ Index: debian-mutt/po/POTFILES.in
  crypt-gpgme.c
  crypt.c
  cryptglue.c
-Index: debian-mutt/status.c
-===================================================================
---- debian-mutt.orig/status.c  2007-03-20 22:31:20.000000000 +0100
-+++ debian-mutt/status.c       2007-03-21 21:28:21.000000000 +0100
-@@ -97,6 +97,14 @@ status_format_str (char *buf, size_t buf
+--- a/status.c
++++ b/status.c
+@@ -99,6 +99,14 @@ status_format_str (char *buf, size_t buf
  
      case 'f':
        snprintf (fmt, sizeof(fmt), "%%%ss", prefix);