]> git.llucax.com Git - software/mutt-debian.git/blobdiff - debian/patches/features/trash-folder
upstream/544794-smtp-batch.patch: mutt won't ask for a password if smtp_user and...
[software/mutt-debian.git] / debian / patches / features / trash-folder
index 489672b17a363310ccf09c0634579bd1047e298e..b8711756f008dab38c9119f249f863242b45ccc8 100644 (file)
@@ -46,9 +46,11 @@ To sum up, it's more integrated and transparent to the user.
   - Fixed indentation of "appended" in mutt.h.
 
 == END PATCH
---- a/commands.c
-+++ b/commands.c
-@@ -688,6 +688,7 @@ int _mutt_save_message (HEADER *h, CONTE
+Index: mutt/commands.c
+===================================================================
+--- mutt.orig/commands.c       2009-06-25 12:35:37.000000000 +0200
++++ mutt/commands.c    2009-06-25 12:35:48.000000000 +0200
+@@ -716,6 +716,7 @@
      if (option (OPTDELETEUNTAG))
        mutt_set_flag (Context, h, M_TAG, 0);
    }
@@ -56,9 +58,11 @@ To sum up, it's more integrated and transparent to the user.
    
    return 0;
  }
---- a/flags.c
-+++ b/flags.c
-@@ -69,7 +69,13 @@ void _mutt_set_flag (CONTEXT *ctx, HEADE
+Index: mutt/flags.c
+===================================================================
+--- mutt.orig/flags.c  2009-06-25 12:35:37.000000000 +0200
++++ mutt/flags.c       2009-06-25 12:35:48.000000000 +0200
+@@ -65,7 +65,13 @@
        {
        h->deleted = 0;
          update = 1;
@@ -73,7 +77,7 @@ To sum up, it's more integrated and transparent to the user.
  #ifdef USE_IMAP
          /* see my comment above */
        if (ctx->magic == M_IMAP) 
-@@ -91,6 +97,17 @@ void _mutt_set_flag (CONTEXT *ctx, HEADE
+@@ -87,6 +93,17 @@
        }
        break;
  
@@ -91,9 +95,11 @@ To sum up, it's more integrated and transparent to the user.
      case M_NEW:
  
        if (!mutt_bit_isset(ctx->rights,M_ACL_SEEN))
---- a/globals.h
-+++ b/globals.h
-@@ -142,6 +142,7 @@ WHERE char *StChars;
+Index: mutt/globals.h
+===================================================================
+--- mutt.orig/globals.h        2009-06-25 12:35:44.000000000 +0200
++++ mutt/globals.h     2009-06-25 12:35:48.000000000 +0200
+@@ -139,6 +139,7 @@
  WHERE char *Status;
  WHERE char *Tempdir;
  WHERE char *Tochars;
@@ -101,9 +107,11 @@ To sum up, it's more integrated and transparent to the user.
  WHERE char *Username;
  WHERE char *Visual;
  WHERE char *XtermTitle;
---- a/imap/message.c
-+++ b/imap/message.c
-@@ -816,6 +816,7 @@ int imap_copy_messages (CONTEXT* ctx, HE
+Index: mutt/imap/message.c
+===================================================================
+--- mutt.orig/imap/message.c   2009-06-25 12:35:37.000000000 +0200
++++ mutt/imap/message.c        2009-06-25 12:35:48.000000000 +0200
+@@ -867,6 +867,7 @@
          if (ctx->hdrs[n]->tagged)
          {
            mutt_set_flag (ctx, ctx->hdrs[n], M_DELETE, 1);
@@ -111,7 +119,7 @@ To sum up, it's more integrated and transparent to the user.
            if (option (OPTDELETEUNTAG))
              mutt_set_flag (ctx, ctx->hdrs[n], M_TAG, 0);
          }
-@@ -823,6 +824,7 @@ int imap_copy_messages (CONTEXT* ctx, HE
+@@ -874,6 +875,7 @@
      else
      {
        mutt_set_flag (ctx, h, M_DELETE, 1);
@@ -119,11 +127,13 @@ To sum up, it's more integrated and transparent to the user.
        if (option (OPTDELETEUNTAG))
          mutt_set_flag (ctx, h, M_TAG, 0);
      }
---- a/init.h
-+++ b/init.h
-@@ -2881,6 +2881,16 @@ struct option_t MuttVars[] = {
+Index: mutt/init.h
+===================================================================
+--- mutt.orig/init.h   2009-06-25 12:35:44.000000000 +0200
++++ mutt/init.h        2009-06-25 12:35:48.000000000 +0200
+@@ -3180,6 +3180,16 @@
    ** by \fIyou\fP.  The sixth character is used to indicate when a mail
-   ** was sent to a mailing-list you subscribe to (default: L).
+   ** was sent to a mailing-list you subscribe to.
    */
 +  { "trash",          DT_PATH, R_NONE, UL &TrashPath, 0 },
 +  /*
@@ -138,9 +148,11 @@ To sum up, it's more integrated and transparent to the user.
  #ifdef USE_SOCKET
    { "tunnel",            DT_STR, R_NONE, UL &Tunnel, UL 0 },
    /*
---- a/mutt.h
-+++ b/mutt.h
-@@ -201,6 +201,7 @@ enum
+Index: mutt/mutt.h
+===================================================================
+--- mutt.orig/mutt.h   2009-06-25 12:35:44.000000000 +0200
++++ mutt/mutt.h        2009-06-25 12:35:48.000000000 +0200
+@@ -187,6 +187,7 @@
    M_DELETE,
    M_UNDELETE,
    M_DELETED,
@@ -148,7 +160,7 @@ To sum up, it's more integrated and transparent to the user.
    M_FLAG,
    M_TAG,
    M_UNTAG,
-@@ -712,6 +713,7 @@ typedef struct header
+@@ -702,6 +703,7 @@
    unsigned int mime : 1;              /* has a MIME-Version header? */
    unsigned int flagged : 1;           /* marked important? */
    unsigned int tagged : 1;
@@ -156,7 +168,7 @@ To sum up, it's more integrated and transparent to the user.
    unsigned int deleted : 1;
    unsigned int changed : 1;
    unsigned int attach_del : 1;                /* has an attachment marked for deletion */
-@@ -883,6 +885,7 @@ typedef struct _context
+@@ -874,6 +876,7 @@
    int new;                    /* how many new messages? */
    int unread;                 /* how many unread messages? */
    int deleted;                        /* how many deleted messages */
@@ -164,9 +176,11 @@ To sum up, it's more integrated and transparent to the user.
    int flagged;                        /* how many flagged messages */
    int msgnotreadyet;          /* which msg "new" in pager, -1 if none */
  
---- a/muttlib.c
-+++ b/muttlib.c
-@@ -1430,7 +1430,9 @@ int mutt_save_confirm (const char *s, st
+Index: mutt/muttlib.c
+===================================================================
+--- mutt.orig/muttlib.c        2009-06-25 12:35:37.000000000 +0200
++++ mutt/muttlib.c     2009-06-25 12:35:48.000000000 +0200
+@@ -1460,7 +1460,9 @@
  
    if (magic > 0 && !mx_access (s, W_OK))
    {
@@ -177,9 +191,11 @@ To sum up, it's more integrated and transparent to the user.
      {
        snprintf (tmp, sizeof (tmp), _("Append messages to %s?"), s);
        if ((rc = mutt_yesorno (tmp, M_YES)) == M_NO)
---- a/mx.c
-+++ b/mx.c
-@@ -803,6 +803,53 @@ static int sync_mailbox (CONTEXT *ctx, i
+Index: mutt/mx.c
+===================================================================
+--- mutt.orig/mx.c     2009-06-25 12:35:37.000000000 +0200
++++ mutt/mx.c  2009-06-25 12:35:48.000000000 +0200
+@@ -773,6 +773,53 @@
    return rc;
  }
  
@@ -233,7 +249,7 @@ To sum up, it's more integrated and transparent to the user.
  /* save changes and close mailbox */
  int mx_close_mailbox (CONTEXT *ctx, int *index_hint)
  {
-@@ -938,6 +985,7 @@ int mx_close_mailbox (CONTEXT *ctx, int 
+@@ -909,6 +956,7 @@
          if (mutt_append_message (&f, ctx, ctx->hdrs[i], 0, CH_UPDATE_LEN) == 0)
          {
            mutt_set_flag (ctx, ctx->hdrs[i], M_DELETE, 1);
@@ -241,12 +257,12 @@ To sum up, it's more integrated and transparent to the user.
          }
          else
          {
-@@ -959,6 +1007,14 @@ int mx_close_mailbox (CONTEXT *ctx, int 
+@@ -931,6 +979,14 @@
      return 0;
    }
    
 +  /* copy mails to the trash before expunging */
-+  if (purge && ctx->deleted)
++  if (purge && ctx->deleted && mutt_strcmp(ctx->path, TrashPath))
 +    if (trash_append (ctx) != 0)
 +    {
 +      ctx->closing = 0;
@@ -256,22 +272,24 @@ To sum up, it's more integrated and transparent to the user.
  #ifdef USE_IMAP
    /* allow IMAP to preserve the deleted flag across sessions */
    if (ctx->magic == M_IMAP)
-@@ -1154,6 +1210,12 @@ int mx_sync_mailbox (CONTEXT *ctx, int *
+@@ -1130,6 +1186,12 @@
    msgcount = ctx->msgcount;
    deleted = ctx->deleted;
  
-+  if (purge && ctx->deleted)
++  if (purge && ctx->deleted && mutt_strcmp(ctx->path, TrashPath))
 +  {
 +    if (trash_append (ctx) == -1)
 +      return -1;
-+  } 
++  }
 +
  #ifdef USE_IMAP
    if (ctx->magic == M_IMAP)
      rc = imap_sync_mailbox (ctx, purge, index_hint);
---- a/postpone.c
-+++ b/postpone.c
-@@ -279,6 +279,9 @@ int mutt_get_postponed (CONTEXT *ctx, HE
+Index: mutt/postpone.c
+===================================================================
+--- mutt.orig/postpone.c       2009-06-25 12:35:37.000000000 +0200
++++ mutt/postpone.c    2009-06-25 12:35:48.000000000 +0200
+@@ -276,6 +276,9 @@
    /* finished with this message, so delete it. */
    mutt_set_flag (PostContext, h, M_DELETE, 1);
  
@@ -281,9 +299,3 @@ To sum up, it's more integrated and transparent to the user.
    /* update the count for the status display */
    PostCount = PostContext->msgcount - PostContext->deleted;
  
---- a/PATCHES
-+++ b/PATCHES
-@@ -1,2 +1,3 @@
-+patch-1.5.13.cd.trash_folder.3.4
- patch-1.5.13.nt+ab.xtitles.4
- patch-1.5.13.cd.ifdef.2