http://www.spinnaker.de/mutt/compressed/
* Patch last synced with upstream:
- - Date: 2007-06-14
- - File: http://www.spinnaker.de/mutt/compressed/patch-1.5.16.rr.compressed.1.gz
+ - Date: 2008-05-20
+ - File: http://www.spinnaker.de/mutt/compressed/patch-1.5.18.rr.compressed.1.gz
* Changes made:
- - 2007-06-14 myon: remove hunks for Muttrc*
+ - 2008-05-20 myon: refreshed to remove hunks in auto* files
+ - 2009-09-15 myon: refreshed for mutt-1.5.19
+ status.c:103: add sizeof (tmp) to mutt_pretty_mailbox
+ - 2009-09-15 scotton: removed doc/Muttrc for mutt-1.5.19 (only patch doc/Muttrc.head)
+ - 2009-09-11 antonio: removed DefaultMagic, see 541360
+ - 2010-05-31 myon: remove commented paragraph "Use folders..." in
+ doc/Muttrc.head, see #578096
== END PATCH
--- /dev/null
+++ b/compress.c
-@@ -0,0 +1,499 @@
+@@ -0,0 +1,496 @@
+/*
+ * Copyright (C) 1997 Alain Penders <Alain@Finale-Dev.com>
+ *
+ ctx->realpath = ctx->path;
+
+ /* Uncompress to /tmp */
-+ mutt_mktemp (tmppath);
++ mutt_mktemp (tmppath, sizeof(tmppath));
+ ctx->path = safe_malloc (strlen (tmppath) + 1);
+ strcpy (ctx->path, tmppath);
+}
+static char *get_compression_cmd (const char* cmd, const CONTEXT* ctx)
+{
+ char expanded[_POSIX_PATH_MAX];
-+ mutt_FormatString (expanded, sizeof (expanded), 0, cmd,
++ mutt_FormatString (expanded, sizeof (expanded), 0, cmd,
+ compresshook_format_str, (unsigned long) ctx, 0);
+ return safe_strdup (expanded);
+}
+
+ set_path (ctx);
+
-+ ctx->magic = DefaultMagic;
-+
+ if (!is_new (ctx->realpath))
-+ if (ctx->magic == M_MBOX || ctx->magic == M_MMDF)
+ if ((fh = fopen (ctx->path, "w")))
+ fclose (fh);
+ /* No error checking - the parent function will catch it */
+ fclose (ctx->fp);
+ ctx->fp = NULL;
+ /* if the folder was removed, remove the gzipped folder too */
-+ if ((ctx->magic > 0)
-+ && (access (ctx->path, F_OK) != 0)
++ if ((ctx->magic > 0)
++ && (access (ctx->path, F_OK) != 0)
+ && ! option (OPTSAVEEMPTY))
+ remove (ctx->realpath);
+ else
+ if (! (ctx->append
+ && ((append = get_append_command (ctx->realpath, ctx))
+ || (append = ci->close))))
-+ {
++ {
+ /* if we can not or should not append, we only have to remove the */
+ /* compressed info, because sync was already called */
+ mutt_fast_close_compressed (ctx);
+void mutt_fast_close_compressed (CONTEXT *);
--- a/configure.ac
+++ b/configure.ac
-@@ -791,6 +791,11 @@ AC_ARG_ENABLE(locales-fix, AC_HELP_STRIN
+@@ -812,6 +812,11 @@
AC_DEFINE(LOCALES_HACK,1,[ Define if the result of isprint() is unreliable. ])
fi])
AC_DEFINE_UNQUOTED(EXECSHELL, "$withval",
--- a/curs_main.c
+++ b/curs_main.c
-@@ -1131,6 +1131,11 @@ int mutt_index_menu (void)
+@@ -1153,6 +1153,11 @@
{
int check;
--- a/doc/manual.xml.head
+++ b/doc/manual.xml.head
-@@ -5010,6 +5010,205 @@ becomes an issue as mutt will silently f
+@@ -6116,6 +6116,205 @@
</chapter>
+For example:
+
+<screen>
-+open-hook \\.gz$ "gzip -cd %f > %t"
++open-hook \\.gz$ "gzip -cd %f > %t"
+close-hook \\.gz$ "gzip -c %t > %f"
-+append-hook \\.gz$ "gzip -c %t >> %f"
++append-hook \\.gz$ "gzip -c %t >> %f"
+</screen>
+
+You do not have to specify all of the commands. If you omit <link
+Example:
+
+<screen>
-+open-hook \\.gz$ "gzip -cd %f > %t"
++open-hook \\.gz$ "gzip -cd %f > %t"
+</screen>
+
+If the <emphasis>command</emphasis> is empty, this operation is
+Example:
+
+<screen>
-+append-hook \\.gz$ "gzip -c %t >> %f"
++append-hook \\.gz$ "gzip -c %t >> %f"
+</screen>
+
+When <link linkend="append-hook">append-hook</link> is used, the folder
--- a/doc/muttrc.man.head
+++ b/doc/muttrc.man.head
-@@ -345,6 +345,24 @@ specify the ID of the public key to be u
+@@ -346,6 +346,24 @@
to a certain recipient. The meaning of "key ID" is to be taken
broadly: This can be a different e-mail address, a numerical key ID,
or even just an arbitrary search string.
+"\fI\\\\.gz$\fP"). The commands tell Mutt how to uncompress a folder
+(\fBopen-hook\fP), compress a folder (\fBclose-hook\fP) or append a
+compressed mail to a compressed folder (\fBappend-hook\fP). The
-+\fIcommand\fP string is the
++\fIcommand\fP string is the
+.BR printf (3)
+like format string, and it should accept two parameters: \fB%f\fP,
+which is replaced with the (compressed) folder name, and \fB%t\fP
#include <limits.h>
#include <string.h>
#include <stdlib.h>
-@@ -92,6 +96,16 @@ int mutt_parse_hook (BUFFER *buf, BUFFER
+@@ -92,6 +96,16 @@
memset (&pattern, 0, sizeof (pattern));
pattern.data = safe_strdup (path);
}
)
--- a/init.h
+++ b/init.h
-@@ -3193,6 +3193,11 @@ struct command_t Commands[] = {
+@@ -3530,6 +3530,11 @@
{ "fcc-hook", mutt_parse_hook, M_FCCHOOK },
{ "fcc-save-hook", mutt_parse_hook, M_FCCHOOK | M_SAVEHOOK },
{ "folder-hook", mutt_parse_hook, M_FOLDERHOOK },
+ { "close-hook", mutt_parse_hook, M_CLOSEHOOK },
+ { "append-hook", mutt_parse_hook, M_APPENDHOOK },
+#endif
- { "group", parse_group, 0 },
- { "ungroup", parse_ungroup, 0 },
+ { "group", parse_group, M_GROUP },
+ { "ungroup", parse_group, M_UNGROUP },
{ "hdr_order", parse_list, UL &HeaderOrderList },
--- a/main.c
+++ b/main.c
-@@ -401,6 +401,12 @@ static void show_version (void)
+@@ -401,6 +401,12 @@
#else
"-LOCALES_HACK "
#endif
"+HAVE_WC_FUNCS "
--- a/Makefile.am
+++ b/Makefile.am
-@@ -18,7 +18,7 @@ BUILT_SOURCES = keymap_defs.h patchlist.
+@@ -22,7 +22,7 @@
bin_PROGRAMS = mutt @DOTLOCK_TARGET@ @PGPAUX_TARGET@
- mutt_SOURCES = $(BUILT_SOURCES) \
+ mutt_SOURCES = \
addrbook.c alias.c attach.c base64.c browser.c buffy.c color.c \
- crypt.c cryptglue.c \
+ crypt.c cryptglue.c compress.c \
commands.c complete.c compose.c copy.c curs_lib.c curs_main.c date.c \
edit.c enter.c flags.c init.c filter.c from.c \
getdomain.c group.c \
-@@ -66,7 +66,7 @@ EXTRA_mutt_SOURCES = account.c md5.c mut
- utf8.c wcwidth.c
+@@ -61,7 +61,7 @@
+ bcache.h browser.h hcache.h mbyte.h mutt_idna.h remailer.h url.h
EXTRA_DIST = COPYRIGHT GPL OPS OPS.PGP OPS.CRYPT OPS.SMIME TODO UPDATING \
- configure account.h \
#include <sys/stat.h>
#include <dirent.h>
#include <string.h>
-@@ -1026,6 +1030,12 @@ bail: /* Come here in case of disaster
+@@ -1070,6 +1074,12 @@
int mbox_close_mailbox (CONTEXT *ctx)
{
mx_unlock_file (ctx->path, fileno (ctx->fp), 1);
return 0;
--- a/mutt.h
+++ b/mutt.h
-@@ -160,6 +160,11 @@ typedef enum
+@@ -146,6 +146,11 @@
#define M_ACCOUNTHOOK (1<<9)
#define M_REPLYHOOK (1<<10)
#define M_SEND2HOOK (1<<11)
/* tree characters for linearize_tree and print_enriched_string */
#define M_TREE_LLCORNER 1
-@@ -891,6 +896,11 @@ typedef struct _context
+@@ -887,6 +892,11 @@
int flagged; /* how many flagged messages */
int msgnotreadyet; /* which msg "new" in pager, -1 if none */
#ifdef USE_IMAP
#include "imap.h"
#endif
-@@ -445,6 +449,10 @@ int mx_get_magic (const char *path)
+@@ -414,6 +418,10 @@
return (-1);
}
return (magic);
}
-@@ -484,6 +492,13 @@ static int mx_open_mailbox_append (CONTE
+@@ -453,6 +461,13 @@
{
struct stat sb;
ctx->append = 1;
#ifdef USE_IMAP
-@@ -647,7 +662,12 @@ CONTEXT *mx_open_mailbox (const char *pa
+@@ -616,7 +631,12 @@
}
ctx->magic = mx_get_magic (path);
if(ctx->magic == 0)
mutt_error (_("%s is not a mailbox."), path);
-@@ -748,6 +768,10 @@ void mx_fastclose_mailbox (CONTEXT *ctx)
+@@ -721,6 +741,10 @@
mutt_free_header (&ctx->hdrs[i]);
FREE (&ctx->hdrs);
FREE (&ctx->v2r);
FREE (&ctx->path);
FREE (&ctx->pattern);
if (ctx->limit_pattern)
-@@ -800,6 +824,12 @@ static int sync_mailbox (CONTEXT *ctx, i
+@@ -773,6 +797,12 @@
if (tmp && tmp->new == 0)
mutt_update_mailbox (tmp);
return rc;
}
-@@ -1058,6 +1088,11 @@ int mx_close_mailbox (CONTEXT *ctx, int
+@@ -1043,6 +1073,11 @@
!mutt_is_spool(ctx->path) && !option (OPTSAVEEMPTY))
mx_unlink_empty (ctx->path);
mx_fastclose_mailbox (ctx);
return 0;
-@@ -1373,6 +1408,11 @@ int mx_check_mailbox (CONTEXT *ctx, int
+@@ -1361,6 +1396,11 @@
{
int rc;
if (ctx->locked) lock = 0;
--- a/mx.h
+++ b/mx.h
-@@ -40,6 +40,9 @@ enum
- #ifdef USE_POP
- , M_POP
- #endif
+@@ -36,6 +36,9 @@
+ M_MAILDIR,
+ M_IMAP,
+ M_POP
+#ifdef USE_COMPRESSED
+ , M_COMPRESSED
+#endif
};
WHERE short DefaultMagic INITVAL (M_MBOX);
---- a/PATCHES
-+++ b/PATCHES
-@@ -4,3 +4,4 @@ patch-1.5.13.cd.purge_message.3.4
- patch-1.5.13.nt+ab.xtitles.4
- patch-1.5.13.cd.ifdef.2
- patch-1.5.8.hr.sensible_browser_position.3
-+patch-1.5.16.rr.compressed.1
+--- a/po/POTFILES.in
++++ b/po/POTFILES.in
+@@ -8,6 +8,7 @@
+ color.c
+ commands.c
+ compose.c
++compress.c
+ crypt-gpgme.c
+ crypt.c
+ cryptglue.c
+--- a/status.c
++++ b/status.c
+@@ -96,6 +96,14 @@
+
+ case 'f':
+ snprintf (fmt, sizeof(fmt), "%%%ss", prefix);
++#ifdef USE_COMPRESSED
++ if (Context && Context->compressinfo && Context->realpath)
++ {
++ strfcpy (tmp, Context->realpath, sizeof (tmp));
++ mutt_pretty_mailbox (tmp, sizeof (tmp));
++ }
++ else
++#endif
+ if (Context && Context->path)
+ {
+ strfcpy (tmp, Context->path, sizeof (tmp));
--- a/po/de.po
+++ b/po/de.po
-@@ -3,7 +3,7 @@ msgstr ""
- "Project-Id-Version: 1.5.16\n"
- "Report-Msgid-Bugs-To: \n"
- "POT-Creation-Date: 2007-06-09 20:30-0700\n"
--"PO-Revision-Date: 2007-06-10 17:18+0200\n"
-+"PO-Revision-Date: 2007-09-08 22:04+0200\n"
- "Last-Translator: Roland Rosenfeld <roland@spinnaker.de>\n"
- "Language-Team: German <mutt-po@mutt.org>\n"
- "MIME-Version: 1.0\n"
-@@ -1279,6 +1279,48 @@ msgstr "Prüfung des Absenders fehlgeschl
- msgid "Failed to figure out sender"
- msgstr "Kann Absender nicht ermitteln"
+@@ -5159,6 +5159,36 @@
+ msgid "show S/MIME options"
+ msgstr "Zeige S/MIME Optionen"
-+#: compress.c:203 mbox.c:661
-+msgid "Mailbox was corrupted!"
-+msgstr "Mailbox wurde zerstört!"
+
+#: compress.c:228 compress.c:253
+#, c-format
+msgid "Decompressing %s...\n"
+msgstr "Entpacke %s...\n"
+
-+#: compress.c:246 compress.c:367 compress.c:443 mbox.c:706
-+msgid "Unable to lock mailbox!"
-+msgstr "Kann Mailbox nicht für exklusiven Zugriff sperren!"
-+
-+#: compress.c:264
-+#, c-format
-+msgid "Error executing: %s : unable to open the mailbox!\n"
-+msgstr "Fehler beim Ausführen von %s : Kann die Mailbox nicht öffnen!\n"
-+
+#: compress.c:350 compress.c:377 compress.c:423 compress.c:454
+#, c-format
+msgid "Compressing %s...\n"
+msgid " %s: Error compressing mailbox! Uncompressed one kept!\n"
+msgstr " %s: Fehler beim packen der Mailbox! Entpackte Mailbox gespeichert!\n"
+
- #: crypt.c:69
- #, c-format
- msgid " (current time: %c)"
-@@ -1948,6 +1990,10 @@ msgstr "Hilfe für %s"
- msgid "Bad history file format (line %d)"
- msgstr "Falsches Format der Datei früherer Eingaben (Zeile %d)"
-
-+#: hook.c:96
-+msgid "badly formatted command string"
-+msgstr "Hook enthält nicht die Muster %f und %t"
-+
- #: hook.c:251
- #, c-format
- msgid "unhook: Can't do unhook * from within a hook."
-@@ -3452,18 +3498,10 @@ msgstr "Lese %s..."
- msgid "Mailbox is corrupt!"
- msgstr "Mailbox fehlerhaft!"
-
--#: mbox.c:670
--msgid "Mailbox was corrupted!"
--msgstr "Mailbox wurde zerstört!"
--
- #: mbox.c:711 mbox.c:964
- msgid "Fatal error! Could not reopen mailbox!"
- msgstr "Fataler Fehler, konnte Mailbox nicht erneut öffnen!"
-
--#: mbox.c:720
--msgid "Unable to lock mailbox!"
--msgstr "Kann Mailbox nicht für exklusiven Zugriff sperren!"
--
- #. this means ctx->changed or ctx->deleted was set, but no
- #. * messages were found to be changed or deleted. This should
- #. * never happen, is we presume it is a bug in mutt.
---- a/po/POTFILES.in
-+++ b/po/POTFILES.in
-@@ -8,6 +8,7 @@ charset.c
- color.c
- commands.c
- compose.c
-+compress.c
- crypt-gpgme.c
- crypt.c
- cryptglue.c
---- a/status.c
-+++ b/status.c
-@@ -99,6 +99,14 @@ status_format_str (char *buf, size_t buf
+ #~ msgid "Clear"
+ #~ msgstr "Klartext"
- case 'f':
- snprintf (fmt, sizeof(fmt), "%%%ss", prefix);
-+#ifdef USE_COMPRESSED
-+ if (Context && Context->compressinfo && Context->realpath)
-+ {
-+ strfcpy (tmp, Context->realpath, sizeof (tmp));
-+ mutt_pretty_mailbox (tmp);
-+ }
-+ else
-+#endif
- if (Context && Context->path)
- {
- strfcpy (tmp, Context->path, sizeof (tmp));