--enable-debug \
--enable-fcntl \
--enable-hcache \
+ --enable-gpgme \
--enable-imap \
+ --enable-smtp \
--enable-inodesort \
--enable-pop \
\
env LC_COLLATE=C sort PATCHES.unsorted >PATCHES
# do not rebuild these files
- touch configure.in aclocal.m4 Makefile.in configure stamp-h.in config.h.in
+ touch configure.in aclocal.m4 Makefile.in configure config.h.in
-mkdir $(objdir)
cd $(objdir) && \
build: $(objdir)/build-stamp
$(objdir)/build-stamp: $(objdir)/configure-stamp
cd $(objdir) && \
- $(MAKE)
+ $(MAKE) CFLAGS="$(CFLAGS)"
touch $@
# quilt cruft
rm -f patches
rm -rf .pc
+ touch PATCHES
# please dpkg-source
rm -f po/*.gmo
chmod +x debian/header.awk
debian/header.awk debian/patches/features/* >debian/tmp/README.Patches
- cp $(objdir)/Muttrc.head debian/tmp/Muttrc
- echo "# GnuPG configuration" >>debian/tmp/Muttrc
- grep '^set' contrib/gpg.rc \
- | sed -e 's#pgpewrap#/usr/lib/mutt/pgpewrap#' \
- | sed -e 's#/usr/bin/gpg#gpg#' \
- >> debian/tmp/Muttrc
- cat debian/extra/rc/* >>debian/tmp/Muttrc
+ ( cat $(objdir)/Muttrc.head; \
+ echo "# GnuPG configuration"; \
+ grep '^set' contrib/gpg.rc; \
+ echo; \
+ cat debian/extra/rc/* ) > debian/tmp/Muttrc
touch $@
dh_testdir
dh_testroot
+ dh_installdirs
dh_install
dh_installman
- dh_installmime
dh_installmenu
dh_installdocs
dh_installexamples