#!/usr/bin/make -f
include /usr/share/quilt/quilt.make
+QUILT = QUILT_PATCHES=$(QUILT_PATCH_DIR) quilt --quiltrc /dev/null
###################### user serviceable parts ######################
###
# build a separate mutt-patched package?
-#BUILD_PATCHED := yes -- disabled until there is a sidebar patch for 1.5.19
+BUILD_PATCHED := yes
###
# header cache backend
# HCACHE_DB := bdb
-HCACHE_DB := gdbm
+# HCACHE_DB := gdbm
# HCACHE_DB := qdbm
+HCACHE_DB := tokyocabinet
###
# GPGME backend
-# GPGME := --enable-gpgme
+GPGME := --enable-gpgme
###
###################### variables ######################
# Configure arguments
ifeq ($(HCACHE_DB),bdb)
- hcache_db := --without-gdbm --without-qdbm
+ hcache_db := --without-gdbm --without-qdbm --without-tokyocabinet
endif
ifeq ($(HCACHE_DB),gdbm)
- hcache_db := --without-qdbm --without-bdb
+ hcache_db := --without-qdbm --without-bdb --without-tokyocabinet
endif
ifeq ($(HCACHE_DB),qdbm)
- hcache_db := --without-gdbm --without-bdb
+ hcache_db := --without-gdbm --without-bdb --without-tokyocabinet
+endif
+ifeq ($(HCACHE_DB),tokyocabinet)
+ hcache_db := --without-gdbm --without-bdb --without-qdbm
endif
confflags = --prefix=/usr \
ifeq ($(BUILD_PATCHED),yes)
###################### building mutt-patched ######################
+ $(QUILT) applied > PATCHES
autoreconf --install --include=m4
cd $(objdir)-patched && \
env CFLAGS="$(CFLAGS)" CPPFLAGS="$(CPPFLAGS)" \
build build-arch: $(objdir)/build-stamp
$(objdir)/build-stamp: $(objdir)-patched/build-stamp
###################### building mutt ######################
- QUILT_PATCHES=$(QUILT_PATCH_DIR) quilt --quiltrc /dev/null pop mutt.org
+ $(QUILT) pop mutt.org
+ $(QUILT) applied > PATCHES
autoreconf --install --include=m4
-mkdir $(objdir)
###################### install ######################
dh_testdir
dh_testroot
- dh_clean -k
+ dh_prep
cd $(objdir) && $(MAKE) install DESTDIR=$(CURDIR)/debian/tmp
cd debian/tmp/usr/share/doc && \
rm -rf samples/iconv samples/ca-bundle.crt && \
mv NEWS NEWS.old && \
- mv ChangeLog.old changelog.old && \
cp $(CURDIR)/UPDATING NEWS
chmod +x debian/extra/lib/*
# please dpkg-source
rm -f po/*.gmo
- touch PATCHES
+ echo -n > PATCHES
# remove build trees
rm -rf $(objdir) $(objdir)-patched
rm -f configure config.h.in
rm -f Makefile.in contrib/Makefile.in imap/Makefile.in doc/Makefile.in m4/Makefile.in
- # clean PATCHES hunks (blame quilt refresh)
- for p in `grep -rl PATCHES debian/patches` ; do perl -wi debian/fix-PATCHES.pl $$p ; done
-
dh_clean
.PHONY: configure build build-arch build-indep clean install binary binary-arch binary-indep patch