]> git.llucax.com Git - software/mutt-debian.git/blobdiff - debian/rules
uploading to experimental
[software/mutt-debian.git] / debian / rules
index 84363f3db77169d81ea9ee708cc8541718232691..4dc943c94f646fb3a168377fd4a1647eeda3da59 100755 (executable)
@@ -1,20 +1,22 @@
 #!/usr/bin/make -f
 
 include /usr/share/quilt/quilt.make
+QUILT = QUILT_PATCHES=$(QUILT_PATCH_DIR) quilt --quiltrc /dev/null
 
 ###################### user serviceable parts ######################
 
 ###
 # build a separate mutt-patched package?
-#BUILD_PATCHED := yes -- disabled until there is a sidebar patch for 1.5.19
+BUILD_PATCHED := yes
 ###
 # header cache backend
 # HCACHE_DB := bdb
-HCACHE_DB := gdbm
+HCACHE_DB := gdbm
 # HCACHE_DB := qdbm
+HCACHE_DB := tokyocabinet
 ###
 # GPGME backend
-GPGME := --enable-gpgme
+GPGME := --enable-gpgme
 ###
 
 ###################### variables ######################
@@ -26,13 +28,19 @@ endif
 # Configure arguments
 
 ifeq ($(HCACHE_DB),bdb)
-    hcache_db := --without-gdbm --without-qdbm
+    hcache_db := --without-gdbm --without-qdbm --without-tokyocabinet
 endif
 ifeq ($(HCACHE_DB),gdbm)
-    hcache_db := --without-qdbm --without-bdb
+    hcache_db := --without-qdbm --without-bdb --without-tokyocabinet
 endif
 ifeq ($(HCACHE_DB),qdbm)
-    hcache_db := --without-gdbm --without-bdb
+    hcache_db := --without-gdbm --without-bdb --without-tokyocabinet
+endif
+ifeq ($(HCACHE_DB),tokyocabinet)
+    hcache_db := --without-gdbm --without-bdb --without-qdbm
+    ifeq ($(shell dpkg --print-architecture),hurd-i386)
+       hcache_db := --without-bdb --without-qdbm
+    endif
 endif
 
 confflags =    --prefix=/usr                   \
@@ -92,6 +100,7 @@ $(objdir)-patched/build-stamp: $(QUILT_STAMPFN)
        
 ifeq ($(BUILD_PATCHED),yes)
        ###################### building mutt-patched ######################
+       $(QUILT) applied > PATCHES
        autoreconf --install --include=m4
        cd $(objdir)-patched && \
        env CFLAGS="$(CFLAGS)" CPPFLAGS="$(CPPFLAGS)" \
@@ -108,7 +117,8 @@ endif
 build build-arch: $(objdir)/build-stamp
 $(objdir)/build-stamp: $(objdir)-patched/build-stamp
        ###################### building mutt ######################
-       QUILT_PATCHES=$(QUILT_PATCH_DIR) quilt --quiltrc /dev/null pop mutt.org
+       $(QUILT) pop mutt.org
+       $(QUILT) applied > PATCHES
        
        autoreconf --install --include=m4
        -mkdir $(objdir)
@@ -126,13 +136,12 @@ install: build
        ###################### install ######################
        dh_testdir
        dh_testroot
-       dh_clean -k
+       dh_prep
        cd $(objdir) && $(MAKE) install DESTDIR=$(CURDIR)/debian/tmp
        
        cd debian/tmp/usr/share/doc && \
        rm -rf samples/iconv samples/ca-bundle.crt && \
        mv NEWS NEWS.old && \
-       mv ChangeLog.old changelog.old && \
        cp $(CURDIR)/UPDATING NEWS
        
        chmod +x debian/extra/lib/*
@@ -147,8 +156,11 @@ install: build
          grep '^set' contrib/gpg.rc; \
          echo ) > debian/tmp/gpg.rc
        
+       dh_install
+       
+       # prepare files for update-alternatives
+       mv debian/mutt/usr/bin/mutt debian/mutt/usr/bin/mutt-org
 ifeq ($(BUILD_PATCHED),yes)
-       # temporarily call the binary mutt-patched so dh_strip gets the debug file name right
        install -D $(objdir)-patched/mutt debian/mutt-patched/usr/bin/mutt-patched
 endif
        
@@ -159,7 +171,6 @@ endif
 
 binary binary-arch: install
        ###################### binary ######################
-       dh_install
        dh_installman
        dh_installmenu
        dh_installmime
@@ -171,9 +182,6 @@ binary binary-arch: install
        dh_strip --dbg-package=mutt-dbg
        rm -rf $(CURDIR)/debian/mutt-dbg/usr/share/doc/mutt-dbg \
                $(CURDIR)/debian/mutt-patched/usr/share/doc/mutt-patched
-ifeq ($(BUILD_PATCHED),yes)
-       mv debian/mutt-patched/usr/bin/mutt-patched debian/mutt-patched/usr/bin/mutt
-endif
        
        dh_link
        dh_compress --exclude usr/share/doc/mutt/README.Patches
@@ -194,7 +202,7 @@ clean: unpatch
        
        # please dpkg-source
        rm -f po/*.gmo
-       touch PATCHES
+       echo -n > PATCHES
        
        # remove build trees
        rm -rf $(objdir) $(objdir)-patched
@@ -203,9 +211,6 @@ clean: unpatch
        rm -f configure config.h.in
        rm -f Makefile.in contrib/Makefile.in imap/Makefile.in doc/Makefile.in m4/Makefile.in
        
-       # clean PATCHES hunks (blame quilt refresh)
-       for p in `grep -rl PATCHES debian/patches` ; do perl -wi debian/fix-PATCHES.pl $$p ; done
-       
        dh_clean
 
 .PHONY: configure build build-arch build-indep clean install binary binary-arch binary-indep patch