+Enable pgp_mime_signature_filename and pgp_mime_signature_description
+
--- a/globals.h
+++ b/globals.h
-@@ -241,6 +241,8 @@
+@@ -243,6 +243,8 @@
WHERE char *PgpListSecringCommand;
WHERE char *PgpListPubringCommand;
WHERE char *PgpGetkeysCommand;
WHERE char *SmimeDefaultKey;
--- a/init.h
+++ b/init.h
-@@ -1790,6 +1790,18 @@
- ** checked with the \fC$<check-traditional-pgp>\fP function, mutt will automatically
- ** check the message for traditional pgp.
+@@ -2556,6 +2556,18 @@
+ ** a line quoted text if it also matches $$smileys. This mostly
+ ** happens at the beginning of a line.
*/
+ { "pgp_mime_signature_filename", DT_STR, R_NONE, UL &PgpMimeSignatureFilename, UL "signature.asc"},
+ /*
+ ** PGP/MIME signed messages.
+ */
- /* XXX Default values! */
+
--- a/pgp.c
+++ b/pgp.c
-@@ -1113,6 +1113,8 @@
- t->disposition = DISPINLINE;
+@@ -1129,6 +1129,8 @@
+ t->disposition = DISPNONE;
t->encoding = ENC7BIT;
t->unlink = 1; /* ok to remove this file after sending. */
+ mutt_set_parameter ("name", PgpMimeSignatureFilename, &t->parameter);
return (a);
}
---- a/PATCHES
-+++ b/PATCHES
-@@ -1,3 +1,4 @@
-+patch-1.5.4.vk.pgp_verbose_mime
- patch-1.5.13.cd.purge_message.3.4
- patch-1.5.13.nt+ab.xtitles.4
- patch-1.5.6.dw.maildir-mtime.1