- Fixed indentation of "purged" in mutt.h.
== END PATCH
---- a/OPS
-+++ b/OPS
+Index: mutt/OPS
+===================================================================
+--- mutt.orig/OPS 2009-06-25 12:35:37.000000000 +0200
++++ mutt/OPS 2009-06-25 12:36:14.000000000 +0200
@@ -141,6 +141,7 @@
OP_PREV_LINE "scroll up one line"
OP_PREV_PAGE "move to the previous page"
OP_QUERY "query external program for addresses"
OP_QUERY_APPEND "append new query results to current results"
OP_QUIT "save changes to mailbox and quit"
---- a/curs_main.c
-+++ b/curs_main.c
-@@ -1816,6 +1816,7 @@
+Index: mutt/curs_main.c
+===================================================================
+--- mutt.orig/curs_main.c 2009-06-25 12:35:44.000000000 +0200
++++ mutt/curs_main.c 2009-06-25 12:36:14.000000000 +0200
+@@ -1823,6 +1823,7 @@
MAYBE_REDRAW (menu->redraw);
break;
case OP_DELETE:
CHECK_MSGCOUNT;
-@@ -1826,6 +1827,7 @@
+@@ -1833,6 +1834,7 @@
if (tag)
{
mutt_tag_set_flag (M_DELETE, 1);
if (option (OPTDELETEUNTAG))
mutt_tag_set_flag (M_TAG, 0);
menu->redraw = REDRAW_INDEX;
-@@ -1833,6 +1835,8 @@
+@@ -1840,6 +1842,8 @@
else
{
mutt_set_flag (Context, CURHDR, M_DELETE, 1);
if (option (OPTDELETEUNTAG))
mutt_set_flag (Context, CURHDR, M_TAG, 0);
if (option (OPTRESOLVE))
-@@ -2129,11 +2133,13 @@
+@@ -2136,11 +2140,13 @@
if (tag)
{
mutt_tag_set_flag (M_DELETE, 0);
if (option (OPTRESOLVE) && menu->current < Context->vcount - 1)
{
menu->current++;
-@@ -2154,9 +2160,11 @@
+@@ -2161,9 +2167,11 @@
CHECK_ACL(M_ACL_DELETE, _("undelete message(s)"));
rc = mutt_thread_set_flag (CURHDR, M_DELETE, 0,
{
if (option (OPTRESOLVE))
{
---- a/flags.c
-+++ b/flags.c
+Index: mutt/flags.c
+===================================================================
+--- mutt.orig/flags.c 2009-06-25 12:35:48.000000000 +0200
++++ mutt/flags.c 2009-06-25 12:36:14.000000000 +0200
@@ -104,6 +104,16 @@
}
break;
case M_NEW:
if (!mutt_bit_isset(ctx->rights,M_ACL_SEEN))
---- a/functions.h
-+++ b/functions.h
+Index: mutt/functions.h
+===================================================================
+--- mutt.orig/functions.h 2009-06-25 12:35:37.000000000 +0200
++++ mutt/functions.h 2009-06-25 12:36:14.000000000 +0200
@@ -120,6 +120,7 @@
{ "toggle-write", OP_TOGGLE_WRITE, "%" },
{ "next-thread", OP_MAIN_NEXT_THREAD, "\016" },
{ "query", OP_QUERY, "Q" },
{ "quit", OP_QUIT, "q" },
{ "reply", OP_REPLY, "r" },
-@@ -207,6 +208,7 @@
+@@ -209,6 +210,7 @@
{ "print-message", OP_PRINT, "p" },
{ "previous-thread", OP_MAIN_PREV_THREAD, "\020" },
{ "previous-subthread",OP_MAIN_PREV_SUBTHREAD, "\033p" },
{ "quit", OP_QUIT, "Q" },
{ "exit", OP_EXIT, "q" },
{ "reply", OP_REPLY, "r" },
---- a/mutt.h
-+++ b/mutt.h
-@@ -182,6 +182,7 @@
+Index: mutt/mutt.h
+===================================================================
+--- mutt.orig/mutt.h 2009-06-25 12:35:48.000000000 +0200
++++ mutt/mutt.h 2009-06-25 12:36:14.000000000 +0200
+@@ -188,6 +188,7 @@
M_UNDELETE,
M_DELETED,
M_APPENDED,
M_FLAG,
M_TAG,
M_UNTAG,
-@@ -695,6 +696,7 @@
+@@ -704,6 +705,7 @@
unsigned int flagged : 1; /* marked important? */
unsigned int tagged : 1;
unsigned int appended : 1; /* has been saved */
unsigned int deleted : 1;
unsigned int changed : 1;
unsigned int attach_del : 1; /* has an attachment marked for deletion */
---- a/mx.c
-+++ b/mx.c
-@@ -833,6 +833,7 @@
+Index: mutt/mx.c
+===================================================================
+--- mutt.orig/mx.c 2009-06-25 12:36:10.000000000 +0200
++++ mutt/mx.c 2009-06-25 12:36:14.000000000 +0200
+@@ -803,6 +803,7 @@
{
for (i = 0 ; i < ctx->msgcount ; i++)
if (ctx->hdrs[i]->deleted && !ctx->hdrs[i]->appended
&& mutt_append_message (ctx_trash, ctx, ctx->hdrs[i], 0, 0) == -1)
{
mx_close_mailbox (ctx_trash, NULL);
---- a/pager.c
-+++ b/pager.c
-@@ -2272,12 +2272,15 @@
+Index: mutt/pager.c
+===================================================================
+--- mutt.orig/pager.c 2009-06-25 12:35:44.000000000 +0200
++++ mutt/pager.c 2009-06-25 12:36:14.000000000 +0200
+@@ -2316,12 +2316,15 @@
MAYBE_REDRAW (redraw);
break;
if (option (OPTDELETEUNTAG))
mutt_set_flag (Context, extra->hdr, M_TAG, 0);
redraw = REDRAW_STATUS | REDRAW_INDEX;
-@@ -2590,6 +2593,7 @@
+@@ -2648,6 +2651,7 @@
CHECK_ACL(M_ACL_DELETE, _("undelete message"));
mutt_set_flag (Context, extra->hdr, M_DELETE, 0);
redraw = REDRAW_STATUS | REDRAW_INDEX;
if (option (OPTRESOLVE))
{
-@@ -2605,9 +2609,11 @@
+@@ -2663,9 +2667,11 @@
CHECK_ACL(M_ACL_DELETE, _("undelete message(s)"));
r = mutt_thread_set_flag (extra->hdr, M_DELETE, 0,
{
if (option (OPTRESOLVE))
{
---- a/pattern.c
-+++ b/pattern.c
-@@ -1344,8 +1344,10 @@
+Index: mutt/pattern.c
+===================================================================
+--- mutt.orig/pattern.c 2009-06-25 12:35:37.000000000 +0200
++++ mutt/pattern.c 2009-06-25 12:36:14.000000000 +0200
+@@ -1347,8 +1347,10 @@
{
switch (op)
{
mutt_set_flag (Context, Context->hdrs[Context->v2r[i]], M_DELETE,
(op == M_DELETE));
break;
---- a/PATCHES
-+++ b/PATCHES
-@@ -1,3 +1,4 @@
-+patch-1.5.13.cd.purge_message.3.4
- patch-1.5.13.nt+ab.xtitles.4
- patch-1.5.6.dw.maildir-mtime.1
- patch-1.5.13.cd.ifdef.2