+If /etc/mailname is present, the hostname inside the file will be
+used, rather than calling gethostbyname() on the actual hostname
+
--- a/init.c
+++ b/init.c
-@@ -47,6 +47,7 @@
+@@ -48,6 +48,7 @@
#include <unistd.h>
#include <string.h>
#include <sys/utsname.h>
+#include <netdb.h>
#include <errno.h>
#include <sys/wait.h>
-
+ #include <sys/time.h>
@@ -2952,6 +2953,31 @@
- return 0;
+ srandom(seed);
}
+int getmailname(char *s, size_t l)
void mutt_init (int skip_sys_rc, LIST *commands)
{
struct passwd *pw;
-@@ -3026,10 +3052,25 @@
+@@ -3027,10 +3053,25 @@
Hostname = mutt_substrdup (utsname.nodename, p);
p++;
strfcpy (buffer, p, sizeof (buffer)); /* save the domain for below */