]> git.llucax.com Git - software/mutt-debian.git/blobdiff - debian/patches/debian-specific/Md.etc_mailname_gethostbyname.diff
624085-gnutls-deprecated-verify-peers.patch: deprecate gnutls_certificate_verify_peer...
[software/mutt-debian.git] / debian / patches / debian-specific / Md.etc_mailname_gethostbyname.diff
index 6220c0f1cfddbe018ac69506250a373e2f83cc5c..13a96b65cb85b213b94a6900c2515956546b88ac 100644 (file)
@@ -1,15 +1,18 @@
+If /etc/mailname is present, the hostname inside the file will be
+used, rather than calling gethostbyname() on the actual hostname
+
 --- a/init.c
 +++ b/init.c
-@@ -47,6 +47,7 @@
+@@ -48,6 +48,7 @@
  #include <unistd.h>
  #include <string.h>
  #include <sys/utsname.h>
 +#include <netdb.h>
  #include <errno.h>
  #include <sys/wait.h>
+ #include <sys/time.h>
 @@ -2952,6 +2953,31 @@
-   return 0;
+   srandom(seed);
  }
  
 +int getmailname(char *s, size_t l)
@@ -40,7 +43,7 @@
  void mutt_init (int skip_sys_rc, LIST *commands)
  {
    struct passwd *pw;
-@@ -3026,10 +3052,25 @@
+@@ -3027,10 +3053,25 @@
      Hostname = mutt_substrdup (utsname.nodename, p);
      p++;
      strfcpy (buffer, p, sizeof (buffer)); /* save the domain for below */