]> git.llucax.com Git - software/mutt-debian.git/blobdiff - debian/patches/features/purge-message
removing patches that were applied usptream into 1.5.21
[software/mutt-debian.git] / debian / patches / features / purge-message
index 125c8fca7ef967ece59f07fc589ff7fb7589a4c3..9d290b9a61f66aca381880b909a9a65dda95e395 100644 (file)
@@ -28,7 +28,7 @@ of having a trash folder feature.
 == END PATCH
 --- a/OPS
 +++ b/OPS
 == END PATCH
 --- a/OPS
 +++ b/OPS
-@@ -141,6 +141,7 @@
+@@ -142,6 +142,7 @@
  OP_PREV_LINE "scroll up one line"
  OP_PREV_PAGE "move to the previous page"
  OP_PRINT "print the current entry"
  OP_PREV_LINE "scroll up one line"
  OP_PREV_PAGE "move to the previous page"
  OP_PRINT "print the current entry"
@@ -38,7 +38,7 @@ of having a trash folder feature.
  OP_QUIT "save changes to mailbox and quit"
 --- a/curs_main.c
 +++ b/curs_main.c
  OP_QUIT "save changes to mailbox and quit"
 --- a/curs_main.c
 +++ b/curs_main.c
-@@ -1816,6 +1816,7 @@
+@@ -1843,6 +1843,7 @@
        MAYBE_REDRAW (menu->redraw);
        break;
  
        MAYBE_REDRAW (menu->redraw);
        break;
  
@@ -46,7 +46,7 @@ of having a trash folder feature.
        case OP_DELETE:
  
        CHECK_MSGCOUNT;
        case OP_DELETE:
  
        CHECK_MSGCOUNT;
-@@ -1826,6 +1827,7 @@
+@@ -1853,6 +1854,7 @@
        if (tag)
        {
          mutt_tag_set_flag (M_DELETE, 1);
        if (tag)
        {
          mutt_tag_set_flag (M_DELETE, 1);
@@ -54,7 +54,7 @@ of having a trash folder feature.
          if (option (OPTDELETEUNTAG))
            mutt_tag_set_flag (M_TAG, 0);
          menu->redraw = REDRAW_INDEX;
          if (option (OPTDELETEUNTAG))
            mutt_tag_set_flag (M_TAG, 0);
          menu->redraw = REDRAW_INDEX;
-@@ -1833,6 +1835,8 @@
+@@ -1860,6 +1862,8 @@
        else
        {
          mutt_set_flag (Context, CURHDR, M_DELETE, 1);
        else
        {
          mutt_set_flag (Context, CURHDR, M_DELETE, 1);
@@ -63,7 +63,7 @@ of having a trash folder feature.
          if (option (OPTDELETEUNTAG))
            mutt_set_flag (Context, CURHDR, M_TAG, 0);
          if (option (OPTRESOLVE))
          if (option (OPTDELETEUNTAG))
            mutt_set_flag (Context, CURHDR, M_TAG, 0);
          if (option (OPTRESOLVE))
-@@ -2129,11 +2133,13 @@
+@@ -2161,11 +2165,13 @@
        if (tag)
        {
          mutt_tag_set_flag (M_DELETE, 0);
        if (tag)
        {
          mutt_tag_set_flag (M_DELETE, 0);
@@ -77,7 +77,7 @@ of having a trash folder feature.
          if (option (OPTRESOLVE) && menu->current < Context->vcount - 1)
          {
            menu->current++;
          if (option (OPTRESOLVE) && menu->current < Context->vcount - 1)
          {
            menu->current++;
-@@ -2154,9 +2160,11 @@
+@@ -2186,9 +2192,11 @@
        CHECK_ACL(M_ACL_DELETE, _("undelete message(s)"));
  
        rc = mutt_thread_set_flag (CURHDR, M_DELETE, 0,
        CHECK_ACL(M_ACL_DELETE, _("undelete message(s)"));
  
        rc = mutt_thread_set_flag (CURHDR, M_DELETE, 0,
@@ -112,7 +112,7 @@ of having a trash folder feature.
        if (!mutt_bit_isset(ctx->rights,M_ACL_SEEN))
 --- a/functions.h
 +++ b/functions.h
        if (!mutt_bit_isset(ctx->rights,M_ACL_SEEN))
 --- a/functions.h
 +++ b/functions.h
-@@ -120,6 +120,7 @@
+@@ -121,6 +121,7 @@
    { "toggle-write",           OP_TOGGLE_WRITE,                "%" },
    { "next-thread",            OP_MAIN_NEXT_THREAD,            "\016" },
    { "next-subthread",         OP_MAIN_NEXT_SUBTHREAD,         "\033n" },
    { "toggle-write",           OP_TOGGLE_WRITE,                "%" },
    { "next-thread",            OP_MAIN_NEXT_THREAD,            "\016" },
    { "next-subthread",         OP_MAIN_NEXT_SUBTHREAD,         "\033n" },
@@ -120,7 +120,7 @@ of having a trash folder feature.
    { "query",                  OP_QUERY,                       "Q" },
    { "quit",                   OP_QUIT,                        "q" },
    { "reply",                  OP_REPLY,                       "r" },
    { "query",                  OP_QUERY,                       "Q" },
    { "quit",                   OP_QUIT,                        "q" },
    { "reply",                  OP_REPLY,                       "r" },
-@@ -207,6 +208,7 @@
+@@ -213,6 +214,7 @@
    { "print-message",  OP_PRINT,                       "p" },
    { "previous-thread",        OP_MAIN_PREV_THREAD,            "\020" },
    { "previous-subthread",OP_MAIN_PREV_SUBTHREAD,      "\033p" },
    { "print-message",  OP_PRINT,                       "p" },
    { "previous-thread",        OP_MAIN_PREV_THREAD,            "\020" },
    { "previous-subthread",OP_MAIN_PREV_SUBTHREAD,      "\033p" },
@@ -130,7 +130,7 @@ of having a trash folder feature.
    { "reply",          OP_REPLY,                       "r" },
 --- a/mutt.h
 +++ b/mutt.h
    { "reply",          OP_REPLY,                       "r" },
 --- a/mutt.h
 +++ b/mutt.h
-@@ -182,6 +182,7 @@
+@@ -188,6 +188,7 @@
    M_UNDELETE,
    M_DELETED,
    M_APPENDED,
    M_UNDELETE,
    M_DELETED,
    M_APPENDED,
@@ -138,7 +138,7 @@ of having a trash folder feature.
    M_FLAG,
    M_TAG,
    M_UNTAG,
    M_FLAG,
    M_TAG,
    M_UNTAG,
-@@ -695,6 +696,7 @@
+@@ -709,6 +710,7 @@
    unsigned int flagged : 1;           /* marked important? */
    unsigned int tagged : 1;
    unsigned int appended : 1;          /* has been saved */
    unsigned int flagged : 1;           /* marked important? */
    unsigned int tagged : 1;
    unsigned int appended : 1;          /* has been saved */
@@ -148,7 +148,7 @@ of having a trash folder feature.
    unsigned int attach_del : 1;                /* has an attachment marked for deletion */
 --- a/mx.c
 +++ b/mx.c
    unsigned int attach_del : 1;                /* has an attachment marked for deletion */
 --- a/mx.c
 +++ b/mx.c
-@@ -833,6 +833,7 @@
+@@ -806,6 +806,7 @@
      {
        for (i = 0 ; i < ctx->msgcount ; i++)
        if (ctx->hdrs[i]->deleted && !ctx->hdrs[i]->appended
      {
        for (i = 0 ; i < ctx->msgcount ; i++)
        if (ctx->hdrs[i]->deleted && !ctx->hdrs[i]->appended
@@ -158,7 +158,7 @@ of having a trash folder feature.
            mx_close_mailbox (ctx_trash, NULL);
 --- a/pager.c
 +++ b/pager.c
            mx_close_mailbox (ctx_trash, NULL);
 --- a/pager.c
 +++ b/pager.c
-@@ -2272,12 +2272,15 @@
+@@ -2343,12 +2343,15 @@
        MAYBE_REDRAW (redraw);
        break;
  
        MAYBE_REDRAW (redraw);
        break;
  
@@ -174,7 +174,7 @@ of having a trash folder feature.
          if (option (OPTDELETEUNTAG))
          mutt_set_flag (Context, extra->hdr, M_TAG, 0);
        redraw = REDRAW_STATUS | REDRAW_INDEX;
          if (option (OPTDELETEUNTAG))
          mutt_set_flag (Context, extra->hdr, M_TAG, 0);
        redraw = REDRAW_STATUS | REDRAW_INDEX;
-@@ -2590,6 +2593,7 @@
+@@ -2675,6 +2678,7 @@
        CHECK_ACL(M_ACL_DELETE, _("undelete message"));
  
        mutt_set_flag (Context, extra->hdr, M_DELETE, 0);
        CHECK_ACL(M_ACL_DELETE, _("undelete message"));
  
        mutt_set_flag (Context, extra->hdr, M_DELETE, 0);
@@ -182,7 +182,7 @@ of having a trash folder feature.
        redraw = REDRAW_STATUS | REDRAW_INDEX;
        if (option (OPTRESOLVE))
        {
        redraw = REDRAW_STATUS | REDRAW_INDEX;
        if (option (OPTRESOLVE))
        {
-@@ -2605,9 +2609,11 @@
+@@ -2690,9 +2694,11 @@
        CHECK_ACL(M_ACL_DELETE, _("undelete message(s)"));
  
        r = mutt_thread_set_flag (extra->hdr, M_DELETE, 0,
        CHECK_ACL(M_ACL_DELETE, _("undelete message(s)"));
  
        r = mutt_thread_set_flag (extra->hdr, M_DELETE, 0,
@@ -197,7 +197,7 @@ of having a trash folder feature.
          {
 --- a/pattern.c
 +++ b/pattern.c
          {
 --- a/pattern.c
 +++ b/pattern.c
-@@ -1344,8 +1344,10 @@
+@@ -1357,8 +1357,10 @@
        {
        switch (op)
        {
        {
        switch (op)
        {
@@ -209,10 +209,3 @@ of having a trash folder feature.
            mutt_set_flag (Context, Context->hdrs[Context->v2r[i]], M_DELETE, 
                          (op == M_DELETE));
            break;
            mutt_set_flag (Context, Context->hdrs[Context->v2r[i]], M_DELETE, 
                          (op == M_DELETE));
            break;
---- a/PATCHES
-+++ b/PATCHES
-@@ -1,3 +1,4 @@
-+patch-1.5.13.cd.purge_message.3.4
- patch-1.5.13.nt+ab.xtitles.4
- patch-1.5.6.dw.maildir-mtime.1
- patch-1.5.13.cd.ifdef.2