void index_make_entry (char *s, size_t l, MUTTMENU *menu, int num)
{
format_flag flag = M_FORMAT_MAKEPRINT | M_FORMAT_ARROWCURSOR | M_FORMAT_INDEX;
-@@ -566,6 +579,13 @@
+@@ -562,6 +575,13 @@
SETCOLOR (MT_COLOR_NORMAL);
BKGDSET (MT_COLOR_NORMAL);
menu->redraw &= ~REDRAW_STATUS;
menu->redraw = 0;
--- a/globals.h
+++ b/globals.h
-@@ -140,6 +140,8 @@
+@@ -141,6 +141,8 @@
WHERE char *Tochars;
WHERE char *Username;
WHERE char *Visual;
WHERE char *LastFolder;
--- a/init.c
+++ b/init.c
-@@ -1892,6 +1892,26 @@
+@@ -1873,6 +1873,26 @@
toggle_option (MuttVars[idx].data);
else
set_option (MuttVars[idx].data);
DTYPE (MuttVars[idx].type) == DT_PATH ||
--- a/init.h
+++ b/init.h
-@@ -3285,6 +3285,27 @@
- ** option does nothing: mutt will never write out the ``Bcc:'' header
- ** in this case.
+@@ -3364,6 +3364,27 @@
+ ** Also see the $$read_inc, $$net_inc and $$time_inc variables and the
+ ** ``$tuning'' section of the manual for performance considerations.
*/
+ {"xterm_icon", DT_STR, R_BOTH, UL &XtermIcon, UL "M%?n?AIL&ail?"},
+ /*
+ ** to the one used by ``$$status_format''.
+ */
/*--*/
- { NULL }
+ { NULL, 0, 0, 0, 0 }
};
--- a/mutt.h
+++ b/mutt.h
-@@ -438,6 +438,7 @@
+@@ -447,6 +447,7 @@
OPTWRAPSEARCH,
OPTWRITEBCC, /* write out a bcc header? */
OPTXMAILER,
OPTCRYPTUSEPKA,
--- a/pager.c
+++ b/pager.c
-@@ -1761,6 +1761,13 @@
- mutt_paddstr (COLS, IsHeader (extra) || IsMsgAttach (extra) ? buffer : banner);
+@@ -1812,6 +1812,13 @@
+ }
BKGDSET (MT_COLOR_NORMAL);
SETCOLOR (MT_COLOR_NORMAL);
+ if (option(OPTXTERMSETTITLES))
MUTTMENU *mutt_new_menu (int);
void mutt_menuDestroy (MUTTMENU **);
---- a/PATCHES
-+++ b/PATCHES
-@@ -1,2 +1,3 @@
-+patch-1.5.13.nt+ab.xtitles.4
- patch-1.5.6.dw.maildir-mtime.1
- patch-1.5.13.cd.ifdef.2