]> git.llucax.com Git - software/mutt-debian.git/blobdiff - debian/patches/debian-specific/Md.etc_mailname_gethostbyname.diff
Merge branch '1.5.20-1+fix533439-atime'
[software/mutt-debian.git] / debian / patches / debian-specific / Md.etc_mailname_gethostbyname.diff
index 6220c0f1cfddbe018ac69506250a373e2f83cc5c..61d04ce4f872e5be1e7436d33d65722eb8b5fa26 100644 (file)
@@ -1,3 +1,6 @@
+If /etc/mailname is present, the hostname inside the file will be
+used, rather than calling gethostbyname() on the actual hostname
+
 --- a/init.c
 +++ b/init.c
 @@ -47,6 +47,7 @@
 --- a/init.c
 +++ b/init.c
 @@ -47,6 +47,7 @@
@@ -8,7 +11,7 @@
  #include <errno.h>
  #include <sys/wait.h>
  
  #include <errno.h>
  #include <sys/wait.h>
  
-@@ -2952,6 +2953,31 @@
+@@ -2953,6 +2954,31 @@
    return 0;
  }
  
    return 0;
  }
  
@@ -40,7 +43,7 @@
  void mutt_init (int skip_sys_rc, LIST *commands)
  {
    struct passwd *pw;
  void mutt_init (int skip_sys_rc, LIST *commands)
  {
    struct passwd *pw;
-@@ -3026,10 +3052,25 @@
+@@ -3027,10 +3053,25 @@
      Hostname = mutt_substrdup (utsname.nodename, p);
      p++;
      strfcpy (buffer, p, sizeof (buffer)); /* save the domain for below */
      Hostname = mutt_substrdup (utsname.nodename, p);
      p++;
      strfcpy (buffer, p, sizeof (buffer)); /* save the domain for below */