]> git.llucax.com Git - software/mutt-debian.git/blobdiff - debian/patches/features/purge-message
Merge branch '1.5.20-1+fix533439-atime'
[software/mutt-debian.git] / debian / patches / features / purge-message
index 125c8fca7ef967ece59f07fc589ff7fb7589a4c3..a509e1df316bfe4eba90375f9f261a078827e740 100644 (file)
@@ -38,7 +38,7 @@ of having a trash folder feature.
  OP_QUIT "save changes to mailbox and quit"
 --- a/curs_main.c
 +++ b/curs_main.c
-@@ -1816,6 +1816,7 @@
+@@ -1823,6 +1823,7 @@
        MAYBE_REDRAW (menu->redraw);
        break;
  
@@ -46,7 +46,7 @@ of having a trash folder feature.
        case OP_DELETE:
  
        CHECK_MSGCOUNT;
-@@ -1826,6 +1827,7 @@
+@@ -1833,6 +1834,7 @@
        if (tag)
        {
          mutt_tag_set_flag (M_DELETE, 1);
@@ -54,7 +54,7 @@ of having a trash folder feature.
          if (option (OPTDELETEUNTAG))
            mutt_tag_set_flag (M_TAG, 0);
          menu->redraw = REDRAW_INDEX;
-@@ -1833,6 +1835,8 @@
+@@ -1840,6 +1842,8 @@
        else
        {
          mutt_set_flag (Context, CURHDR, M_DELETE, 1);
@@ -63,7 +63,7 @@ of having a trash folder feature.
          if (option (OPTDELETEUNTAG))
            mutt_set_flag (Context, CURHDR, M_TAG, 0);
          if (option (OPTRESOLVE))
-@@ -2129,11 +2133,13 @@
+@@ -2136,11 +2140,13 @@
        if (tag)
        {
          mutt_tag_set_flag (M_DELETE, 0);
@@ -77,7 +77,7 @@ of having a trash folder feature.
          if (option (OPTRESOLVE) && menu->current < Context->vcount - 1)
          {
            menu->current++;
-@@ -2154,9 +2160,11 @@
+@@ -2161,9 +2167,11 @@
        CHECK_ACL(M_ACL_DELETE, _("undelete message(s)"));
  
        rc = mutt_thread_set_flag (CURHDR, M_DELETE, 0,
@@ -120,7 +120,7 @@ of having a trash folder feature.
    { "query",                  OP_QUERY,                       "Q" },
    { "quit",                   OP_QUIT,                        "q" },
    { "reply",                  OP_REPLY,                       "r" },
-@@ -207,6 +208,7 @@
+@@ -209,6 +210,7 @@
    { "print-message",  OP_PRINT,                       "p" },
    { "previous-thread",        OP_MAIN_PREV_THREAD,            "\020" },
    { "previous-subthread",OP_MAIN_PREV_SUBTHREAD,      "\033p" },
@@ -130,7 +130,7 @@ of having a trash folder feature.
    { "reply",          OP_REPLY,                       "r" },
 --- a/mutt.h
 +++ b/mutt.h
-@@ -182,6 +182,7 @@
+@@ -188,6 +188,7 @@
    M_UNDELETE,
    M_DELETED,
    M_APPENDED,
@@ -138,7 +138,7 @@ of having a trash folder feature.
    M_FLAG,
    M_TAG,
    M_UNTAG,
-@@ -695,6 +696,7 @@
+@@ -705,6 +706,7 @@
    unsigned int flagged : 1;           /* marked important? */
    unsigned int tagged : 1;
    unsigned int appended : 1;          /* has been saved */
@@ -148,7 +148,7 @@ of having a trash folder feature.
    unsigned int attach_del : 1;                /* has an attachment marked for deletion */
 --- a/mx.c
 +++ b/mx.c
-@@ -833,6 +833,7 @@
+@@ -803,6 +803,7 @@
      {
        for (i = 0 ; i < ctx->msgcount ; i++)
        if (ctx->hdrs[i]->deleted && !ctx->hdrs[i]->appended
@@ -158,7 +158,7 @@ of having a trash folder feature.
            mx_close_mailbox (ctx_trash, NULL);
 --- a/pager.c
 +++ b/pager.c
-@@ -2272,12 +2272,15 @@
+@@ -2316,12 +2316,15 @@
        MAYBE_REDRAW (redraw);
        break;
  
@@ -174,7 +174,7 @@ of having a trash folder feature.
          if (option (OPTDELETEUNTAG))
          mutt_set_flag (Context, extra->hdr, M_TAG, 0);
        redraw = REDRAW_STATUS | REDRAW_INDEX;
-@@ -2590,6 +2593,7 @@
+@@ -2648,6 +2651,7 @@
        CHECK_ACL(M_ACL_DELETE, _("undelete message"));
  
        mutt_set_flag (Context, extra->hdr, M_DELETE, 0);
@@ -182,7 +182,7 @@ of having a trash folder feature.
        redraw = REDRAW_STATUS | REDRAW_INDEX;
        if (option (OPTRESOLVE))
        {
-@@ -2605,9 +2609,11 @@
+@@ -2663,9 +2667,11 @@
        CHECK_ACL(M_ACL_DELETE, _("undelete message(s)"));
  
        r = mutt_thread_set_flag (extra->hdr, M_DELETE, 0,
@@ -197,7 +197,7 @@ of having a trash folder feature.
          {
 --- a/pattern.c
 +++ b/pattern.c
-@@ -1344,8 +1344,10 @@
+@@ -1347,8 +1347,10 @@
        {
        switch (op)
        {
@@ -209,10 +209,3 @@ of having a trash folder feature.
            mutt_set_flag (Context, Context->hdrs[Context->v2r[i]], M_DELETE, 
                          (op == M_DELETE));
            break;
---- a/PATCHES
-+++ b/PATCHES
-@@ -1,3 +1,4 @@
-+patch-1.5.13.cd.purge_message.3.4
- patch-1.5.13.nt+ab.xtitles.4
- patch-1.5.6.dw.maildir-mtime.1
- patch-1.5.13.cd.ifdef.2