+ needsort=0;
+ tmp = Incoming;
+ for ( ; tmp ; tmp=tmp->next ) {
-+ if (tmp->next != NULL && strcmp(tmp->path, tmp->next->path) > 0) {
++ if (tmp->next != NULL && strcoll(tmp->path, tmp->next->path) > 0) {
+ needsort=1;
+ prev = tmp->prev;
+ next = tmp->next;
OPTSIGDASHES,
OPTSIGONTOP,
OPTSORTRE,
---- a/debian/extra/samples/sidebar.muttrc
-+++ b/debian/extra/samples/sidebar.muttrc
-@@ -55,6 +55,9 @@
- # When using IMAP, a '.' is often used as a separator. This option
- # allows to shorten the folder name to the part after the last dot.
- #
-+# sidebar_sort (boolean)
-+# Sorts the folders in the sidebar alphabetically.
-+#
- # color sidebar_new [fg] [bg]
- # The foreground (fg) and background (bg) color of folders that contain new
- # mail.