]> git.llucax.com Git - software/mutt-debian.git/blobdiff - debian/patches/mutt-patched/sidebar-sorted
sidebar: don't overwrite the status if status_on_top is enabled (Closes: 494735)
[software/mutt-debian.git] / debian / patches / mutt-patched / sidebar-sorted
index dbfa3cf6baeadfbe9cdfeaa7b6b0cc9d0fa9f1da..c5211b8ff84c69dcdae5fe148960ce032ae17a7e 100644 (file)
@@ -26,7 +26,7 @@ should be easy to adopt it to a vanilla mutt.
 +                      needsort=0;
 +                      tmp = Incoming;
 +                      for ( ; tmp ; tmp=tmp->next ) {
-+                              if (tmp->next != NULL && strcmp(tmp->path, tmp->next->path) > 0) {
++                              if (tmp->next != NULL && strcoll(tmp->path, tmp->next->path) > 0) {
 +                                      needsort=1;
 +                                      prev = tmp->prev;
 +                                      next = tmp->next;
@@ -51,7 +51,7 @@ should be easy to adopt it to a vanilla mutt.
        if ( BottomBuffy == 0 ) {
 --- a/init.h
 +++ b/init.h
-@@ -1984,6 +1984,11 @@
+@@ -1986,6 +1986,11 @@
    ** .pp
    ** Should the sidebar shorten the path showed.
    */
@@ -65,7 +65,7 @@ should be easy to adopt it to a vanilla mutt.
    ** .pp
 --- a/mutt.h
 +++ b/mutt.h
-@@ -428,6 +428,7 @@
+@@ -433,6 +433,7 @@
    OPTSCORE,
    OPTSIDEBAR,
    OPTSIDEBARSHORTPATH,
@@ -73,3 +73,15 @@ should be easy to adopt it to a vanilla mutt.
    OPTSIGDASHES,
    OPTSIGONTOP,
    OPTSORTRE,
+--- a/debian/extra/samples/sidebar.muttrc
++++ b/debian/extra/samples/sidebar.muttrc
+@@ -55,6 +55,9 @@
+ # When using IMAP, a '.' is often used as a separator. This option
+ # allows to shorten the folder name to the part after the last dot.
+ #
++# sidebar_sort (boolean)
++# Sorts the folders in the sidebar alphabetically.
++#
+ # color sidebar_new [fg] [bg]
+ # The foreground (fg) and background (bg) color of folders that contain new
+ # mail.