]> git.llucax.com Git - software/mutt-debian.git/blobdiff - debian/rules
incorporating fixes of http://bugs.mutt.org/3308 into the existing patch
[software/mutt-debian.git] / debian / rules
index 7a34979c77b1874c88d9cc76a3c9dddddb748b99..1b5641f63e6aa76d5f3214ace21c16a0fe81def6 100755 (executable)
@@ -2,6 +2,11 @@
 
 include /usr/share/quilt/quilt.make
 
+###################### user serviceable parts ######################
+
+###
+# build a separate mutt-patched package?
+BUILD_PATCHED := yes
 ###
 # header cache backend
 # HCACHE_DB := bdb
@@ -9,19 +14,25 @@ HCACHE_DB := gdbm
 # HCACHE_DB := qdbm
 ###
 # GPGME backend
-GPGME := --enable-gpgme
+GPGME := --enable-gpgme
 ###
 
+###################### variables ######################
+
+ifneq ($(BUILD_PATCHED),yes)
+export DH_OPTIONS := -Nmutt-patched
+endif
+
 # Configure arguments
 
 ifeq ($(HCACHE_DB),bdb)
-    hcache_db := --without-gdbm --without-qdbm
+    hcache_db := --without-gdbm --without-qdbm --without-tokyocabinet
 endif
 ifeq ($(HCACHE_DB),gdbm)
-    hcache_db := --without-qdbm --without-bdb
+    hcache_db := --without-qdbm --without-bdb --without-tokyocabinet
 endif
 ifeq ($(HCACHE_DB),qdbm)
-    hcache_db := --without-gdbm --without-bdb
+    hcache_db := --without-gdbm --without-bdb --without-tokyocabinet
 endif
 
 confflags =    --prefix=/usr                   \
@@ -45,6 +56,7 @@ confflags =   --prefix=/usr                   \
                                                \
                --with-curses                   \
                --with-gnutls                   \
+               --with-gss                      \
                --with-idn                      \
                --with-mixmaster                \
                --with-sasl                     \
@@ -71,41 +83,61 @@ endif
 # Directory to make the build on
 objdir = $(CURDIR)/obj-$(DEB_HOST_GNU_TYPE)
 
-configure: $(objdir)/configure-stamp
-$(objdir)/configure-stamp: $(QUILT_STAMPFN)
+###################### main ######################
+
+$(objdir)-patched/build-stamp: $(QUILT_STAMPFN)
        dh_testdir
+       dh_clean
+       -mkdir $(objdir)-patched
        
+ifeq ($(BUILD_PATCHED),yes)
+       ###################### building mutt-patched ######################
        autoreconf --install --include=m4
-       -mkdir $(objdir)
-       cd $(objdir) && \
+       cd $(objdir)-patched && \
        env CFLAGS="$(CFLAGS)" CPPFLAGS="$(CPPFLAGS)" \
        ../configure $(confflags)
        
-       echo '#include "config-debian.h"' >>$(objdir)/config.h
+       echo '#include "config-debian.h"' >> $(objdir)-patched/config.h
+       
+       # we should just "make mutt" here, but that doesn't work yet
+       cd $(objdir)-patched && $(MAKE) CFLAGS="$(CFLAGS)"
+endif
        
        touch $@
 
 build build-arch: $(objdir)/build-stamp
-$(objdir)/build-stamp: $(objdir)/configure-stamp
+$(objdir)/build-stamp: $(objdir)-patched/build-stamp
+       ###################### building mutt ######################
+       QUILT_PATCHES=$(QUILT_PATCH_DIR) quilt --quiltrc /dev/null pop mutt.org
+       
+       autoreconf --install --include=m4
+       -mkdir $(objdir)
+       cd $(objdir) && \
+       env CFLAGS="$(CFLAGS)" CPPFLAGS="$(CPPFLAGS)" \
+       ../configure $(confflags)
+       
+       echo '#include "config-debian.h"' >>$(objdir)/config.h
+       
        cd $(objdir) && $(MAKE) CFLAGS="$(CFLAGS)"
+       
        touch $@
 
-install: debian/tmp/install-stamp
-debian/tmp/install-stamp: $(objdir)/build-stamp
+install: build
+       ###################### install ######################
        dh_testdir
        dh_testroot
-       dh_clean
+       dh_prep
        cd $(objdir) && $(MAKE) install DESTDIR=$(CURDIR)/debian/tmp
        
        cd debian/tmp/usr/share/doc && \
        rm -rf samples/iconv samples/ca-bundle.crt && \
        mv NEWS NEWS.old && \
-       mv ChangeLog.old changelog.old && \
        cp $(CURDIR)/UPDATING NEWS
        
        chmod +x debian/extra/lib/*
        chmod +x debian/header.awk
-       debian/header.awk debian/patches/features/* >debian/tmp/README.Patches
+       debian/header.awk debian/patches/features/* \
+               debian/patches/mutt-patched/* > debian/tmp/README.Patches
        
        ( sed -e '/## More settings/,$$d' $(objdir)/doc/Muttrc || exit 1 ; \
          cat debian/extra/rc/Muttrc.foot ) > debian/tmp/Muttrc
@@ -114,23 +146,34 @@ debian/tmp/install-stamp: $(objdir)/build-stamp
          grep '^set' contrib/gpg.rc; \
          echo ) > debian/tmp/gpg.rc
        
-       touch $@
-
-binary binary-arch: build install
-       dh_testdir
-       dh_testroot
+ifeq ($(BUILD_PATCHED),yes)
+       # temporarily call the binary mutt-patched so dh_strip gets the debug file name right
+       install -D $(objdir)-patched/mutt debian/mutt-patched/usr/bin/mutt-patched
+endif
        
+       # reportbug driver
        dh_installdirs
+       install -m644 debian/bug/control $(CURDIR)/debian/mutt/usr/share/bug/mutt
+       install       debian/bug/script  $(CURDIR)/debian/mutt/usr/share/bug/mutt
+
+binary binary-arch: install
+       ###################### binary ######################
        dh_install
        dh_installman
        dh_installmenu
+       dh_installmime
        dh_installdocs
        dh_installexamples
        dh_installchangelogs ChangeLog
-       install -m644 debian/mutt.lintian $(CURDIR)/debian/mutt/usr/share/lintian/overrides/mutt
+       -dh_lintian
        
        dh_strip --dbg-package=mutt-dbg
-       rm -rf $(CURDIR)/debian/mutt-dbg/usr/share/doc/mutt-dbg
+       rm -rf $(CURDIR)/debian/mutt-dbg/usr/share/doc/mutt-dbg \
+               $(CURDIR)/debian/mutt-patched/usr/share/doc/mutt-patched
+ifeq ($(BUILD_PATCHED),yes)
+       mv debian/mutt-patched/usr/bin/mutt-patched debian/mutt-patched/usr/bin/mutt
+endif
+       
        dh_link
        dh_compress --exclude usr/share/doc/mutt/README.Patches
        dh_fixperms --exclude usr/bin/mutt_dotlock
@@ -140,10 +183,11 @@ binary binary-arch: build install
        dh_md5sums
        dh_builddeb
 
-binary-indep:
+build-indep binary-indep:
        @echo "Nothing to do."
 
 clean: unpatch
+       ###################### clean ######################
        dh_testdir
        dh_testroot
        
@@ -151,8 +195,8 @@ clean: unpatch
        rm -f po/*.gmo
        touch PATCHES
        
-       # remove build tree
-       rm -rf $(objdir)
+       # remove build trees
+       rm -rf $(objdir) $(objdir)-patched
        
        # remove autotool-generated files so they don't show up in the diff.gz
        rm -f configure config.h.in