]> git.llucax.com Git - software/mutt-debian.git/blobdiff - debian/rules
lintian clean, removed the deprecated dh_clean -k
[software/mutt-debian.git] / debian / rules
index 05b512f85cb137473ec20533be9019129e92e2b1..fdc4d9983f88bc3edb8b63c6540d2d3df0e36fbe 100755 (executable)
@@ -2,6 +2,11 @@
 
 include /usr/share/quilt/quilt.make
 
+###################### user serviceable parts ######################
+
+###
+# build a separate mutt-patched package?
+BUILD_PATCHED := yes
 ###
 # header cache backend
 # HCACHE_DB := bdb
@@ -12,6 +17,12 @@ HCACHE_DB := gdbm
 # GPGME := --enable-gpgme
 ###
 
+###################### variables ######################
+
+ifneq ($(BUILD_PATCHED),yes)
+export DH_OPTIONS := -Nmutt-patched
+endif
+
 # Configure arguments
 
 ifeq ($(HCACHE_DB),bdb)
@@ -45,6 +56,7 @@ confflags =   --prefix=/usr                   \
                                                \
                --with-curses                   \
                --with-gnutls                   \
+               --with-gss                      \
                --with-idn                      \
                --with-mixmaster                \
                --with-sasl                     \
@@ -71,13 +83,16 @@ endif
 # Directory to make the build on
 objdir = $(CURDIR)/obj-$(DEB_HOST_GNU_TYPE)
 
+###################### main ######################
+
 $(objdir)-patched/build-stamp: $(QUILT_STAMPFN)
        dh_testdir
        dh_clean
+       -mkdir $(objdir)-patched
        
+ifeq ($(BUILD_PATCHED),yes)
        ###################### building mutt-patched ######################
        autoreconf --install --include=m4
-       -mkdir $(objdir)-patched
        cd $(objdir)-patched && \
        env CFLAGS="$(CFLAGS)" CPPFLAGS="$(CPPFLAGS)" \
        ../configure $(confflags)
@@ -86,6 +101,7 @@ $(objdir)-patched/build-stamp: $(QUILT_STAMPFN)
        
        # we should just "make mutt" here, but that doesn't work yet
        cd $(objdir)-patched && $(MAKE) CFLAGS="$(CFLAGS)"
+endif
        
        touch $@
 
@@ -108,13 +124,14 @@ $(objdir)/build-stamp: $(objdir)-patched/build-stamp
 
 install: build
        ###################### install ######################
-       dh_clean -k
+       dh_testdir
+       dh_testroot
+       dh_prep
        cd $(objdir) && $(MAKE) install DESTDIR=$(CURDIR)/debian/tmp
        
        cd debian/tmp/usr/share/doc && \
        rm -rf samples/iconv samples/ca-bundle.crt && \
        mv NEWS NEWS.old && \
-       mv ChangeLog.old changelog.old && \
        cp $(CURDIR)/UPDATING NEWS
        
        chmod +x debian/extra/lib/*
@@ -129,27 +146,33 @@ install: build
          grep '^set' contrib/gpg.rc; \
          echo ) > debian/tmp/gpg.rc
        
+ifeq ($(BUILD_PATCHED),yes)
        # temporarily call the binary mutt-patched so dh_strip gets the debug file name right
        install -D $(objdir)-patched/mutt debian/mutt-patched/usr/bin/mutt-patched
+endif
+       
+       # reportbug driver
+       dh_installdirs
+       install -m644 debian/bug/control $(CURDIR)/debian/mutt/usr/share/bug/mutt
+       install       debian/bug/script  $(CURDIR)/debian/mutt/usr/share/bug/mutt
 
 binary binary-arch: install
        ###################### binary ######################
-       dh_testdir
-       dh_testroot
-       
-       dh_installdirs
        dh_install
        dh_installman
        dh_installmenu
+       dh_installmime
        dh_installdocs
        dh_installexamples
        dh_installchangelogs ChangeLog
-       install -m644 debian/mutt.lintian $(CURDIR)/debian/mutt/usr/share/lintian/overrides/mutt
+       -dh_lintian
        
        dh_strip --dbg-package=mutt-dbg
        rm -rf $(CURDIR)/debian/mutt-dbg/usr/share/doc/mutt-dbg \
                $(CURDIR)/debian/mutt-patched/usr/share/doc/mutt-patched
+ifeq ($(BUILD_PATCHED),yes)
        mv debian/mutt-patched/usr/bin/mutt-patched debian/mutt-patched/usr/bin/mutt
+endif
        
        dh_link
        dh_compress --exclude usr/share/doc/mutt/README.Patches