]> git.llucax.com Git - software/mutt-debian.git/blobdiff - debian/rules
* Call autoreconf at build time, drop the autotools-update patch.
[software/mutt-debian.git] / debian / rules
index 34b3edb63eda1cea962e65aa0e038bd763da953d..42ce474a8458d8e60d6b55da7656f6465699a00f 100755 (executable)
@@ -3,14 +3,20 @@
 include /usr/share/quilt/quilt.make
 
 ###
-# Uncomment one of these if you're rebuilding using them instead of libdb4.X
-# HCACHE_DB := gdbm
+# header cache backend
+# HCACHE_DB := bdb
+HCACHE_DB := gdbm
 # HCACHE_DB := qdbm
 ###
+# GPGME backend
+# GPGME := --enable-gpgme
+###
 
 # Configure arguments
 
-hcache_db := --without-gdbm --without-qdbm
+ifeq ($(HCACHE_DB),bdb)
+    hcache_db := --without-gdbm --without-qdbm
+endif
 ifeq ($(HCACHE_DB),gdbm)
     hcache_db := --without-qdbm --without-bdb
 endif
@@ -31,7 +37,7 @@ confflags =   --prefix=/usr                   \
                --enable-debug                  \
                --enable-fcntl                  \
                --enable-hcache                 \
-               --enable-gpgme                  \
+               $(GPGME)                        \
                --enable-imap                   \
                --enable-smtp                   \
                --enable-inodesort              \
@@ -69,12 +75,7 @@ configure: $(objdir)/configure-stamp
 $(objdir)/configure-stamp: $(QUILT_STAMPFN)
        dh_testdir
        
-       ln -sf /usr/share/misc/config.sub .
-       ln -sf /usr/share/misc/config.guess .
-       
-       # do not rebuild these files
-       touch configure.in aclocal.m4 Makefile.in configure config.h.in
-       
+       autoreconf --install --include=m4
        -mkdir $(objdir)
        cd $(objdir) && \
        env CFLAGS="$(CFLAGS)" CPPFLAGS="$(CPPFLAGS)" \
@@ -146,12 +147,15 @@ clean: unpatch
        
        # please dpkg-source
        rm -f po/*.gmo
-       rm -f config.guess config.sub
        touch PATCHES
        
        # remove build tree
        rm -rf $(objdir)
        
+       # remove autotool-generated files so they don't show up in the diff.gz
+       rm -f configure config.h.in
+       rm -f Makefile.in contrib/Makefile.in imap/Makefile.in doc/Makefile.in m4/Makefile.in
+       
        dh_clean
 
 .PHONY: configure build build-arch build-indep clean install binary binary-arch binary-indep patch