include /usr/share/quilt/quilt.make
###
-# Uncomment one of these if you're rebuilding using them instead of libdb4.X
-# HCACHE_DB := gdbm
+# header cache backend
+# HCACHE_DB := bdb
+HCACHE_DB := gdbm
# HCACHE_DB := qdbm
###
+# GPGME backend
+# GPGME := --enable-gpgme
+###
# Configure arguments
-hcache_db := --without-gdbm --without-qdbm
+ifeq ($(HCACHE_DB),bdb)
+ hcache_db := --without-gdbm --without-qdbm
+endif
ifeq ($(HCACHE_DB),gdbm)
hcache_db := --without-qdbm --without-bdb
endif
--enable-debug \
--enable-fcntl \
--enable-hcache \
- --enable-gpgme \
+ $(GPGME) \
--enable-imap \
--enable-smtp \
--enable-inodesort \
$(objdir)/configure-stamp: $(QUILT_STAMPFN)
dh_testdir
- ln -sf /usr/share/misc/config.sub .
- ln -sf /usr/share/misc/config.guess .
-
- # do not rebuild these files
- touch configure.in aclocal.m4 Makefile.in configure config.h.in
-
+ autoreconf --install --include=m4
-mkdir $(objdir)
cd $(objdir) && \
env CFLAGS="$(CFLAGS)" CPPFLAGS="$(CPPFLAGS)" \
dh_installdocs
dh_installexamples
dh_installchangelogs ChangeLog
+ install -m644 debian/mutt.lintian $(CURDIR)/debian/mutt/usr/share/lintian/overrides/mutt
dh_link
dh_strip
# please dpkg-source
rm -f po/*.gmo
- rm -f config.guess config.sub
touch PATCHES
# remove build tree
rm -rf $(objdir)
+ # remove autotool-generated files so they don't show up in the diff.gz
+ rm -f configure config.h.in
+ rm -f Makefile.in contrib/Makefile.in imap/Makefile.in doc/Makefile.in m4/Makefile.in
+
+ # clean PATCHES hunks (blame quilt refresh)
+ for p in `grep -rl PATCHES debian/patches` ; do perl -wi debian/fix-PATCHES.pl $$p ; done
+
dh_clean
.PHONY: configure build build-arch build-indep clean install binary binary-arch binary-indep patch