]> git.llucax.com Git - software/mutt-debian.git/blobdiff - debian/rules
mutt (1.5.16-2) unstable; urgency=low
[software/mutt-debian.git] / debian / rules
index 34b3edb63eda1cea962e65aa0e038bd763da953d..0deaca25ad57ace98cc3ee3040ac641e6cdd15cf 100755 (executable)
@@ -3,14 +3,20 @@
 include /usr/share/quilt/quilt.make
 
 ###
-# Uncomment one of these if you're rebuilding using them instead of libdb4.X
-# HCACHE_DB := gdbm
+# header cache backend
+# HCACHE_DB := bdb
+HCACHE_DB := gdbm
 # HCACHE_DB := qdbm
 ###
+# GPGME backend
+# GPGME := --enable-gpgme
+###
 
 # Configure arguments
 
-hcache_db := --without-gdbm --without-qdbm
+ifeq ($(HCACHE_DB),bdb)
+    hcache_db := --without-gdbm --without-qdbm
+endif
 ifeq ($(HCACHE_DB),gdbm)
     hcache_db := --without-qdbm --without-bdb
 endif
@@ -31,7 +37,7 @@ confflags =   --prefix=/usr                   \
                --enable-debug                  \
                --enable-fcntl                  \
                --enable-hcache                 \
-               --enable-gpgme                  \
+               $(GPGME)                        \
                --enable-imap                   \
                --enable-smtp                   \
                --enable-inodesort              \
@@ -69,11 +75,11 @@ configure: $(objdir)/configure-stamp
 $(objdir)/configure-stamp: $(QUILT_STAMPFN)
        dh_testdir
        
-       ln -sf /usr/share/misc/config.sub .
-       ln -sf /usr/share/misc/config.guess .
+       #ln -sf /usr/share/misc/config.sub .
+       #ln -sf /usr/share/misc/config.guess .
        
        # do not rebuild these files
-       touch configure.in aclocal.m4 Makefile.in configure config.h.in
+       touch configure.ac aclocal.m4 Makefile.in configure config.h.in
        
        -mkdir $(objdir)
        cd $(objdir) && \
@@ -146,7 +152,7 @@ clean: unpatch
        
        # please dpkg-source
        rm -f po/*.gmo
-       rm -f config.guess config.sub
+       #rm -f config.guess config.sub
        touch PATCHES
        
        # remove build tree