else if (ch == '|')
--- a/mx.c
+++ b/mx.c
-@@ -596,6 +596,7 @@
+@@ -595,6 +595,7 @@
* M_APPEND open mailbox for appending
* M_READONLY open mailbox in read-only mode
* M_QUIET only print error messages
* ctx if non-null, context struct to use
*/
CONTEXT *mx_open_mailbox (const char *path, int flags, CONTEXT *pctx)
-@@ -618,6 +619,8 @@
+@@ -617,6 +618,8 @@
ctx->quiet = 1;
if (flags & M_READONLY)
ctx->readonly = 1;
if (flags & (M_APPEND|M_NEWFOLDER))
{
-@@ -722,9 +725,21 @@
+@@ -721,9 +724,21 @@
void mx_fastclose_mailbox (CONTEXT *ctx)
{
int i;
FREE (&value);
return;
}
---- a/PATCHES
-+++ b/PATCHES
-@@ -1,2 +1,3 @@
-+patch-1.5.19.sidebar.20090522.txt
- patch-1.5.18.rr.compressed.1
- patch-1.5.13.cd.ifdef.2