--- a/globals.h
+++ b/globals.h
-@@ -242,6 +242,8 @@
+@@ -243,6 +243,8 @@
WHERE char *PgpListSecringCommand;
WHERE char *PgpListPubringCommand;
WHERE char *PgpGetkeysCommand;
WHERE char *SmimeDefaultKey;
--- a/init.h
+++ b/init.h
-@@ -2551,6 +2551,18 @@
+@@ -2556,6 +2556,18 @@
** a line quoted text if it also matches $$smileys. This mostly
** happens at the beginning of a line.
*/
--- a/pgp.c
+++ b/pgp.c
-@@ -1131,6 +1131,8 @@
- t->disposition = DISPINLINE;
+@@ -1129,6 +1129,8 @@
+ t->disposition = DISPNONE;
t->encoding = ENC7BIT;
t->unlink = 1; /* ok to remove this file after sending. */
+ mutt_set_parameter ("name", PgpMimeSignatureFilename, &t->parameter);