]> git.llucax.com Git - software/mutt-debian.git/blobdiff - debian/patches/features/sensible_browser_position
refreshed a bunch of patches
[software/mutt-debian.git] / debian / patches / features / sensible_browser_position
index cf8cc7b45b0901d731aacb975fe744ac98bfae5b..744353a89f8f529f20ede902e4b6acffaddec7e4 100644 (file)
@@ -5,8 +5,10 @@ This is the sensible browser position patch by Haakon Riiser.
     http://lists.df7cb.de/mutt/message/20050309.162127.a244a894.en.html
 
 == END PATCH
---- a/menu.c
-+++ b/menu.c
+Index: mutt/menu.c
+===================================================================
+--- mutt.orig/menu.c   2009-06-25 12:35:36.000000000 +0200
++++ mutt/menu.c        2009-06-25 12:36:19.000000000 +0200
 @@ -853,8 +853,17 @@
  
  int mutt_menuLoop (MUTTMENU *menu)
@@ -34,9 +36,11 @@ This is the sensible browser position patch by Haakon Riiser.
        return (i);
      }
    }
---- a/browser.c
-+++ b/browser.c
-@@ -56,6 +56,7 @@
+Index: mutt/browser.c
+===================================================================
+--- mutt.orig/browser.c        2009-06-25 12:35:37.000000000 +0200
++++ mutt/browser.c     2009-06-25 12:36:19.000000000 +0200
+@@ -55,6 +55,7 @@
    int num;
  } FOLDER;
  
@@ -44,7 +48,7 @@ This is the sensible browser position patch by Haakon Riiser.
  static char LastDir[_POSIX_PATH_MAX] = "";
  static char LastDirBackup[_POSIX_PATH_MAX] = "";
  
-@@ -526,9 +527,13 @@
+@@ -519,9 +520,13 @@
    menu->tagged = 0;
    
    if (buffy)
@@ -58,7 +62,7 @@ This is the sensible browser position patch by Haakon Riiser.
      strfcpy (path, LastDir, sizeof (path));
      mutt_pretty_mailbox (path, sizeof (path));
  #ifdef USE_IMAP
-@@ -537,8 +542,22 @@
+@@ -530,8 +535,22 @@
              path, NONULL (Mask.pattern));
    else
  #endif
@@ -83,7 +87,7 @@ This is the sensible browser position patch by Haakon Riiser.
    }
    menu->redraw = REDRAW_FULL;
  }
-@@ -721,7 +740,6 @@
+@@ -714,7 +733,6 @@
  #endif
            )
          {
@@ -91,8 +95,10 @@ This is the sensible browser position patch by Haakon Riiser.
  
            /* save the old directory */
            strfcpy (OldLastDir, LastDir, sizeof (OldLastDir));
---- a/mutt_menu.h
-+++ b/mutt_menu.h
+Index: mutt/mutt_menu.h
+===================================================================
+--- mutt.orig/mutt_menu.h      2009-06-25 12:35:44.000000000 +0200
++++ mutt/mutt_menu.h   2009-06-25 12:36:19.000000000 +0200
 @@ -49,6 +49,7 @@
    int offset; /* which screen row to start the index */
    int pagelen;        /* number of entries per screen */