]> git.llucax.com Git - software/mutt-debian.git/blobdiff - debian/patches/features/compressed-folders
removing patches that were applied usptream into 1.5.21
[software/mutt-debian.git] / debian / patches / features / compressed-folders
index dc2c38e0ad171a6000752ab56204561882e80ab8..7f6e233373adbb5fb9840b528e43a12e0b97f65f 100644 (file)
@@ -15,11 +15,14 @@ The home page for this patch is:
   - 2009-09-15 myon: refreshed for mutt-1.5.19
                      status.c:103: add sizeof (tmp) to mutt_pretty_mailbox
   - 2009-09-15 scotton: removed doc/Muttrc for mutt-1.5.19 (only patch doc/Muttrc.head)
   - 2009-09-15 myon: refreshed for mutt-1.5.19
                      status.c:103: add sizeof (tmp) to mutt_pretty_mailbox
   - 2009-09-15 scotton: removed doc/Muttrc for mutt-1.5.19 (only patch doc/Muttrc.head)
+  - 2009-09-11 antonio: removed DefaultMagic, see 541360
+  - 2010-05-31 myon: remove commented paragraph "Use folders..." in
+                     doc/Muttrc.head, see #578096
 
 == END PATCH
 --- /dev/null
 +++ b/compress.c
 
 == END PATCH
 --- /dev/null
 +++ b/compress.c
-@@ -0,0 +1,499 @@
+@@ -0,0 +1,496 @@
 +/*
 + * Copyright (C) 1997 Alain Penders <Alain@Finale-Dev.com>
 + *
 +/*
 + * Copyright (C) 1997 Alain Penders <Alain@Finale-Dev.com>
 + *
@@ -172,7 +175,7 @@ The home page for this patch is:
 +  ctx->realpath = ctx->path;
 +
 +  /* Uncompress to /tmp */
 +  ctx->realpath = ctx->path;
 +
 +  /* Uncompress to /tmp */
-+  mutt_mktemp (tmppath);
++  mutt_mktemp (tmppath, sizeof(tmppath));
 +  ctx->path = safe_malloc (strlen (tmppath) + 1);
 +  strcpy (ctx->path, tmppath);
 +}
 +  ctx->path = safe_malloc (strlen (tmppath) + 1);
 +  strcpy (ctx->path, tmppath);
 +}
@@ -343,10 +346,7 @@ The home page for this patch is:
 +
 +  set_path (ctx);
 +
 +
 +  set_path (ctx);
 +
-+  ctx->magic = DefaultMagic;
-+
 +  if (!is_new (ctx->realpath))
 +  if (!is_new (ctx->realpath))
-+    if (ctx->magic == M_MBOX || ctx->magic == M_MMDF)
 +      if ((fh = fopen (ctx->path, "w")))
 +      fclose (fh);
 +  /* No error checking - the parent function will catch it */
 +      if ((fh = fopen (ctx->path, "w")))
 +      fclose (fh);
 +  /* No error checking - the parent function will catch it */
@@ -551,7 +551,7 @@ The home page for this patch is:
 +void mutt_fast_close_compressed (CONTEXT *);
 --- a/configure.ac
 +++ b/configure.ac
 +void mutt_fast_close_compressed (CONTEXT *);
 --- a/configure.ac
 +++ b/configure.ac
-@@ -805,6 +805,11 @@
+@@ -812,6 +812,11 @@
                  AC_DEFINE(LOCALES_HACK,1,[ Define if the result of isprint() is unreliable. ])
          fi])
  
                  AC_DEFINE(LOCALES_HACK,1,[ Define if the result of isprint() is unreliable. ])
          fi])
  
@@ -565,7 +565,7 @@ The home page for this patch is:
                  AC_DEFINE_UNQUOTED(EXECSHELL, "$withval",
 --- a/curs_main.c
 +++ b/curs_main.c
                  AC_DEFINE_UNQUOTED(EXECSHELL, "$withval",
 --- a/curs_main.c
 +++ b/curs_main.c
-@@ -1135,6 +1135,11 @@
+@@ -1153,6 +1153,11 @@
          {
          int check;
  
          {
          int check;
  
@@ -579,7 +579,7 @@ The home page for this patch is:
  
 --- a/doc/manual.xml.head
 +++ b/doc/manual.xml.head
  
 --- a/doc/manual.xml.head
 +++ b/doc/manual.xml.head
-@@ -5678,6 +5678,205 @@
+@@ -6116,6 +6116,205 @@
  
  </chapter>
  
  
  </chapter>
  
@@ -785,23 +785,9 @@ The home page for this patch is:
  <chapter id="mimesupport">
  <title>Mutt's MIME Support</title>
  
  <chapter id="mimesupport">
  <title>Mutt's MIME Support</title>
  
---- a/doc/Muttrc.head
-+++ b/doc/Muttrc.head
-@@ -29,6 +29,11 @@
- macro index,pager y "<change-folder>?<toggle-mailboxes>" "show incoming mailboxes list"
- bind browser y exit
-+# Use folders which match on \\.gz$ as gzipped folders:
-+# open-hook \\.gz$ "gzip -cd %f > %t"
-+# close-hook \\.gz$ "gzip -c %t > %f"
-+# append-hook \\.gz$ "gzip -c %t >> %f"
-+
- # If Mutt is unable to determine your site's domain name correctly, you can
- # set the default here.
- #
 --- a/doc/muttrc.man.head
 +++ b/doc/muttrc.man.head
 --- a/doc/muttrc.man.head
 +++ b/doc/muttrc.man.head
-@@ -345,6 +345,24 @@
+@@ -346,6 +346,24 @@
  to a certain recipient.  The meaning of "key ID" is to be taken
  broadly: This can be a different e-mail address, a numerical key ID,
  or even just an arbitrary search string.
  to a certain recipient.  The meaning of "key ID" is to be taken
  broadly: This can be a different e-mail address, a numerical key ID,
  or even just an arbitrary search string.
@@ -858,7 +844,7 @@ The home page for this patch is:
        )
 --- a/init.h
 +++ b/init.h
        )
 --- a/init.h
 +++ b/init.h
-@@ -3514,6 +3514,11 @@
+@@ -3530,6 +3530,11 @@
    { "fcc-hook",               mutt_parse_hook,        M_FCCHOOK },
    { "fcc-save-hook",  mutt_parse_hook,        M_FCCHOOK | M_SAVEHOOK },
    { "folder-hook",    mutt_parse_hook,        M_FOLDERHOOK },
    { "fcc-hook",               mutt_parse_hook,        M_FCCHOOK },
    { "fcc-save-hook",  mutt_parse_hook,        M_FCCHOOK | M_SAVEHOOK },
    { "folder-hook",    mutt_parse_hook,        M_FOLDERHOOK },
@@ -867,12 +853,12 @@ The home page for this patch is:
 +  { "close-hook",     mutt_parse_hook,        M_CLOSEHOOK },
 +  { "append-hook",    mutt_parse_hook,        M_APPENDHOOK },
 +#endif
 +  { "close-hook",     mutt_parse_hook,        M_CLOSEHOOK },
 +  { "append-hook",    mutt_parse_hook,        M_APPENDHOOK },
 +#endif
-   { "group",          parse_group,            0 },
-   { "ungroup",                parse_ungroup,          0 },
+   { "group",          parse_group,            M_GROUP },
+   { "ungroup",                parse_group,            M_UNGROUP },
    { "hdr_order",      parse_list,             UL &HeaderOrderList },
 --- a/main.c
 +++ b/main.c
    { "hdr_order",      parse_list,             UL &HeaderOrderList },
 --- a/main.c
 +++ b/main.c
-@@ -402,6 +402,12 @@
+@@ -401,6 +401,12 @@
  #else
        "-LOCALES_HACK  "
  #endif
  #else
        "-LOCALES_HACK  "
  #endif
@@ -887,7 +873,7 @@ The home page for this patch is:
        "+HAVE_WC_FUNCS  "
 --- a/Makefile.am
 +++ b/Makefile.am
        "+HAVE_WC_FUNCS  "
 --- a/Makefile.am
 +++ b/Makefile.am
-@@ -18,7 +18,7 @@
+@@ -22,7 +22,7 @@
  bin_PROGRAMS = mutt @DOTLOCK_TARGET@ @PGPAUX_TARGET@
  mutt_SOURCES = \
        addrbook.c alias.c attach.c base64.c browser.c buffy.c color.c \
  bin_PROGRAMS = mutt @DOTLOCK_TARGET@ @PGPAUX_TARGET@
  mutt_SOURCES = \
        addrbook.c alias.c attach.c base64.c browser.c buffy.c color.c \
@@ -896,7 +882,7 @@ The home page for this patch is:
        commands.c complete.c compose.c copy.c curs_lib.c curs_main.c date.c \
        edit.c enter.c flags.c init.c filter.c from.c \
        getdomain.c group.c \
        commands.c complete.c compose.c copy.c curs_lib.c curs_main.c date.c \
        edit.c enter.c flags.c init.c filter.c from.c \
        getdomain.c group.c \
-@@ -57,7 +57,7 @@
+@@ -61,7 +61,7 @@
        bcache.h browser.h hcache.h mbyte.h mutt_idna.h remailer.h url.h
  
  EXTRA_DIST = COPYRIGHT GPL OPS OPS.PGP OPS.CRYPT OPS.SMIME TODO UPDATING \
        bcache.h browser.h hcache.h mbyte.h mutt_idna.h remailer.h url.h
  
  EXTRA_DIST = COPYRIGHT GPL OPS OPS.PGP OPS.CRYPT OPS.SMIME TODO UPDATING \
@@ -918,7 +904,7 @@ The home page for this patch is:
  #include <sys/stat.h>
  #include <dirent.h>
  #include <string.h>
  #include <sys/stat.h>
  #include <dirent.h>
  #include <string.h>
-@@ -1048,6 +1052,12 @@
+@@ -1070,6 +1074,12 @@
  int mbox_close_mailbox (CONTEXT *ctx)
  {
    mx_unlock_file (ctx->path, fileno (ctx->fp), 1);
  int mbox_close_mailbox (CONTEXT *ctx)
  {
    mx_unlock_file (ctx->path, fileno (ctx->fp), 1);
@@ -945,7 +931,7 @@ The home page for this patch is:
  
  /* tree characters for linearize_tree and print_enriched_string */
  #define M_TREE_LLCORNER               1
  
  /* tree characters for linearize_tree and print_enriched_string */
  #define M_TREE_LLCORNER               1
-@@ -883,6 +888,11 @@
+@@ -887,6 +892,11 @@
    int flagged;                        /* how many flagged messages */
    int msgnotreadyet;          /* which msg "new" in pager, -1 if none */
  
    int flagged;                        /* how many flagged messages */
    int msgnotreadyet;          /* which msg "new" in pager, -1 if none */
  
@@ -970,7 +956,7 @@ The home page for this patch is:
  #ifdef USE_IMAP
  #include "imap.h"
  #endif
  #ifdef USE_IMAP
  #include "imap.h"
  #endif
-@@ -415,6 +419,10 @@
+@@ -414,6 +418,10 @@
      return (-1);
    }
  
      return (-1);
    }
  
@@ -981,7 +967,7 @@ The home page for this patch is:
    return (magic);
  }
  
    return (magic);
  }
  
-@@ -454,6 +462,13 @@
+@@ -453,6 +461,13 @@
  {
    struct stat sb;
  
  {
    struct stat sb;
  
@@ -995,7 +981,7 @@ The home page for this patch is:
    ctx->append = 1;
  
  #ifdef USE_IMAP
    ctx->append = 1;
  
  #ifdef USE_IMAP
-@@ -617,7 +632,12 @@
+@@ -616,7 +631,12 @@
    }
  
    ctx->magic = mx_get_magic (path);
    }
  
    ctx->magic = mx_get_magic (path);
@@ -1009,7 +995,7 @@ The home page for this patch is:
    if(ctx->magic == 0)
      mutt_error (_("%s is not a mailbox."), path);
  
    if(ctx->magic == 0)
      mutt_error (_("%s is not a mailbox."), path);
  
-@@ -718,6 +738,10 @@
+@@ -721,6 +741,10 @@
      mutt_free_header (&ctx->hdrs[i]);
    FREE (&ctx->hdrs);
    FREE (&ctx->v2r);
      mutt_free_header (&ctx->hdrs[i]);
    FREE (&ctx->hdrs);
    FREE (&ctx->v2r);
@@ -1020,7 +1006,7 @@ The home page for this patch is:
    FREE (&ctx->path);
    FREE (&ctx->pattern);
    if (ctx->limit_pattern) 
    FREE (&ctx->path);
    FREE (&ctx->pattern);
    if (ctx->limit_pattern) 
-@@ -770,6 +794,12 @@
+@@ -773,6 +797,12 @@
    
    if (tmp && tmp->new == 0)
      mutt_update_mailbox (tmp);
    
    if (tmp && tmp->new == 0)
      mutt_update_mailbox (tmp);
@@ -1033,7 +1019,7 @@ The home page for this patch is:
    return rc;
  }
  
    return rc;
  }
  
-@@ -1033,6 +1063,11 @@
+@@ -1043,6 +1073,11 @@
        !mutt_is_spool(ctx->path) && !option (OPTSAVEEMPTY))
      mx_unlink_empty (ctx->path);
  
        !mutt_is_spool(ctx->path) && !option (OPTSAVEEMPTY))
      mx_unlink_empty (ctx->path);
  
@@ -1045,7 +1031,7 @@ The home page for this patch is:
    mx_fastclose_mailbox (ctx);
  
    return 0;
    mx_fastclose_mailbox (ctx);
  
    return 0;
-@@ -1355,6 +1390,11 @@
+@@ -1361,6 +1396,11 @@
  {
    int rc;
  
  {
    int rc;
  
@@ -1059,52 +1045,55 @@ The home page for this patch is:
      if (ctx->locked) lock = 0;
 --- a/mx.h
 +++ b/mx.h
      if (ctx->locked) lock = 0;
 --- a/mx.h
 +++ b/mx.h
-@@ -40,6 +40,9 @@
- #ifdef USE_POP
-   , M_POP
- #endif
+@@ -36,6 +36,9 @@
+   M_MAILDIR,
+   M_IMAP,
+   M_POP
 +#ifdef USE_COMPRESSED
 +  , M_COMPRESSED
 +#endif
  };
  
  WHERE short DefaultMagic INITVAL (M_MBOX);
 +#ifdef USE_COMPRESSED
 +  , M_COMPRESSED
 +#endif
  };
  
  WHERE short DefaultMagic INITVAL (M_MBOX);
+--- a/po/POTFILES.in
++++ b/po/POTFILES.in
+@@ -8,6 +8,7 @@
+ color.c
+ commands.c
+ compose.c
++compress.c
+ crypt-gpgme.c
+ crypt.c
+ cryptglue.c
+--- a/status.c
++++ b/status.c
+@@ -96,6 +96,14 @@
+     case 'f':
+       snprintf (fmt, sizeof(fmt), "%%%ss", prefix);
++#ifdef USE_COMPRESSED
++      if (Context && Context->compressinfo && Context->realpath)
++      {
++       strfcpy (tmp, Context->realpath, sizeof (tmp));
++       mutt_pretty_mailbox (tmp, sizeof (tmp));
++      }
++      else
++#endif
+       if (Context && Context->path)
+       {
+       strfcpy (tmp, Context->path, sizeof (tmp));
 --- a/po/de.po
 +++ b/po/de.po
 --- a/po/de.po
 +++ b/po/de.po
-@@ -2005,6 +2005,10 @@
- msgid "Bad history file format (line %d)"
- msgstr "Falsches Format der Datei früherer Eingaben (Zeile %d)"
-+#: hook.c:96
-+msgid "badly formatted command string"
-+msgstr "Hook enthält nicht die Muster %f und %t"
-+
- #: hook.c:251
- #, c-format
- msgid "unhook: Can't do unhook * from within a hook."
-@@ -5378,3 +5382,45 @@
+@@ -5159,6 +5159,36 @@
+ msgid "show S/MIME options"
+ msgstr "Zeige S/MIME Optionen"
  
  
- #~ msgid "Authentication method is unknown."
- #~ msgstr "Authentifizierungsmethode unbekannt."
-+
-+#: compress.c:203 mbox.c:661
-+msgid "Mailbox was corrupted!"
-+msgstr "Mailbox wurde zerstört!"
 +
 +#: compress.c:228 compress.c:253
 +#, c-format
 +msgid "Decompressing %s...\n"
 +msgstr "Entpacke %s...\n"
 +
 +
 +#: compress.c:228 compress.c:253
 +#, c-format
 +msgid "Decompressing %s...\n"
 +msgstr "Entpacke %s...\n"
 +
-+#: compress.c:246 compress.c:367 compress.c:443 mbox.c:706
-+msgid "Unable to lock mailbox!"
-+msgstr "Kann Mailbox nicht für exklusiven Zugriff sperren!"
-+
-+#: compress.c:264
-+#, c-format
-+msgid "Error executing: %s : unable to open the mailbox!\n"
-+msgstr "Fehler beim Ausführen von %s : Kann die Mailbox nicht öffnen!\n"
-+
 +#: compress.c:350 compress.c:377 compress.c:423 compress.c:454
 +#, c-format
 +msgid "Compressing %s...\n"
 +#: compress.c:350 compress.c:377 compress.c:423 compress.c:454
 +#, c-format
 +msgid "Compressing %s...\n"
@@ -1128,35 +1117,7 @@ The home page for this patch is:
 +#, c-format
 +msgid " %s: Error compressing mailbox!  Uncompressed one kept!\n"
 +msgstr " %s: Fehler beim packen der Mailbox! Entpackte Mailbox gespeichert!\n"
 +#, c-format
 +msgid " %s: Error compressing mailbox!  Uncompressed one kept!\n"
 +msgstr " %s: Fehler beim packen der Mailbox! Entpackte Mailbox gespeichert!\n"
---- a/po/POTFILES.in
-+++ b/po/POTFILES.in
-@@ -8,6 +8,7 @@
- color.c
- commands.c
- compose.c
-+compress.c
- crypt-gpgme.c
- crypt.c
- cryptglue.c
---- a/status.c
-+++ b/status.c
-@@ -96,6 +96,14 @@
++
+ #~ msgid "Clear"
+ #~ msgstr "Klartext"
  
  
-     case 'f':
-       snprintf (fmt, sizeof(fmt), "%%%ss", prefix);
-+#ifdef USE_COMPRESSED
-+      if (Context && Context->compressinfo && Context->realpath)
-+      {
-+       strfcpy (tmp, Context->realpath, sizeof (tmp));
-+       mutt_pretty_mailbox (tmp, sizeof (tmp));
-+      }
-+      else
-+#endif
-       if (Context && Context->path)
-       {
-       strfcpy (tmp, Context->path, sizeof (tmp));
---- a/PATCHES
-+++ b/PATCHES
-@@ -1 +1,2 @@
-+patch-1.5.18.rr.compressed.1
- patch-1.5.13.cd.ifdef.2