---- init.c.orig
-+++ init.c
+--- a/init.c
++++ b/init.c
@@ -46,6 +46,7 @@
#include <unistd.h>
#include <string.h>
#include <errno.h>
#include <sys/wait.h>
-@@ -2770,6 +2771,31 @@
+@@ -2911,6 +2912,31 @@ static int mutt_execute_commands (LIST *
return 0;
}
void mutt_init (int skip_sys_rc, LIST *commands)
{
struct passwd *pw;
-@@ -2841,10 +2867,25 @@
+@@ -2982,10 +3008,25 @@ void mutt_init (int skip_sys_rc, LIST *c
Hostname = mutt_substrdup (utsname.nodename, p);
p++;
strfcpy (buffer, p, sizeof (buffer)); /* save the domain for below */