]> git.llucax.com Git - software/mutt-debian.git/blobdiff - debian/patches/features-old/patch-1.5.4.vk.pgp_verbose_mime
removing an article form the Description of mutt-patched to make lintian happy
[software/mutt-debian.git] / debian / patches / features-old / patch-1.5.4.vk.pgp_verbose_mime
index 07feee8e70ae67152b8a083332051621d16fc223..4179485098fc712cb5a89101aea909f849bb31c4 100644 (file)
@@ -1,12 +1,8 @@
-diff -ruN mutt.orig/PATCHES mutt/PATCHES
---- mutt.orig/PATCHES  2003-09-13 16:23:24.000000000 +0200
-+++ mutt/PATCHES       2003-09-13 16:21:53.000000000 +0200
-@@ -1,0 +1 @@
-+patch-1.5.4.vk.pgp_verbose_mime
-diff -ruN mutt.orig/globals.h mutt/globals.h
---- mutt.orig/globals.h        2003-09-13 16:23:24.000000000 +0200
-+++ mutt/globals.h     2003-09-13 16:23:18.000000000 +0200
-@@ -195,6 +195,8 @@
+Enable pgp_mime_signature_filename and pgp_mime_signature_description
+
+--- a/globals.h
++++ b/globals.h
+@@ -243,6 +243,8 @@
  WHERE char *PgpListSecringCommand;
  WHERE char *PgpListPubringCommand;
  WHERE char *PgpGetkeysCommand;
  WHERE char *PgpListSecringCommand;
  WHERE char *PgpListPubringCommand;
  WHERE char *PgpGetkeysCommand;
@@ -15,12 +11,11 @@ diff -ruN mutt.orig/globals.h mutt/globals.h
  
  /*-- formerly in smime.h --*/
  WHERE char *SmimeDefaultKey;
  
  /*-- formerly in smime.h --*/
  WHERE char *SmimeDefaultKey;
-diff -ruN mutt.orig/init.h mutt/init.h
---- mutt.orig/init.h   2003-09-13 16:23:24.000000000 +0200
-+++ mutt/init.h        2003-09-13 16:21:53.000000000 +0200
-@@ -1458,6 +1458,18 @@
-   ** This option overrides ``$$pgp_create_traditional''
-   ** (PGP only)
+--- a/init.h
++++ b/init.h
+@@ -2556,6 +2556,18 @@
+   ** a line quoted text if it also matches $$smileys. This mostly
+   ** happens at the beginning of a line.
    */
 +  { "pgp_mime_signature_filename", DT_STR, R_NONE, UL &PgpMimeSignatureFilename, UL "signature.asc"},
 +  /*
    */
 +  { "pgp_mime_signature_filename", DT_STR, R_NONE, UL &PgpMimeSignatureFilename, UL "signature.asc"},
 +  /*
@@ -35,13 +30,12 @@ diff -ruN mutt.orig/init.h mutt/init.h
 +  ** PGP/MIME signed messages.
 +  */
  
 +  ** PGP/MIME signed messages.
 +  */
  
-   /* XXX Default values! */
-   
-diff -ruN mutt.orig/pgp.c mutt/pgp.c
---- mutt.orig/pgp.c    2003-09-13 16:23:24.000000000 +0200
-+++ mutt/pgp.c 2003-09-13 16:21:53.000000000 +0200
-@@ -998,6 +998,8 @@
-   t->disposition = DISPINLINE;
+--- a/pgp.c
++++ b/pgp.c
+@@ -1129,6 +1129,8 @@
+   t->disposition = DISPNONE;
    t->encoding = ENC7BIT;
    t->unlink = 1; /* ok to remove this file after sending. */
 +  mutt_set_parameter ("name", PgpMimeSignatureFilename, &t->parameter);
    t->encoding = ENC7BIT;
    t->unlink = 1; /* ok to remove this file after sending. */
 +  mutt_set_parameter ("name", PgpMimeSignatureFilename, &t->parameter);