- Fixed indentation of "purged" in mutt.h.
== END PATCH
-Index: trash/OPS
+Index: mutt/OPS
===================================================================
---- trash.orig/OPS 2006-12-12 14:15:02.000000000 +0100
-+++ trash/OPS 2007-02-15 19:39:57.479112576 +0100
-@@ -140,6 +140,7 @@ OP_PREV_ENTRY "move to the previous entr
+--- mutt.orig/OPS 2009-06-25 12:35:37.000000000 +0200
++++ mutt/OPS 2009-06-25 12:36:14.000000000 +0200
+@@ -141,6 +141,7 @@
OP_PREV_LINE "scroll up one line"
OP_PREV_PAGE "move to the previous page"
OP_PRINT "print the current entry"
OP_QUERY "query external program for addresses"
OP_QUERY_APPEND "append new query results to current results"
OP_QUIT "save changes to mailbox and quit"
-Index: trash/curs_main.c
+Index: mutt/curs_main.c
===================================================================
---- trash.orig/curs_main.c 2006-12-12 14:15:02.000000000 +0100
-+++ trash/curs_main.c 2007-02-15 19:39:57.480112424 +0100
-@@ -1778,6 +1778,7 @@ int mutt_index_menu (void)
+--- mutt.orig/curs_main.c 2009-06-25 12:35:44.000000000 +0200
++++ mutt/curs_main.c 2009-06-25 12:36:14.000000000 +0200
+@@ -1823,6 +1823,7 @@
MAYBE_REDRAW (menu->redraw);
break;
case OP_DELETE:
CHECK_MSGCOUNT;
-@@ -1788,6 +1789,7 @@ int mutt_index_menu (void)
+@@ -1833,6 +1834,7 @@
if (tag)
{
mutt_tag_set_flag (M_DELETE, 1);
if (option (OPTDELETEUNTAG))
mutt_tag_set_flag (M_TAG, 0);
menu->redraw = REDRAW_INDEX;
-@@ -1795,6 +1797,8 @@ int mutt_index_menu (void)
+@@ -1840,6 +1842,8 @@
else
{
mutt_set_flag (Context, CURHDR, M_DELETE, 1);
if (option (OPTDELETEUNTAG))
mutt_set_flag (Context, CURHDR, M_TAG, 0);
if (option (OPTRESOLVE))
-@@ -2088,11 +2092,13 @@ int mutt_index_menu (void)
+@@ -2136,11 +2140,13 @@
if (tag)
{
mutt_tag_set_flag (M_DELETE, 0);
if (option (OPTRESOLVE) && menu->current < Context->vcount - 1)
{
menu->current++;
-@@ -2113,9 +2119,11 @@ int mutt_index_menu (void)
+@@ -2161,9 +2167,11 @@
CHECK_ACL(M_ACL_DELETE, _("undelete message(s)"));
rc = mutt_thread_set_flag (CURHDR, M_DELETE, 0,
{
if (option (OPTRESOLVE))
{
-Index: trash/flags.c
+Index: mutt/flags.c
===================================================================
---- trash.orig/flags.c 2007-02-15 19:38:00.433906152 +0100
-+++ trash/flags.c 2007-02-15 19:39:57.480112424 +0100
-@@ -105,6 +105,16 @@ void _mutt_set_flag (CONTEXT *ctx, HEADE
+--- mutt.orig/flags.c 2009-06-25 12:35:48.000000000 +0200
++++ mutt/flags.c 2009-06-25 12:36:14.000000000 +0200
+@@ -104,6 +104,16 @@
}
break;
case M_NEW:
if (!mutt_bit_isset(ctx->rights,M_ACL_SEEN))
-Index: trash/functions.h
+Index: mutt/functions.h
===================================================================
---- trash.orig/functions.h 2005-09-18 13:16:40.000000000 +0200
-+++ trash/functions.h 2007-02-15 19:39:57.481112272 +0100
-@@ -103,6 +103,7 @@ struct binding_t OpMain[] = {
+--- mutt.orig/functions.h 2009-06-25 12:35:37.000000000 +0200
++++ mutt/functions.h 2009-06-25 12:36:14.000000000 +0200
+@@ -120,6 +120,7 @@
{ "toggle-write", OP_TOGGLE_WRITE, "%" },
{ "next-thread", OP_MAIN_NEXT_THREAD, "\016" },
{ "next-subthread", OP_MAIN_NEXT_SUBTHREAD, "\033n" },
{ "query", OP_QUERY, "Q" },
{ "quit", OP_QUIT, "q" },
{ "reply", OP_REPLY, "r" },
-@@ -189,6 +190,7 @@ struct binding_t OpPager[] = {
+@@ -209,6 +210,7 @@
{ "print-message", OP_PRINT, "p" },
{ "previous-thread", OP_MAIN_PREV_THREAD, "\020" },
{ "previous-subthread",OP_MAIN_PREV_SUBTHREAD, "\033p" },
{ "quit", OP_QUIT, "Q" },
{ "exit", OP_EXIT, "q" },
{ "reply", OP_REPLY, "r" },
-Index: trash/mutt.h
+Index: mutt/mutt.h
===================================================================
---- trash.orig/mutt.h 2007-02-15 19:38:00.435905848 +0100
-+++ trash/mutt.h 2007-02-15 19:40:38.768835584 +0100
-@@ -201,6 +201,7 @@ enum
+--- mutt.orig/mutt.h 2009-06-25 12:35:48.000000000 +0200
++++ mutt/mutt.h 2009-06-25 12:36:14.000000000 +0200
+@@ -188,6 +188,7 @@
M_UNDELETE,
M_DELETED,
M_APPENDED,
M_FLAG,
M_TAG,
M_UNTAG,
-@@ -705,6 +706,7 @@ typedef struct header
+@@ -704,6 +705,7 @@
unsigned int flagged : 1; /* marked important? */
unsigned int tagged : 1;
unsigned int appended : 1; /* has been saved */
unsigned int deleted : 1;
unsigned int changed : 1;
unsigned int attach_del : 1; /* has an attachment marked for deletion */
-Index: trash/mx.c
+Index: mutt/mx.c
===================================================================
---- trash.orig/mx.c 2007-02-15 19:38:00.436905696 +0100
-+++ trash/mx.c 2007-02-15 19:39:57.482112120 +0100
-@@ -852,6 +852,7 @@ static int trash_append (CONTEXT *ctx)
+--- mutt.orig/mx.c 2009-06-25 12:36:10.000000000 +0200
++++ mutt/mx.c 2009-06-25 12:36:14.000000000 +0200
+@@ -803,6 +803,7 @@
{
for (i = 0 ; i < ctx->msgcount ; i++)
if (ctx->hdrs[i]->deleted && !ctx->hdrs[i]->appended
&& mutt_append_message (ctx_trash, ctx, ctx->hdrs[i], 0, 0) == -1)
{
mx_close_mailbox (ctx_trash, NULL);
-Index: trash/pager.c
+Index: mutt/pager.c
===================================================================
---- trash.orig/pager.c 2006-12-12 14:15:03.000000000 +0100
-+++ trash/pager.c 2007-02-15 19:39:57.482112120 +0100
-@@ -2254,12 +2254,15 @@ search_next:
+--- mutt.orig/pager.c 2009-06-25 12:35:44.000000000 +0200
++++ mutt/pager.c 2009-06-25 12:36:14.000000000 +0200
+@@ -2316,12 +2316,15 @@
MAYBE_REDRAW (redraw);
break;
if (option (OPTDELETEUNTAG))
mutt_set_flag (Context, extra->hdr, M_TAG, 0);
redraw = REDRAW_STATUS | REDRAW_INDEX;
-@@ -2572,6 +2575,7 @@ search_next:
+@@ -2648,6 +2651,7 @@
CHECK_ACL(M_ACL_DELETE, _("undelete message"));
mutt_set_flag (Context, extra->hdr, M_DELETE, 0);
redraw = REDRAW_STATUS | REDRAW_INDEX;
if (option (OPTRESOLVE))
{
-@@ -2587,9 +2591,11 @@ search_next:
+@@ -2663,9 +2667,11 @@
CHECK_ACL(M_ACL_DELETE, _("undelete message(s)"));
r = mutt_thread_set_flag (extra->hdr, M_DELETE, 0,
{
if (option (OPTRESOLVE))
{
-Index: trash/pattern.c
+Index: mutt/pattern.c
===================================================================
---- trash.orig/pattern.c 2007-01-25 21:44:41.000000000 +0100
-+++ trash/pattern.c 2007-02-15 19:39:57.483111968 +0100
-@@ -1338,8 +1338,10 @@ int mutt_pattern_func (int op, char *pro
+--- mutt.orig/pattern.c 2009-06-25 12:35:37.000000000 +0200
++++ mutt/pattern.c 2009-06-25 12:36:14.000000000 +0200
+@@ -1347,8 +1347,10 @@
{
switch (op)
{
mutt_set_flag (Context, Context->hdrs[Context->v2r[i]], M_DELETE,
(op == M_DELETE));
break;
-Index: trash/PATCHES
-===================================================================
---- trash.orig/PATCHES 2007-02-15 19:38:00.437905544 +0100
-+++ trash/PATCHES 2007-02-15 19:41:01.724345816 +0100
-@@ -1 +1,2 @@
- patch-1.5.13.cd.trash_folder.3.4
-+patch-1.5.13.cd.purge_message.3.4