]> git.llucax.com Git - software/mutt-debian.git/blobdiff - debian/rules
* Build a mutt-dbg package, and bump DH level to 5.
[software/mutt-debian.git] / debian / rules
index 0deaca25ad57ace98cc3ee3040ac641e6cdd15cf..8579e24067581f6f653e37443fc95cf7d363b0b3 100755 (executable)
@@ -75,12 +75,7 @@ configure: $(objdir)/configure-stamp
 $(objdir)/configure-stamp: $(QUILT_STAMPFN)
        dh_testdir
        
-       #ln -sf /usr/share/misc/config.sub .
-       #ln -sf /usr/share/misc/config.guess .
-       
-       # do not rebuild these files
-       touch configure.ac aclocal.m4 Makefile.in configure config.h.in
-       
+       autoreconf --install --include=m4
        -mkdir $(objdir)
        cd $(objdir) && \
        env CFLAGS="$(CFLAGS)" CPPFLAGS="$(CPPFLAGS)" \
@@ -132,9 +127,11 @@ binary binary-arch: build install
        dh_installdocs
        dh_installexamples
        dh_installchangelogs ChangeLog
+       install -m644 debian/mutt.lintian $(CURDIR)/debian/mutt/usr/share/lintian/overrides/mutt
        
+       dh_strip --dbg-package=mutt-dbg
+       rm -rf $(CURDIR)/debian/mutt-dbg/usr/share/doc/mutt-dbg
        dh_link
-       dh_strip
        dh_compress --exclude usr/share/doc/mutt/README.Patches
        dh_fixperms --exclude usr/bin/mutt_dotlock
        dh_installdeb
@@ -152,12 +149,18 @@ clean: unpatch
        
        # please dpkg-source
        rm -f po/*.gmo
-       #rm -f config.guess config.sub
        touch PATCHES
        
        # remove build tree
        rm -rf $(objdir)
        
+       # remove autotool-generated files so they don't show up in the diff.gz
+       rm -f configure config.h.in
+       rm -f Makefile.in contrib/Makefile.in imap/Makefile.in doc/Makefile.in m4/Makefile.in
+       
+       # clean PATCHES hunks (blame quilt refresh)
+       for p in `grep -rl PATCHES debian/patches` ; do perl -wi debian/fix-PATCHES.pl $$p ; done
+       
        dh_clean
 
 .PHONY: configure build build-arch build-indep clean install binary binary-arch binary-indep patch