---- init.c.orig
-+++ init.c
-@@ -46,6 +46,7 @@
+If /etc/mailname is present, the hostname inside the file will be
+used, rather than calling gethostbyname() on the actual hostname
+
+--- a/init.c
++++ b/init.c
+@@ -48,6 +48,7 @@
#include <unistd.h>
#include <string.h>
#include <sys/utsname.h>
+#include <netdb.h>
#include <errno.h>
#include <sys/wait.h>
-
-@@ -2770,6 +2771,31 @@
- return 0;
+ #include <sys/time.h>
+@@ -2952,6 +2953,31 @@
+ srandom(seed);
}
+int getmailname(char *s, size_t l)
void mutt_init (int skip_sys_rc, LIST *commands)
{
struct passwd *pw;
-@@ -2841,10 +2867,25 @@
+@@ -3027,10 +3053,25 @@
Hostname = mutt_substrdup (utsname.nodename, p);
p++;
strfcpy (buffer, p, sizeof (buffer)); /* save the domain for below */