http://www.spinnaker.de/mutt/compressed/
* Patch last synced with upstream:
- - Date: 2007-06-14
- - File: http://www.spinnaker.de/mutt/compressed/patch-1.5.16.rr.compressed.1.gz
+ - Date: 2008-05-20
+ - File: http://www.spinnaker.de/mutt/compressed/patch-1.5.18.rr.compressed.1.gz
* Changes made:
- - 2007-06-14 myon: remove hunks for Muttrc*
+ - 2008-05-20 myon: refreshed to remove hunks in auto* files
+ - 2009-09-15 myon: refreshed for mutt-1.5.19
+ status.c:103: add sizeof (tmp) to mutt_pretty_mailbox
+ - 2009-09-15 scotton: removed doc/Muttrc for mutt-1.5.19 (only patch doc/Muttrc.head)
+ - 2009-09-11 antonio: removed DefaultMagic, see 541360
+ - 2010-05-31 myon: remove commented paragraph "Use folders..." in
+ doc/Muttrc.head, see #578096
== END PATCH
-Index: debian-mutt/compress.c
-===================================================================
---- /dev/null 1970-01-01 00:00:00.000000000 +0000
-+++ debian-mutt/compress.c 2007-06-14 10:57:02.000000000 +0200
-@@ -0,0 +1,499 @@
+--- /dev/null
++++ b/compress.c
+@@ -0,0 +1,496 @@
+/*
+ * Copyright (C) 1997 Alain Penders <Alain@Finale-Dev.com>
+ *
+ ctx->realpath = ctx->path;
+
+ /* Uncompress to /tmp */
-+ mutt_mktemp (tmppath);
++ mutt_mktemp (tmppath, sizeof(tmppath));
+ ctx->path = safe_malloc (strlen (tmppath) + 1);
+ strcpy (ctx->path, tmppath);
+}
+static char *get_compression_cmd (const char* cmd, const CONTEXT* ctx)
+{
+ char expanded[_POSIX_PATH_MAX];
-+ mutt_FormatString (expanded, sizeof (expanded), 0, cmd,
++ mutt_FormatString (expanded, sizeof (expanded), 0, cmd,
+ compresshook_format_str, (unsigned long) ctx, 0);
+ return safe_strdup (expanded);
+}
+
+ set_path (ctx);
+
-+ ctx->magic = DefaultMagic;
-+
+ if (!is_new (ctx->realpath))
-+ if (ctx->magic == M_MBOX || ctx->magic == M_MMDF)
+ if ((fh = fopen (ctx->path, "w")))
+ fclose (fh);
+ /* No error checking - the parent function will catch it */
+ fclose (ctx->fp);
+ ctx->fp = NULL;
+ /* if the folder was removed, remove the gzipped folder too */
-+ if ((ctx->magic > 0)
-+ && (access (ctx->path, F_OK) != 0)
++ if ((ctx->magic > 0)
++ && (access (ctx->path, F_OK) != 0)
+ && ! option (OPTSAVEEMPTY))
+ remove (ctx->realpath);
+ else
+ if (! (ctx->append
+ && ((append = get_append_command (ctx->realpath, ctx))
+ || (append = ci->close))))
-+ {
++ {
+ /* if we can not or should not append, we only have to remove the */
+ /* compressed info, because sync was already called */
+ mutt_fast_close_compressed (ctx);
+}
+
+#endif /* USE_COMPRESSED */
-Index: debian-mutt/compress.h
-===================================================================
---- /dev/null 1970-01-01 00:00:00.000000000 +0000
-+++ debian-mutt/compress.h 2007-06-14 10:57:02.000000000 +0200
+--- /dev/null
++++ b/compress.h
@@ -0,0 +1,27 @@
+/*
+ * Copyright (C) 1997 Alain Penders <Alain@Finale-Dev.com>
+int mutt_test_compress_command (const char *);
+int mutt_check_mailbox_compressed (CONTEXT *);
+void mutt_fast_close_compressed (CONTEXT *);
-Index: debian-mutt/config.h.in
-===================================================================
---- debian-mutt.orig/config.h.in 2007-06-14 10:54:19.000000000 +0200
-+++ debian-mutt/config.h.in 2007-06-14 10:57:02.000000000 +0200
-@@ -513,6 +513,9 @@
- /* Define to enable Sun mailtool attachments support. */
- #undef SUN_ATTACHMENT
-
-+/* Define to enable compressed mailboxes support */
-+#undef USE_COMPRESSED
-+
- /* Define to use dotlocking for mailboxes. */
- #undef USE_DOTLOCK
-
-Index: debian-mutt/configure
-===================================================================
---- debian-mutt.orig/configure 2007-06-14 10:54:19.000000000 +0200
-+++ debian-mutt/configure 2007-06-14 10:57:02.000000000 +0200
-@@ -1371,6 +1371,7 @@ Optional Features:
- --enable-hcache Enable header caching
- --disable-iconv Disable iconv support
- --disable-nls Do not use Native Language Support
-+ --enable-compressed Enable compressed folders support
-
- Optional Packages:
- --with-PACKAGE[=ARG] use PACKAGE [ARG=yes]
-@@ -15105,6 +15106,17 @@ _ACEOF
- fi
-
-
-+# Check whether --enable-compressed or --disable-compressed was given.
-+if test "${enable_compressed+set}" = set; then
-+ enableval="$enable_compressed"; if test x$enableval = xyes; then
-+
-+cat >>confdefs.h <<\_ACEOF
-+#define USE_COMPRESSED 1
-+_ACEOF
-+
-+ fi
-+fi
-+
-
- # Check whether --with-exec-shell was given.
- if test "${with_exec_shell+set}" = set; then
-Index: debian-mutt/configure.ac
-===================================================================
---- debian-mutt.orig/configure.ac 2007-06-14 10:54:19.000000000 +0200
-+++ debian-mutt/configure.ac 2007-06-14 10:57:02.000000000 +0200
-@@ -785,6 +785,11 @@ AC_ARG_ENABLE(locales-fix, AC_HELP_STRIN
+--- a/configure.ac
++++ b/configure.ac
+@@ -812,6 +812,11 @@
AC_DEFINE(LOCALES_HACK,1,[ Define if the result of isprint() is unreliable. ])
fi])
AC_ARG_WITH(exec-shell, AC_HELP_STRING([--with-exec-shell=SHELL], [Specify alternate shell (ONLY if /bin/sh is broken)]),
[if test $withval != yes; then
AC_DEFINE_UNQUOTED(EXECSHELL, "$withval",
-Index: debian-mutt/curs_main.c
-===================================================================
---- debian-mutt.orig/curs_main.c 2007-06-14 10:54:19.000000000 +0200
-+++ debian-mutt/curs_main.c 2007-06-14 10:57:02.000000000 +0200
-@@ -1111,6 +1111,11 @@ int mutt_index_menu (void)
+--- a/curs_main.c
++++ b/curs_main.c
+@@ -1153,6 +1153,11 @@
{
int check;
mutt_str_replace (&LastFolder, Context->path);
oldcount = Context ? Context->msgcount : 0;
-Index: debian-mutt/doc/manual.xml.head
-===================================================================
---- debian-mutt.orig/doc/manual.xml.head 2007-06-14 10:54:19.000000000 +0200
-+++ debian-mutt/doc/manual.xml.head 2007-06-14 10:57:02.000000000 +0200
-@@ -4910,6 +4910,205 @@ becomes an issue as mutt will silently f
+--- a/doc/manual.xml.head
++++ b/doc/manual.xml.head
+@@ -6116,6 +6116,205 @@
</chapter>
+For example:
+
+<screen>
-+open-hook \\.gz$ "gzip -cd %f > %t"
++open-hook \\.gz$ "gzip -cd %f > %t"
+close-hook \\.gz$ "gzip -c %t > %f"
-+append-hook \\.gz$ "gzip -c %t >> %f"
++append-hook \\.gz$ "gzip -c %t >> %f"
+</screen>
+
+You do not have to specify all of the commands. If you omit <link
+Example:
+
+<screen>
-+open-hook \\.gz$ "gzip -cd %f > %t"
++open-hook \\.gz$ "gzip -cd %f > %t"
+</screen>
+
+If the <emphasis>command</emphasis> is empty, this operation is
+Example:
+
+<screen>
-+append-hook \\.gz$ "gzip -c %t >> %f"
++append-hook \\.gz$ "gzip -c %t >> %f"
+</screen>
+
+When <link linkend="append-hook">append-hook</link> is used, the folder
<chapter id="mimesupport">
<title>Mutt's MIME Support</title>
-Index: debian-mutt/doc/muttrc.man.head
-===================================================================
---- debian-mutt.orig/doc/muttrc.man.head 2007-06-14 10:54:19.000000000 +0200
-+++ debian-mutt/doc/muttrc.man.head 2007-06-14 10:57:02.000000000 +0200
-@@ -345,6 +345,24 @@ specify the ID of the public key to be u
+--- a/doc/muttrc.man.head
++++ b/doc/muttrc.man.head
+@@ -346,6 +346,24 @@
to a certain recipient. The meaning of "key ID" is to be taken
broadly: This can be a different e-mail address, a numerical key ID,
or even just an arbitrary search string.
+"\fI\\\\.gz$\fP"). The commands tell Mutt how to uncompress a folder
+(\fBopen-hook\fP), compress a folder (\fBclose-hook\fP) or append a
+compressed mail to a compressed folder (\fBappend-hook\fP). The
-+\fIcommand\fP string is the
++\fIcommand\fP string is the
+.BR printf (3)
+like format string, and it should accept two parameters: \fB%f\fP,
+which is replaced with the (compressed) folder name, and \fB%t\fP
.TP
\fBpush\fP \fIstring\fP
This command adds the named \fIstring\fP to the keyboard buffer.
-Index: debian-mutt/hook.c
-===================================================================
---- debian-mutt.orig/hook.c 2007-06-14 10:54:19.000000000 +0200
-+++ debian-mutt/hook.c 2007-06-14 10:57:02.000000000 +0200
+--- a/hook.c
++++ b/hook.c
@@ -24,6 +24,10 @@
#include "mailbox.h"
#include "mutt_crypt.h"
#include <limits.h>
#include <string.h>
#include <stdlib.h>
-@@ -92,6 +96,16 @@ int mutt_parse_hook (BUFFER *buf, BUFFER
+@@ -92,6 +96,16 @@
memset (&pattern, 0, sizeof (pattern));
pattern.data = safe_strdup (path);
}
else if (DefaultHook && !(data & (M_CHARSETHOOK | M_ICONVHOOK | M_ACCOUNTHOOK))
&& (!WithCrypto || !(data & M_CRYPTHOOK))
)
-Index: debian-mutt/init.h
-===================================================================
---- debian-mutt.orig/init.h 2007-06-14 10:54:19.000000000 +0200
-+++ debian-mutt/init.h 2007-06-14 10:57:02.000000000 +0200
-@@ -3129,6 +3129,11 @@ struct command_t Commands[] = {
+--- a/init.h
++++ b/init.h
+@@ -3530,6 +3530,11 @@
{ "fcc-hook", mutt_parse_hook, M_FCCHOOK },
{ "fcc-save-hook", mutt_parse_hook, M_FCCHOOK | M_SAVEHOOK },
{ "folder-hook", mutt_parse_hook, M_FOLDERHOOK },
+ { "close-hook", mutt_parse_hook, M_CLOSEHOOK },
+ { "append-hook", mutt_parse_hook, M_APPENDHOOK },
+#endif
- { "group", parse_group, 0 },
- { "ungroup", parse_ungroup, 0 },
+ { "group", parse_group, M_GROUP },
+ { "ungroup", parse_group, M_UNGROUP },
{ "hdr_order", parse_list, UL &HeaderOrderList },
-Index: debian-mutt/main.c
-===================================================================
---- debian-mutt.orig/main.c 2007-06-14 10:54:19.000000000 +0200
-+++ debian-mutt/main.c 2007-06-14 10:57:02.000000000 +0200
-@@ -401,6 +401,12 @@ static void show_version (void)
+--- a/main.c
++++ b/main.c
+@@ -401,6 +401,12 @@
#else
"-LOCALES_HACK "
#endif
#ifdef HAVE_WC_FUNCS
"+HAVE_WC_FUNCS "
-Index: debian-mutt/Makefile.am
-===================================================================
---- debian-mutt.orig/Makefile.am 2007-06-14 10:54:19.000000000 +0200
-+++ debian-mutt/Makefile.am 2007-06-14 10:57:02.000000000 +0200
-@@ -18,7 +18,7 @@ BUILT_SOURCES = keymap_defs.h patchlist.
+--- a/Makefile.am
++++ b/Makefile.am
+@@ -22,7 +22,7 @@
bin_PROGRAMS = mutt @DOTLOCK_TARGET@ @PGPAUX_TARGET@
- mutt_SOURCES = $(BUILT_SOURCES) \
- addrbook.c alias.c attach.c base64.c browser.c buffy.c color.c \
-- crypt.c cryptglue.c \
-+ crypt.c cryptglue.c compress.c \
- commands.c complete.c compose.c copy.c curs_lib.c curs_main.c date.c \
- edit.c enter.c flags.c init.c filter.c from.c \
- getdomain.c group.c \
-@@ -66,7 +66,7 @@ EXTRA_mutt_SOURCES = account.c md5c.c mu
- utf8.c wcwidth.c
-
- EXTRA_DIST = COPYRIGHT GPL OPS OPS.PGP OPS.CRYPT OPS.SMIME TODO UPDATING \
-- configure account.h \
-+ configure account.h compress.h \
- attach.h buffy.h charset.h copy.h crypthash.h dotlock.h functions.h gen_defs \
- globals.h hash.h history.h init.h keymap.h mutt_crypt.h \
- mailbox.h mapping.h md5.h mime.h mutt.h mutt_curses.h mutt_menu.h \
-Index: debian-mutt/Makefile.in
-===================================================================
---- debian-mutt.orig/Makefile.in 2007-06-14 10:54:19.000000000 +0200
-+++ debian-mutt/Makefile.in 2007-06-14 10:57:02.000000000 +0200
-@@ -74,7 +74,7 @@ am_mutt_OBJECTS = $(am__objects_1) addrb
- attach.$(OBJEXT) base64.$(OBJEXT) browser.$(OBJEXT) \
- buffy.$(OBJEXT) color.$(OBJEXT) crypt.$(OBJEXT) \
- cryptglue.$(OBJEXT) commands.$(OBJEXT) complete.$(OBJEXT) \
-- compose.$(OBJEXT) copy.$(OBJEXT) curs_lib.$(OBJEXT) \
-+ compose.$(OBJEXT) compress.$(OBJEXT) copy.$(OBJEXT) curs_lib.$(OBJEXT) \
- curs_main.$(OBJEXT) date.$(OBJEXT) edit.$(OBJEXT) \
- enter.$(OBJEXT) flags.$(OBJEXT) init.$(OBJEXT) \
- filter.$(OBJEXT) from.$(OBJEXT) getdomain.$(OBJEXT) \
-@@ -302,7 +302,7 @@ bin_SCRIPTS = muttbug flea @SMIMEAUX_TAR
- BUILT_SOURCES = keymap_defs.h patchlist.c reldate.h hcversion.h
- mutt_SOURCES = $(BUILT_SOURCES) \
+ mutt_SOURCES = \
addrbook.c alias.c attach.c base64.c browser.c buffy.c color.c \
- crypt.c cryptglue.c \
+ crypt.c cryptglue.c compress.c \
commands.c complete.c compose.c copy.c curs_lib.c curs_main.c date.c \
edit.c enter.c flags.c init.c filter.c from.c \
getdomain.c group.c \
-@@ -335,7 +335,7 @@ EXTRA_mutt_SOURCES = account.c md5c.c mu
- utf8.c wcwidth.c
+@@ -61,7 +61,7 @@
+ bcache.h browser.h hcache.h mbyte.h mutt_idna.h remailer.h url.h
EXTRA_DIST = COPYRIGHT GPL OPS OPS.PGP OPS.CRYPT OPS.SMIME TODO UPDATING \
- configure account.h \
attach.h buffy.h charset.h copy.h crypthash.h dotlock.h functions.h gen_defs \
globals.h hash.h history.h init.h keymap.h mutt_crypt.h \
mailbox.h mapping.h md5.h mime.h mutt.h mutt_curses.h mutt_menu.h \
-@@ -507,6 +507,7 @@ distclean-compile:
- @AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/commands.Po@am__quote@
- @AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/complete.Po@am__quote@
- @AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/compose.Po@am__quote@
-+@AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/compress.Po@am__quote@
- @AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/copy.Po@am__quote@
- @AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/crypt-gpgme.Po@am__quote@
- @AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/crypt-mod-pgp-classic.Po@am__quote@
-Index: debian-mutt/mbox.c
-===================================================================
---- debian-mutt.orig/mbox.c 2007-06-14 10:54:19.000000000 +0200
-+++ debian-mutt/mbox.c 2007-06-14 10:57:02.000000000 +0200
+--- a/mbox.c
++++ b/mbox.c
@@ -29,6 +29,10 @@
#include "copy.h"
#include "mutt_curses.h"
#include <sys/stat.h>
#include <dirent.h>
#include <string.h>
-@@ -1026,6 +1030,12 @@ bail: /* Come here in case of disaster
+@@ -1070,6 +1074,12 @@
int mbox_close_mailbox (CONTEXT *ctx)
{
mx_unlock_file (ctx->path, fileno (ctx->fp), 1);
mutt_unblock_signals ();
mx_fastclose_mailbox (ctx);
return 0;
-Index: debian-mutt/mutt.h
-===================================================================
---- debian-mutt.orig/mutt.h 2007-06-14 10:54:19.000000000 +0200
-+++ debian-mutt/mutt.h 2007-06-14 10:57:02.000000000 +0200
-@@ -160,6 +160,11 @@ typedef enum
+--- a/mutt.h
++++ b/mutt.h
+@@ -146,6 +146,11 @@
#define M_ACCOUNTHOOK (1<<9)
#define M_REPLYHOOK (1<<10)
#define M_SEND2HOOK (1<<11)
/* tree characters for linearize_tree and print_enriched_string */
#define M_TREE_LLCORNER 1
-@@ -885,6 +890,11 @@ typedef struct _context
+@@ -887,6 +892,11 @@
int flagged; /* how many flagged messages */
int msgnotreadyet; /* which msg "new" in pager, -1 if none */
short magic; /* mailbox type */
unsigned char rights[(RIGHTSMAX + 7)/8]; /* ACL bits */
-Index: debian-mutt/mx.c
-===================================================================
---- debian-mutt.orig/mx.c 2007-06-14 10:54:19.000000000 +0200
-+++ debian-mutt/mx.c 2007-06-14 10:57:02.000000000 +0200
+--- a/mx.c
++++ b/mx.c
@@ -30,6 +30,10 @@
#include "keymap.h"
#include "url.h"
#ifdef USE_IMAP
#include "imap.h"
#endif
-@@ -450,6 +454,10 @@ int mx_get_magic (const char *path)
+@@ -414,6 +418,10 @@
return (-1);
}
return (magic);
}
-@@ -489,6 +497,13 @@ static int mx_open_mailbox_append (CONTE
+@@ -453,6 +461,13 @@
{
struct stat sb;
ctx->append = 1;
#ifdef USE_IMAP
-@@ -652,7 +667,12 @@ CONTEXT *mx_open_mailbox (const char *pa
+@@ -616,7 +631,12 @@
}
ctx->magic = mx_get_magic (path);
if(ctx->magic == 0)
mutt_error (_("%s is not a mailbox."), path);
-@@ -753,6 +773,10 @@ void mx_fastclose_mailbox (CONTEXT *ctx)
+@@ -721,6 +741,10 @@
mutt_free_header (&ctx->hdrs[i]);
FREE (&ctx->hdrs);
FREE (&ctx->v2r);
FREE (&ctx->path);
FREE (&ctx->pattern);
if (ctx->limit_pattern)
-@@ -805,6 +829,12 @@ static int sync_mailbox (CONTEXT *ctx, i
+@@ -773,6 +797,12 @@
if (tmp && tmp->new == 0)
mutt_update_mailbox (tmp);
return rc;
}
-@@ -1006,6 +1036,11 @@ int mx_close_mailbox (CONTEXT *ctx, int
+@@ -1043,6 +1073,11 @@
!mutt_is_spool(ctx->path) && !option (OPTSAVEEMPTY))
mx_unlink_empty (ctx->path);
mx_fastclose_mailbox (ctx);
return 0;
-@@ -1315,6 +1350,11 @@ int mx_check_mailbox (CONTEXT *ctx, int
+@@ -1361,6 +1396,11 @@
{
int rc;
if (ctx)
{
if (ctx->locked) lock = 0;
-Index: debian-mutt/mx.h
-===================================================================
---- debian-mutt.orig/mx.h 2007-06-14 10:54:19.000000000 +0200
-+++ debian-mutt/mx.h 2007-06-14 10:57:02.000000000 +0200
-@@ -40,6 +40,9 @@ enum
- #ifdef USE_POP
- , M_POP
- #endif
+--- a/mx.h
++++ b/mx.h
+@@ -36,6 +36,9 @@
+ M_MAILDIR,
+ M_IMAP,
+ M_POP
+#ifdef USE_COMPRESSED
+ , M_COMPRESSED
+#endif
};
WHERE short DefaultMagic INITVAL (M_MBOX);
-Index: debian-mutt/PATCHES
-===================================================================
---- /dev/null 1970-01-01 00:00:00.000000000 +0000
-+++ debian-mutt/PATCHES 2007-06-14 10:57:02.000000000 +0200
-@@ -0,0 +1 @@
-+patch-1.5.16.rr.compressed.1
-Index: debian-mutt/po/de.po
-===================================================================
---- debian-mutt.orig/po/de.po 2007-06-14 10:54:19.000000000 +0200
-+++ debian-mutt/po/de.po 2007-06-14 10:57:02.000000000 +0200
-@@ -1279,6 +1279,48 @@ msgstr "Prüfung des Absenders fehlgeschl
- msgid "Failed to figure out sender"
- msgstr "Kann Absender nicht ermitteln"
+--- a/po/POTFILES.in
++++ b/po/POTFILES.in
+@@ -8,6 +8,7 @@
+ color.c
+ commands.c
+ compose.c
++compress.c
+ crypt-gpgme.c
+ crypt.c
+ cryptglue.c
+--- a/status.c
++++ b/status.c
+@@ -96,6 +96,14 @@
+
+ case 'f':
+ snprintf (fmt, sizeof(fmt), "%%%ss", prefix);
++#ifdef USE_COMPRESSED
++ if (Context && Context->compressinfo && Context->realpath)
++ {
++ strfcpy (tmp, Context->realpath, sizeof (tmp));
++ mutt_pretty_mailbox (tmp, sizeof (tmp));
++ }
++ else
++#endif
+ if (Context && Context->path)
+ {
+ strfcpy (tmp, Context->path, sizeof (tmp));
+--- a/po/de.po
++++ b/po/de.po
+@@ -5159,6 +5159,36 @@
+ msgid "show S/MIME options"
+ msgstr "Zeige S/MIME Optionen"
-+#: compress.c:203 mbox.c:661
-+msgid "Mailbox was corrupted!"
-+msgstr "Mailbox wurde zerstört!"
+
+#: compress.c:228 compress.c:253
+#, c-format
+msgid "Decompressing %s...\n"
+msgstr "Entpacke %s...\n"
+
-+#: compress.c:246 compress.c:367 compress.c:443 mbox.c:706
-+msgid "Unable to lock mailbox!"
-+msgstr "Kann Mailbox nicht für exklusiven Zugriff sperren!"
-+
-+#: compress.c:264
-+#, c-format
-+msgid "Error executing: %s : unable to open the mailbox!\n"
-+msgstr "Fehler beim Ausführen von %s : Kann die Mailbox nicht öffnen!\n"
-+
+#: compress.c:350 compress.c:377 compress.c:423 compress.c:454
+#, c-format
+msgid "Compressing %s...\n"
+msgid " %s: Error compressing mailbox! Uncompressed one kept!\n"
+msgstr " %s: Fehler beim packen der Mailbox! Entpackte Mailbox gespeichert!\n"
+
- #: crypt.c:69
- #, c-format
- msgid " (current time: %c)"
-@@ -1948,6 +1990,10 @@ msgstr "Hilfe für %s"
- msgid "Bad history file format (line %d)"
- msgstr "Falsches Format der Datei früherer Eingaben (Zeile %d)"
-
-+#: hook.c:96
-+msgid "badly formatted command string"
-+msgstr "Hook enthält nicht die Muster %f und %t"
-+
- #: hook.c:251
- #, c-format
- msgid "unhook: Can't do unhook * from within a hook."
-@@ -3452,18 +3498,10 @@ msgstr "Lese %s..."
- msgid "Mailbox is corrupt!"
- msgstr "Mailbox fehlerhaft!"
+ #~ msgid "Clear"
+ #~ msgstr "Klartext"
--#: mbox.c:670
--msgid "Mailbox was corrupted!"
--msgstr "Mailbox wurde zerstört!"
--
- #: mbox.c:711 mbox.c:964
- msgid "Fatal error! Could not reopen mailbox!"
- msgstr "Fataler Fehler, konnte Mailbox nicht erneut öffnen!"
-
--#: mbox.c:720
--msgid "Unable to lock mailbox!"
--msgstr "Kann Mailbox nicht für exklusiven Zugriff sperren!"
--
- #. this means ctx->changed or ctx->deleted was set, but no
- #. * messages were found to be changed or deleted. This should
- #. * never happen, is we presume it is a bug in mutt.
-Index: debian-mutt/po/POTFILES.in
-===================================================================
---- debian-mutt.orig/po/POTFILES.in 2007-06-14 10:54:19.000000000 +0200
-+++ debian-mutt/po/POTFILES.in 2007-06-14 10:57:02.000000000 +0200
-@@ -8,6 +8,7 @@ charset.c
- color.c
- commands.c
- compose.c
-+compress.c
- crypt-gpgme.c
- crypt.c
- cryptglue.c
-Index: debian-mutt/status.c
-===================================================================
---- debian-mutt.orig/status.c 2007-06-14 10:54:19.000000000 +0200
-+++ debian-mutt/status.c 2007-06-14 10:57:02.000000000 +0200
-@@ -99,6 +99,14 @@ status_format_str (char *buf, size_t buf
-
- case 'f':
- snprintf (fmt, sizeof(fmt), "%%%ss", prefix);
-+#ifdef USE_COMPRESSED
-+ if (Context && Context->compressinfo && Context->realpath)
-+ {
-+ strfcpy (tmp, Context->realpath, sizeof (tmp));
-+ mutt_pretty_mailbox (tmp);
-+ }
-+ else
-+#endif
- if (Context && Context->path)
- {
- strfcpy (tmp, Context->path, sizeof (tmp));