]> git.llucax.com Git - software/mutt-debian.git/blobdiff - debian/patches/features/sensible_browser_position
Grab two patches from upstream that should also go into lenny
[software/mutt-debian.git] / debian / patches / features / sensible_browser_position
index fd34e32bf536a9d51c3a744d31730a8912dea5fb..3ee8ce2cdf6f5f614c4557e3fc43f202485c3c2c 100644 (file)
@@ -3,13 +3,12 @@ This is the sensible browser position patch by Haakon Riiser.
 
   * Found in: <20050309162127.GA5656@s>
     http://lists.df7cb.de/mutt/message/20050309.162127.a244a894.en.html
 
   * Found in: <20050309162127.GA5656@s>
     http://lists.df7cb.de/mutt/message/20050309.162127.a244a894.en.html
+  * myon 2009-01-15: refreshed for mutt-1.5.19
 
 == END PATCH
 
 == END PATCH
-Index: debian-mutt/menu.c
-===================================================================
---- debian-mutt.orig/menu.c    2007-03-24 18:45:30.000000000 +0100
-+++ debian-mutt/menu.c 2007-06-28 21:48:47.000000000 +0200
-@@ -840,8 +840,12 @@ int menu_redraw (MUTTMENU *menu)
+--- a/menu.c
++++ b/menu.c
+@@ -859,8 +859,12 @@ int menu_redraw (MUTTMENU *menu)
  
  int mutt_menuLoop (MUTTMENU *menu)
  {
  
  int mutt_menuLoop (MUTTMENU *menu)
  {
@@ -22,7 +21,7 @@ Index: debian-mutt/menu.c
    FOREVER
    {
      if (option (OPTMENUCALLER))
    FOREVER
    {
      if (option (OPTMENUCALLER))
-@@ -1073,6 +1077,8 @@ int mutt_menuLoop (MUTTMENU *menu)
+@@ -1088,6 +1092,8 @@ int mutt_menuLoop (MUTTMENU *menu)
        break;
  
        default:
        break;
  
        default:
@@ -31,10 +30,8 @@ Index: debian-mutt/menu.c
        return (i);
      }
    }
        return (i);
      }
    }
-Index: debian-mutt/browser.c
-===================================================================
---- debian-mutt.orig/browser.c 2007-06-28 21:41:27.000000000 +0200
-+++ debian-mutt/browser.c      2007-06-28 21:48:47.000000000 +0200
+--- a/browser.c
++++ b/browser.c
 @@ -56,6 +56,7 @@ typedef struct folder_t
    int num;
  } FOLDER;
 @@ -56,6 +56,7 @@ typedef struct folder_t
    int num;
  } FOLDER;
@@ -43,7 +40,7 @@ Index: debian-mutt/browser.c
  static char LastDir[_POSIX_PATH_MAX] = "";
  static char LastDirBackup[_POSIX_PATH_MAX] = "";
  
  static char LastDir[_POSIX_PATH_MAX] = "";
  static char LastDirBackup[_POSIX_PATH_MAX] = "";
  
-@@ -510,19 +511,38 @@ static void init_menu (struct browser_st
+@@ -511,9 +512,13 @@ static void init_menu (struct browser_st
    menu->tagged = 0;
    
    if (buffy)
    menu->tagged = 0;
    
    if (buffy)
@@ -55,16 +52,11 @@ Index: debian-mutt/browser.c
    {
 +    menu->is_mailbox_list = 0;
      strfcpy (path, LastDir, sizeof (path));
    {
 +    menu->is_mailbox_list = 0;
      strfcpy (path, LastDir, sizeof (path));
-     mutt_pretty_mailbox (path);
+     mutt_pretty_mailbox (path, sizeof (path));
  #ifdef USE_IMAP
  #ifdef USE_IMAP
--  if (state->imap_browse && option (OPTIMAPLSUB))
--    snprintf (title, titlelen, _("Subscribed [%s], File mask: %s"),
--            path, NONULL (Mask.pattern));
--  else
-+    if (state->imap_browse && option (OPTIMAPLSUB))
-+      snprintf (title, titlelen, _("Subscribed [%s], File mask: %s"),
-+              path, NONULL (Mask.pattern));
-+    else
+@@ -522,8 +527,23 @@ static void init_menu (struct browser_st
+             path, NONULL (Mask.pattern));
+   else
  #endif
 -    snprintf (title, titlelen, _("Directory [%s], File mask: %s"),
 -            path, NONULL(Mask.pattern));
  #endif
 -    snprintf (title, titlelen, _("Directory [%s], File mask: %s"),
 -            path, NONULL(Mask.pattern));
@@ -96,10 +88,8 @@ Index: debian-mutt/browser.c
  
            /* save the old directory */
            strfcpy (OldLastDir, LastDir, sizeof (OldLastDir));
  
            /* save the old directory */
            strfcpy (OldLastDir, LastDir, sizeof (OldLastDir));
-Index: debian-mutt/mutt_menu.h
-===================================================================
---- debian-mutt.orig/mutt_menu.h       2007-03-20 20:42:04.000000000 +0100
-+++ debian-mutt/mutt_menu.h    2007-06-28 21:48:47.000000000 +0200
+--- a/mutt_menu.h
++++ b/mutt_menu.h
 @@ -49,6 +49,7 @@ typedef struct menu_t
    int offset; /* which screen row to start the index */
    int pagelen;        /* number of entries per screen */
 @@ -49,6 +49,7 @@ typedef struct menu_t
    int offset; /* which screen row to start the index */
    int pagelen;        /* number of entries per screen */
@@ -108,12 +98,3 @@ Index: debian-mutt/mutt_menu.h
  
    /* Setting dialog != NULL overrides normal menu behaviour. 
     * In dialog mode menubar is hidden and prompt keys are checked before
  
    /* Setting dialog != NULL overrides normal menu behaviour. 
     * In dialog mode menubar is hidden and prompt keys are checked before
-Index: debian-mutt/PATCHES
-===================================================================
---- debian-mutt.orig/PATCHES   2007-06-28 21:49:06.000000000 +0200
-+++ debian-mutt/PATCHES        2007-06-28 21:49:20.000000000 +0200
-@@ -4,3 +4,4 @@ patch-1.5.13.nt+ab.xtitles.4
- patch-1.5.6.dw.maildir-mtime.1
- patch-1.5.13.cd.ifdef.2
- patch-1.5.16.rr.compressed.1
-+patch-1.5.8.hr.sensible_browser_position.3