]> git.llucax.com Git - software/mutt-debian.git/blobdiff - debian/patches/features/compressed-folders
upstream/544794-smtp-batch.patch: mutt won't ask for a password if smtp_user and...
[software/mutt-debian.git] / debian / patches / features / compressed-folders
index 8c38b9d9d6f3ffa388985e122f90ed148f1c5a67..16baf3cfd2356084dc08ff9e7ae5d14aca72066b 100644 (file)
@@ -15,11 +15,12 @@ The home page for this patch is:
   - 2009-09-15 myon: refreshed for mutt-1.5.19
                      status.c:103: add sizeof (tmp) to mutt_pretty_mailbox
   - 2009-09-15 scotton: removed doc/Muttrc for mutt-1.5.19 (only patch doc/Muttrc.head)
+  - 2009-09-11 antonio: removed DefaultMagic, see 541360
 
 == END PATCH
 --- /dev/null
 +++ b/compress.c
-@@ -0,0 +1,499 @@
+@@ -0,0 +1,496 @@
 +/*
 + * Copyright (C) 1997 Alain Penders <Alain@Finale-Dev.com>
 + *
@@ -343,10 +344,7 @@ The home page for this patch is:
 +
 +  set_path (ctx);
 +
-+  ctx->magic = DefaultMagic;
-+
 +  if (!is_new (ctx->realpath))
-+    if (ctx->magic == M_MBOX || ctx->magic == M_MMDF)
 +      if ((fh = fopen (ctx->path, "w")))
 +      fclose (fh);
 +  /* No error checking - the parent function will catch it */
@@ -858,7 +856,7 @@ The home page for this patch is:
        )
 --- a/init.h
 +++ b/init.h
-@@ -3514,6 +3514,11 @@
+@@ -3504,6 +3504,11 @@
    { "fcc-hook",               mutt_parse_hook,        M_FCCHOOK },
    { "fcc-save-hook",  mutt_parse_hook,        M_FCCHOOK | M_SAVEHOOK },
    { "folder-hook",    mutt_parse_hook,        M_FOLDERHOOK },
@@ -945,7 +943,7 @@ The home page for this patch is:
  
  /* tree characters for linearize_tree and print_enriched_string */
  #define M_TREE_LLCORNER               1
-@@ -883,6 +888,11 @@
+@@ -882,6 +887,11 @@
    int flagged;                        /* how many flagged messages */
    int msgnotreadyet;          /* which msg "new" in pager, -1 if none */