]> git.llucax.com Git - software/mutt-debian.git/blobdiff - debian/patches/features/compressed-folders
#define PATH_MAX _POSIX_PATH_MAX. (Fixed in upstream hg, though differently.)
[software/mutt-debian.git] / debian / patches / features / compressed-folders
index 8c38b9d9d6f3ffa388985e122f90ed148f1c5a67..274aec212d0a54c8e05c73646fa3b3024107bd19 100644 (file)
@@ -15,11 +15,14 @@ The home page for this patch is:
   - 2009-09-15 myon: refreshed for mutt-1.5.19
                      status.c:103: add sizeof (tmp) to mutt_pretty_mailbox
   - 2009-09-15 scotton: removed doc/Muttrc for mutt-1.5.19 (only patch doc/Muttrc.head)
   - 2009-09-15 myon: refreshed for mutt-1.5.19
                      status.c:103: add sizeof (tmp) to mutt_pretty_mailbox
   - 2009-09-15 scotton: removed doc/Muttrc for mutt-1.5.19 (only patch doc/Muttrc.head)
+  - 2009-09-11 antonio: removed DefaultMagic, see 541360
+  - 2010-05-31 myon: remove commented paragraph "Use folders..." in
+                     doc/Muttrc.head, see #578096
 
 == END PATCH
 --- /dev/null
 +++ b/compress.c
 
 == END PATCH
 --- /dev/null
 +++ b/compress.c
-@@ -0,0 +1,499 @@
+@@ -0,0 +1,496 @@
 +/*
 + * Copyright (C) 1997 Alain Penders <Alain@Finale-Dev.com>
 + *
 +/*
 + * Copyright (C) 1997 Alain Penders <Alain@Finale-Dev.com>
 + *
@@ -343,10 +346,7 @@ The home page for this patch is:
 +
 +  set_path (ctx);
 +
 +
 +  set_path (ctx);
 +
-+  ctx->magic = DefaultMagic;
-+
 +  if (!is_new (ctx->realpath))
 +  if (!is_new (ctx->realpath))
-+    if (ctx->magic == M_MBOX || ctx->magic == M_MMDF)
 +      if ((fh = fopen (ctx->path, "w")))
 +      fclose (fh);
 +  /* No error checking - the parent function will catch it */
 +      if ((fh = fopen (ctx->path, "w")))
 +      fclose (fh);
 +  /* No error checking - the parent function will catch it */
@@ -785,20 +785,6 @@ The home page for this patch is:
  <chapter id="mimesupport">
  <title>Mutt's MIME Support</title>
  
  <chapter id="mimesupport">
  <title>Mutt's MIME Support</title>
  
---- a/doc/Muttrc.head
-+++ b/doc/Muttrc.head
-@@ -29,6 +29,11 @@
- macro index,pager y "<change-folder>?<toggle-mailboxes>" "show incoming mailboxes list"
- bind browser y exit
-+# Use folders which match on \\.gz$ as gzipped folders:
-+# open-hook \\.gz$ "gzip -cd %f > %t"
-+# close-hook \\.gz$ "gzip -c %t > %f"
-+# append-hook \\.gz$ "gzip -c %t >> %f"
-+
- # If Mutt is unable to determine your site's domain name correctly, you can
- # set the default here.
- #
 --- a/doc/muttrc.man.head
 +++ b/doc/muttrc.man.head
 @@ -345,6 +345,24 @@
 --- a/doc/muttrc.man.head
 +++ b/doc/muttrc.man.head
 @@ -345,6 +345,24 @@
@@ -858,7 +844,7 @@ The home page for this patch is:
        )
 --- a/init.h
 +++ b/init.h
        )
 --- a/init.h
 +++ b/init.h
-@@ -3514,6 +3514,11 @@
+@@ -3504,6 +3504,11 @@
    { "fcc-hook",               mutt_parse_hook,        M_FCCHOOK },
    { "fcc-save-hook",  mutt_parse_hook,        M_FCCHOOK | M_SAVEHOOK },
    { "folder-hook",    mutt_parse_hook,        M_FOLDERHOOK },
    { "fcc-hook",               mutt_parse_hook,        M_FCCHOOK },
    { "fcc-save-hook",  mutt_parse_hook,        M_FCCHOOK | M_SAVEHOOK },
    { "folder-hook",    mutt_parse_hook,        M_FOLDERHOOK },
@@ -945,7 +931,7 @@ The home page for this patch is:
  
  /* tree characters for linearize_tree and print_enriched_string */
  #define M_TREE_LLCORNER               1
  
  /* tree characters for linearize_tree and print_enriched_string */
  #define M_TREE_LLCORNER               1
-@@ -883,6 +888,11 @@
+@@ -882,6 +887,11 @@
    int flagged;                        /* how many flagged messages */
    int msgnotreadyet;          /* which msg "new" in pager, -1 if none */
  
    int flagged;                        /* how many flagged messages */
    int msgnotreadyet;          /* which msg "new" in pager, -1 if none */