- 2009-09-15 myon: refreshed for mutt-1.5.19
status.c:103: add sizeof (tmp) to mutt_pretty_mailbox
- 2009-09-15 scotton: removed doc/Muttrc for mutt-1.5.19 (only patch doc/Muttrc.head)
+ - 2009-09-11 antonio: removed DefaultMagic, see 541360
== END PATCH
--- /dev/null
+++ b/compress.c
-@@ -0,0 +1,499 @@
+@@ -0,0 +1,496 @@
+/*
+ * Copyright (C) 1997 Alain Penders <Alain@Finale-Dev.com>
+ *
+
+ set_path (ctx);
+
-+ ctx->magic = DefaultMagic;
-+
+ if (!is_new (ctx->realpath))
-+ if (ctx->magic == M_MBOX || ctx->magic == M_MMDF)
+ if ((fh = fopen (ctx->path, "w")))
+ fclose (fh);
+ /* No error checking - the parent function will catch it */
)
--- a/init.h
+++ b/init.h
-@@ -3514,6 +3514,11 @@
+@@ -3504,6 +3504,11 @@
{ "fcc-hook", mutt_parse_hook, M_FCCHOOK },
{ "fcc-save-hook", mutt_parse_hook, M_FCCHOOK | M_SAVEHOOK },
{ "folder-hook", mutt_parse_hook, M_FOLDERHOOK },
/* tree characters for linearize_tree and print_enriched_string */
#define M_TREE_LLCORNER 1
-@@ -883,6 +888,11 @@
+@@ -882,6 +887,11 @@
int flagged; /* how many flagged messages */
int msgnotreadyet; /* which msg "new" in pager, -1 if none */