]> git.llucax.com Git - software/mutt-debian.git/blobdiff - debian/patches/features/trash-folder
adding a missing bug number
[software/mutt-debian.git] / debian / patches / features / trash-folder
index 88410e08db1c2ec15efdb9e19e7b94fa9885a7e9..b8711756f008dab38c9119f249f863242b45ccc8 100644 (file)
@@ -46,9 +46,11 @@ To sum up, it's more integrated and transparent to the user.
   - Fixed indentation of "appended" in mutt.h.
 
 == END PATCH
   - Fixed indentation of "appended" in mutt.h.
 
 == END PATCH
---- a/commands.c
-+++ b/commands.c
-@@ -693,6 +693,7 @@
+Index: mutt/commands.c
+===================================================================
+--- mutt.orig/commands.c       2009-06-25 12:35:37.000000000 +0200
++++ mutt/commands.c    2009-06-25 12:35:48.000000000 +0200
+@@ -716,6 +716,7 @@
      if (option (OPTDELETEUNTAG))
        mutt_set_flag (Context, h, M_TAG, 0);
    }
      if (option (OPTDELETEUNTAG))
        mutt_set_flag (Context, h, M_TAG, 0);
    }
@@ -56,8 +58,10 @@ To sum up, it's more integrated and transparent to the user.
    
    return 0;
  }
    
    return 0;
  }
---- a/flags.c
-+++ b/flags.c
+Index: mutt/flags.c
+===================================================================
+--- mutt.orig/flags.c  2009-06-25 12:35:37.000000000 +0200
++++ mutt/flags.c       2009-06-25 12:35:48.000000000 +0200
 @@ -65,7 +65,13 @@
        {
        h->deleted = 0;
 @@ -65,7 +65,13 @@
        {
        h->deleted = 0;
@@ -91,9 +95,11 @@ To sum up, it's more integrated and transparent to the user.
      case M_NEW:
  
        if (!mutt_bit_isset(ctx->rights,M_ACL_SEEN))
      case M_NEW:
  
        if (!mutt_bit_isset(ctx->rights,M_ACL_SEEN))
---- a/globals.h
-+++ b/globals.h
-@@ -138,6 +138,7 @@
+Index: mutt/globals.h
+===================================================================
+--- mutt.orig/globals.h        2009-06-25 12:35:44.000000000 +0200
++++ mutt/globals.h     2009-06-25 12:35:48.000000000 +0200
+@@ -139,6 +139,7 @@
  WHERE char *Status;
  WHERE char *Tempdir;
  WHERE char *Tochars;
  WHERE char *Status;
  WHERE char *Tempdir;
  WHERE char *Tochars;
@@ -101,9 +107,11 @@ To sum up, it's more integrated and transparent to the user.
  WHERE char *Username;
  WHERE char *Visual;
  WHERE char *XtermTitle;
  WHERE char *Username;
  WHERE char *Visual;
  WHERE char *XtermTitle;
---- a/imap/message.c
-+++ b/imap/message.c
-@@ -859,6 +859,7 @@
+Index: mutt/imap/message.c
+===================================================================
+--- mutt.orig/imap/message.c   2009-06-25 12:35:37.000000000 +0200
++++ mutt/imap/message.c        2009-06-25 12:35:48.000000000 +0200
+@@ -867,6 +867,7 @@
          if (ctx->hdrs[n]->tagged)
          {
            mutt_set_flag (ctx, ctx->hdrs[n], M_DELETE, 1);
          if (ctx->hdrs[n]->tagged)
          {
            mutt_set_flag (ctx, ctx->hdrs[n], M_DELETE, 1);
@@ -111,7 +119,7 @@ To sum up, it's more integrated and transparent to the user.
            if (option (OPTDELETEUNTAG))
              mutt_set_flag (ctx, ctx->hdrs[n], M_TAG, 0);
          }
            if (option (OPTDELETEUNTAG))
              mutt_set_flag (ctx, ctx->hdrs[n], M_TAG, 0);
          }
-@@ -866,6 +867,7 @@
+@@ -874,6 +875,7 @@
      else
      {
        mutt_set_flag (ctx, h, M_DELETE, 1);
      else
      {
        mutt_set_flag (ctx, h, M_DELETE, 1);
@@ -119,9 +127,11 @@ To sum up, it's more integrated and transparent to the user.
        if (option (OPTDELETEUNTAG))
          mutt_set_flag (ctx, h, M_TAG, 0);
      }
        if (option (OPTDELETEUNTAG))
          mutt_set_flag (ctx, h, M_TAG, 0);
      }
---- a/init.h
-+++ b/init.h
-@@ -3138,6 +3138,16 @@
+Index: mutt/init.h
+===================================================================
+--- mutt.orig/init.h   2009-06-25 12:35:44.000000000 +0200
++++ mutt/init.h        2009-06-25 12:35:48.000000000 +0200
+@@ -3180,6 +3180,16 @@
    ** by \fIyou\fP.  The sixth character is used to indicate when a mail
    ** was sent to a mailing-list you subscribe to.
    */
    ** by \fIyou\fP.  The sixth character is used to indicate when a mail
    ** was sent to a mailing-list you subscribe to.
    */
@@ -138,9 +148,11 @@ To sum up, it's more integrated and transparent to the user.
  #ifdef USE_SOCKET
    { "tunnel",            DT_STR, R_NONE, UL &Tunnel, UL 0 },
    /*
  #ifdef USE_SOCKET
    { "tunnel",            DT_STR, R_NONE, UL &Tunnel, UL 0 },
    /*
---- a/mutt.h
-+++ b/mutt.h
-@@ -181,6 +181,7 @@
+Index: mutt/mutt.h
+===================================================================
+--- mutt.orig/mutt.h   2009-06-25 12:35:44.000000000 +0200
++++ mutt/mutt.h        2009-06-25 12:35:48.000000000 +0200
+@@ -187,6 +187,7 @@
    M_DELETE,
    M_UNDELETE,
    M_DELETED,
    M_DELETE,
    M_UNDELETE,
    M_DELETED,
@@ -148,7 +160,7 @@ To sum up, it's more integrated and transparent to the user.
    M_FLAG,
    M_TAG,
    M_UNTAG,
    M_FLAG,
    M_TAG,
    M_UNTAG,
-@@ -693,6 +694,7 @@
+@@ -702,6 +703,7 @@
    unsigned int mime : 1;              /* has a MIME-Version header? */
    unsigned int flagged : 1;           /* marked important? */
    unsigned int tagged : 1;
    unsigned int mime : 1;              /* has a MIME-Version header? */
    unsigned int flagged : 1;           /* marked important? */
    unsigned int tagged : 1;
@@ -156,7 +168,7 @@ To sum up, it's more integrated and transparent to the user.
    unsigned int deleted : 1;
    unsigned int changed : 1;
    unsigned int attach_del : 1;                /* has an attachment marked for deletion */
    unsigned int deleted : 1;
    unsigned int changed : 1;
    unsigned int attach_del : 1;                /* has an attachment marked for deletion */
-@@ -864,6 +866,7 @@
+@@ -874,6 +876,7 @@
    int new;                    /* how many new messages? */
    int unread;                 /* how many unread messages? */
    int deleted;                        /* how many deleted messages */
    int new;                    /* how many new messages? */
    int unread;                 /* how many unread messages? */
    int deleted;                        /* how many deleted messages */
@@ -164,9 +176,11 @@ To sum up, it's more integrated and transparent to the user.
    int flagged;                        /* how many flagged messages */
    int msgnotreadyet;          /* which msg "new" in pager, -1 if none */
  
    int flagged;                        /* how many flagged messages */
    int msgnotreadyet;          /* which msg "new" in pager, -1 if none */
  
---- a/muttlib.c
-+++ b/muttlib.c
-@@ -1445,7 +1445,9 @@
+Index: mutt/muttlib.c
+===================================================================
+--- mutt.orig/muttlib.c        2009-06-25 12:35:37.000000000 +0200
++++ mutt/muttlib.c     2009-06-25 12:35:48.000000000 +0200
+@@ -1460,7 +1460,9 @@
  
    if (magic > 0 && !mx_access (s, W_OK))
    {
  
    if (magic > 0 && !mx_access (s, W_OK))
    {
@@ -177,9 +191,11 @@ To sum up, it's more integrated and transparent to the user.
      {
        snprintf (tmp, sizeof (tmp), _("Append messages to %s?"), s);
        if ((rc = mutt_yesorno (tmp, M_YES)) == M_NO)
      {
        snprintf (tmp, sizeof (tmp), _("Append messages to %s?"), s);
        if ((rc = mutt_yesorno (tmp, M_YES)) == M_NO)
---- a/mx.c
-+++ b/mx.c
-@@ -803,6 +803,53 @@
+Index: mutt/mx.c
+===================================================================
+--- mutt.orig/mx.c     2009-06-25 12:35:37.000000000 +0200
++++ mutt/mx.c  2009-06-25 12:35:48.000000000 +0200
+@@ -773,6 +773,53 @@
    return rc;
  }
  
    return rc;
  }
  
@@ -233,7 +249,7 @@ To sum up, it's more integrated and transparent to the user.
  /* save changes and close mailbox */
  int mx_close_mailbox (CONTEXT *ctx, int *index_hint)
  {
  /* save changes and close mailbox */
  int mx_close_mailbox (CONTEXT *ctx, int *index_hint)
  {
-@@ -938,6 +985,7 @@
+@@ -909,6 +956,7 @@
          if (mutt_append_message (&f, ctx, ctx->hdrs[i], 0, CH_UPDATE_LEN) == 0)
          {
            mutt_set_flag (ctx, ctx->hdrs[i], M_DELETE, 1);
          if (mutt_append_message (&f, ctx, ctx->hdrs[i], 0, CH_UPDATE_LEN) == 0)
          {
            mutt_set_flag (ctx, ctx->hdrs[i], M_DELETE, 1);
@@ -241,7 +257,7 @@ To sum up, it's more integrated and transparent to the user.
          }
          else
          {
          }
          else
          {
-@@ -959,6 +1007,14 @@
+@@ -931,6 +979,14 @@
      return 0;
    }
    
      return 0;
    }
    
@@ -256,7 +272,7 @@ To sum up, it's more integrated and transparent to the user.
  #ifdef USE_IMAP
    /* allow IMAP to preserve the deleted flag across sessions */
    if (ctx->magic == M_IMAP)
  #ifdef USE_IMAP
    /* allow IMAP to preserve the deleted flag across sessions */
    if (ctx->magic == M_IMAP)
-@@ -1154,6 +1210,12 @@
+@@ -1130,6 +1186,12 @@
    msgcount = ctx->msgcount;
    deleted = ctx->deleted;
  
    msgcount = ctx->msgcount;
    deleted = ctx->deleted;
  
@@ -264,13 +280,15 @@ To sum up, it's more integrated and transparent to the user.
 +  {
 +    if (trash_append (ctx) == -1)
 +      return -1;
 +  {
 +    if (trash_append (ctx) == -1)
 +      return -1;
-+  } 
++  }
 +
  #ifdef USE_IMAP
    if (ctx->magic == M_IMAP)
      rc = imap_sync_mailbox (ctx, purge, index_hint);
 +
  #ifdef USE_IMAP
    if (ctx->magic == M_IMAP)
      rc = imap_sync_mailbox (ctx, purge, index_hint);
---- a/postpone.c
-+++ b/postpone.c
+Index: mutt/postpone.c
+===================================================================
+--- mutt.orig/postpone.c       2009-06-25 12:35:37.000000000 +0200
++++ mutt/postpone.c    2009-06-25 12:35:48.000000000 +0200
 @@ -276,6 +276,9 @@
    /* finished with this message, so delete it. */
    mutt_set_flag (PostContext, h, M_DELETE, 1);
 @@ -276,6 +276,9 @@
    /* finished with this message, so delete it. */
    mutt_set_flag (PostContext, h, M_DELETE, 1);