== END PATCH
--- a/commands.c
+++ b/commands.c
-@@ -693,6 +693,7 @@
+@@ -717,6 +717,7 @@
if (option (OPTDELETEUNTAG))
mutt_set_flag (Context, h, M_TAG, 0);
}
if (!mutt_bit_isset(ctx->rights,M_ACL_SEEN))
--- a/globals.h
+++ b/globals.h
-@@ -138,6 +138,7 @@
+@@ -139,6 +139,7 @@
WHERE char *Status;
WHERE char *Tempdir;
WHERE char *Tochars;
WHERE char *XtermTitle;
--- a/imap/message.c
+++ b/imap/message.c
-@@ -859,6 +859,7 @@
+@@ -876,6 +876,7 @@
if (ctx->hdrs[n]->tagged)
{
mutt_set_flag (ctx, ctx->hdrs[n], M_DELETE, 1);
if (option (OPTDELETEUNTAG))
mutt_set_flag (ctx, ctx->hdrs[n], M_TAG, 0);
}
-@@ -866,6 +867,7 @@
+@@ -883,6 +884,7 @@
else
{
mutt_set_flag (ctx, h, M_DELETE, 1);
}
--- a/init.h
+++ b/init.h
-@@ -3138,6 +3138,16 @@
+@@ -3195,6 +3195,16 @@
** by \fIyou\fP. The sixth character is used to indicate when a mail
** was sent to a mailing-list you subscribe to.
*/
/*
--- a/mutt.h
+++ b/mutt.h
-@@ -181,6 +181,7 @@
+@@ -187,6 +187,7 @@
M_DELETE,
M_UNDELETE,
M_DELETED,
M_FLAG,
M_TAG,
M_UNTAG,
-@@ -693,6 +694,7 @@
+@@ -707,6 +708,7 @@
unsigned int mime : 1; /* has a MIME-Version header? */
unsigned int flagged : 1; /* marked important? */
unsigned int tagged : 1;
unsigned int deleted : 1;
unsigned int changed : 1;
unsigned int attach_del : 1; /* has an attachment marked for deletion */
-@@ -864,6 +866,7 @@
+@@ -879,6 +881,7 @@
int new; /* how many new messages? */
int unread; /* how many unread messages? */
int deleted; /* how many deleted messages */
--- a/muttlib.c
+++ b/muttlib.c
-@@ -1445,7 +1445,9 @@
+@@ -1515,7 +1515,9 @@
if (magic > 0 && !mx_access (s, W_OK))
{
if ((rc = mutt_yesorno (tmp, M_YES)) == M_NO)
--- a/mx.c
+++ b/mx.c
-@@ -803,6 +803,53 @@
+@@ -776,6 +776,53 @@
return rc;
}
/* save changes and close mailbox */
int mx_close_mailbox (CONTEXT *ctx, int *index_hint)
{
-@@ -938,6 +985,7 @@
+@@ -912,6 +959,7 @@
if (mutt_append_message (&f, ctx, ctx->hdrs[i], 0, CH_UPDATE_LEN) == 0)
{
mutt_set_flag (ctx, ctx->hdrs[i], M_DELETE, 1);
}
else
{
-@@ -959,6 +1007,14 @@
+@@ -936,6 +984,14 @@
return 0;
}
#ifdef USE_IMAP
/* allow IMAP to preserve the deleted flag across sessions */
if (ctx->magic == M_IMAP)
-@@ -1154,6 +1210,12 @@
+@@ -1133,6 +1189,12 @@
msgcount = ctx->msgcount;
deleted = ctx->deleted;
+ {
+ if (trash_append (ctx) == -1)
+ return -1;
-+ }
++ }
+
#ifdef USE_IMAP
if (ctx->magic == M_IMAP)
rc = imap_sync_mailbox (ctx, purge, index_hint);
--- a/postpone.c
+++ b/postpone.c
-@@ -276,6 +276,9 @@
+@@ -277,6 +277,9 @@
/* finished with this message, so delete it. */
mutt_set_flag (PostContext, h, M_DELETE, 1);