http://lists.df7cb.de/mutt/message/20050309.162127.a244a894.en.html
== END PATCH
---- a/menu.c
-+++ b/menu.c
-@@ -859,8 +859,17 @@
+Index: mutt/menu.c
+===================================================================
+--- mutt.orig/menu.c 2009-06-25 12:35:36.000000000 +0200
++++ mutt/menu.c 2009-06-25 12:36:19.000000000 +0200
+@@ -853,8 +853,17 @@
int mutt_menuLoop (MUTTMENU *menu)
{
FOREVER
{
if (option (OPTMENUCALLER))
-@@ -1088,6 +1097,8 @@
+@@ -1082,6 +1091,8 @@
break;
default:
return (i);
}
}
---- a/browser.c
-+++ b/browser.c
-@@ -56,6 +56,7 @@
+Index: mutt/browser.c
+===================================================================
+--- mutt.orig/browser.c 2009-06-25 12:35:37.000000000 +0200
++++ mutt/browser.c 2009-06-25 12:36:19.000000000 +0200
+@@ -55,6 +55,7 @@
int num;
} FOLDER;
static char LastDir[_POSIX_PATH_MAX] = "";
static char LastDirBackup[_POSIX_PATH_MAX] = "";
-@@ -511,9 +512,13 @@
+@@ -519,9 +520,13 @@
menu->tagged = 0;
if (buffy)
strfcpy (path, LastDir, sizeof (path));
mutt_pretty_mailbox (path, sizeof (path));
#ifdef USE_IMAP
-@@ -522,8 +527,22 @@
+@@ -530,8 +535,22 @@
path, NONULL (Mask.pattern));
else
#endif
}
menu->redraw = REDRAW_FULL;
}
-@@ -706,7 +725,6 @@
+@@ -714,7 +733,6 @@
#endif
)
{
/* save the old directory */
strfcpy (OldLastDir, LastDir, sizeof (OldLastDir));
---- a/mutt_menu.h
-+++ b/mutt_menu.h
+Index: mutt/mutt_menu.h
+===================================================================
+--- mutt.orig/mutt_menu.h 2009-06-25 12:35:44.000000000 +0200
++++ mutt/mutt_menu.h 2009-06-25 12:36:19.000000000 +0200
@@ -49,6 +49,7 @@
int offset; /* which screen row to start the index */
int pagelen; /* number of entries per screen */