]> git.llucax.com Git - software/mutt-debian.git/blobdiff - debian/patches/debian-specific/Md.etc_mailname_gethostbyname.diff
a better way of closing 603186 (sidebar-{sorted,dotted} documentation)
[software/mutt-debian.git] / debian / patches / debian-specific / Md.etc_mailname_gethostbyname.diff
index de6765e6b5498168c10360b13573b097a97908eb..13a96b65cb85b213b94a6900c2515956546b88ac 100644 (file)
@@ -1,15 +1,18 @@
---- mutt-1.5.11.orig/init.c
-+++ mutt-1.5.11/init.c
-@@ -46,6 +46,7 @@
+If /etc/mailname is present, the hostname inside the file will be
+used, rather than calling gethostbyname() on the actual hostname
+
+--- a/init.c
++++ b/init.c
+@@ -48,6 +48,7 @@
  #include <unistd.h>
  #include <string.h>
  #include <sys/utsname.h>
 +#include <netdb.h>
  #include <errno.h>
  #include <sys/wait.h>
  #include <unistd.h>
  #include <string.h>
  #include <sys/utsname.h>
 +#include <netdb.h>
  #include <errno.h>
  #include <sys/wait.h>
-@@ -2761,6 +2762,31 @@
-   return 0;
+ #include <sys/time.h>
+@@ -2952,6 +2953,31 @@
+   srandom(seed);
  }
  
 +int getmailname(char *s, size_t l)
  }
  
 +int getmailname(char *s, size_t l)
@@ -40,7 +43,7 @@
  void mutt_init (int skip_sys_rc, LIST *commands)
  {
    struct passwd *pw;
  void mutt_init (int skip_sys_rc, LIST *commands)
  {
    struct passwd *pw;
-@@ -2832,10 +2858,25 @@
+@@ -3027,10 +3053,25 @@
      Hostname = mutt_substrdup (utsname.nodename, p);
      p++;
      strfcpy (buffer, p, sizeof (buffer)); /* save the domain for below */
      Hostname = mutt_substrdup (utsname.nodename, p);
      p++;
      strfcpy (buffer, p, sizeof (buffer)); /* save the domain for below */