]> git.llucax.com Git - software/mutt-debian.git/blobdiff - debian/patches/features/compressed-folders
mutt (1.5.14+cvs20070301-1) experimental; urgency=low
[software/mutt-debian.git] / debian / patches / features / compressed-folders
index 45e3922a82bfd3fba9efecf8bc2930f33e2d16c9..7c0268c252d999ec36d9f671876517e494ac8aba 100644 (file)
@@ -15,11 +15,14 @@ The home page for this patch is:
     $(for f in Makefile.in config.h.in configure 'Muttrc*' doc/manual.txt \
       doc/manual.sgml 'doc/manual*.html' doc/muttrc.man; do echo "-x $f"; done)
   - adjust the init.h hunk to the presence of group & ungroup
     $(for f in Makefile.in config.h.in configure 'Muttrc*' doc/manual.txt \
       doc/manual.sgml 'doc/manual*.html' doc/muttrc.man; do echo "-x $f"; done)
   - adjust the init.h hunk to the presence of group & ungroup
+  - 2006-07-15: adjust Makefile.am and doc/manual.xml.head to mutt-1.5.12
+  - 2006-08-16: adjust Makefile.am mutt-1.5.13
 
 == END PATCH
 
 == END PATCH
-diff -urN mutt-1.5.11/compress.c mutt-1.5.11-ro/compress.c
---- mutt-1.5.11/compress.c     1970-01-01 01:00:00.000000000 +0100
-+++ mutt-1.5.11-ro/compress.c  2005-09-27 13:26:58.000000000 +0200
+Index: compress.c
+===================================================================
+--- /dev/null  1970-01-01 00:00:00.000000000 +0000
++++ compress.c 2007-03-01 22:30:00.101678680 +0100
 @@ -0,0 +1,487 @@
 +/*
 + * Copyright (C) 1997 Alain Penders <Alain@Finale-Dev.com>
 @@ -0,0 +1,487 @@
 +/*
 + * Copyright (C) 1997 Alain Penders <Alain@Finale-Dev.com>
@@ -508,9 +511,10 @@ diff -urN mutt-1.5.11/compress.c mutt-1.5.11-ro/compress.c
 +}
 +
 +#endif /* USE_COMPRESSED */
 +}
 +
 +#endif /* USE_COMPRESSED */
-diff -urN mutt-1.5.11/compress.h mutt-1.5.11-ro/compress.h
---- mutt-1.5.11/compress.h     1970-01-01 01:00:00.000000000 +0100
-+++ mutt-1.5.11-ro/compress.h  2005-09-27 13:26:58.000000000 +0200
+Index: compress.h
+===================================================================
+--- /dev/null  1970-01-01 00:00:00.000000000 +0000
++++ compress.h 2007-03-01 22:30:00.101678680 +0100
 @@ -0,0 +1,27 @@
 +/*
 + * Copyright (C) 1997 Alain Penders <Alain@Finale-Dev.com>
 @@ -0,0 +1,27 @@
 +/*
 + * Copyright (C) 1997 Alain Penders <Alain@Finale-Dev.com>
@@ -539,12 +543,11 @@ diff -urN mutt-1.5.11/compress.h mutt-1.5.11-ro/compress.h
 +int mutt_test_compress_command (const char *);
 +int mutt_check_mailbox_compressed (CONTEXT *);
 +void mutt_fast_close_compressed (CONTEXT *);
 +int mutt_test_compress_command (const char *);
 +int mutt_check_mailbox_compressed (CONTEXT *);
 +void mutt_fast_close_compressed (CONTEXT *);
-diff -urN mutt-1.5.11/config.h.in mutt-1.5.11-ro/config.h.in
-diff -urN mutt-1.5.11/configure mutt-1.5.11-ro/configure
-diff -urN mutt-1.5.11/configure.in mutt-1.5.11-ro/configure.in
---- mutt-1.5.11/configure.in   2005-09-15 16:21:24.000000000 +0200
-+++ mutt-1.5.11-ro/configure.in        2005-09-27 13:26:58.000000000 +0200
-@@ -711,6 +711,11 @@
+Index: configure.in
+===================================================================
+--- configure.in.orig  2007-03-01 22:20:42.248485256 +0100
++++ configure.in       2007-03-01 22:30:00.102678528 +0100
+@@ -808,6 +808,11 @@ AC_ARG_ENABLE(locales-fix, AC_HELP_STRIN
                  AC_DEFINE(LOCALES_HACK,1,[ Define if the result of isprint() is unreliable. ])
          fi])
  
                  AC_DEFINE(LOCALES_HACK,1,[ Define if the result of isprint() is unreliable. ])
          fi])
  
@@ -556,10 +559,11 @@ diff -urN mutt-1.5.11/configure.in mutt-1.5.11-ro/configure.in
  AC_ARG_WITH(exec-shell, AC_HELP_STRING([--with-exec-shell=SHELL], [Specify alternate shell (ONLY if /bin/sh is broken)]),
          [if test $withval != yes; then
                  AC_DEFINE_UNQUOTED(EXECSHELL, "$withval",
  AC_ARG_WITH(exec-shell, AC_HELP_STRING([--with-exec-shell=SHELL], [Specify alternate shell (ONLY if /bin/sh is broken)]),
          [if test $withval != yes; then
                  AC_DEFINE_UNQUOTED(EXECSHELL, "$withval",
-diff -urN mutt-1.5.11/curs_main.c mutt-1.5.11-ro/curs_main.c
---- mutt-1.5.11/curs_main.c    2005-09-07 10:19:43.000000000 +0200
-+++ mutt-1.5.11-ro/curs_main.c 2005-09-27 13:26:58.000000000 +0200
-@@ -1091,6 +1091,11 @@
+Index: curs_main.c
+===================================================================
+--- curs_main.c.orig   2007-03-01 22:08:47.806097008 +0100
++++ curs_main.c        2007-03-01 22:30:00.102678528 +0100
+@@ -1090,6 +1090,11 @@ int mutt_index_menu (void)
          {
          int check;
  
          {
          int check;
  
@@ -571,14 +575,15 @@ diff -urN mutt-1.5.11/curs_main.c mutt-1.5.11-ro/curs_main.c
          mutt_str_replace (&LastFolder, Context->path);
          oldcount = Context ? Context->msgcount : 0;
  
          mutt_str_replace (&LastFolder, Context->path);
          oldcount = Context ? Context->msgcount : 0;
  
-diff -urN mutt-1.5.11/doc/manual.xml.head mutt-1.5.11-ro/doc/manual.xml.head
---- mutt-1.5.11/doc/manual.xml.head    2005-09-06 18:46:44.000000000 +0200
-+++ mutt-1.5.11-ro/doc/manual.xml.head 2005-09-27 13:29:11.000000000 +0200
-@@ -4404,6 +4404,205 @@
+Index: doc/manual.xml.head
+===================================================================
+--- doc/manual.xml.head.orig   2007-03-01 22:08:47.852090016 +0100
++++ doc/manual.xml.head        2007-03-01 22:30:00.106677920 +0100
+@@ -4749,6 +4749,205 @@ becomes an issue as mutt will silently f
  
  </sect1>
  
  
  </sect1>
  
-+<sect2 id="compressedfolders">
++<sect1 id="compressedfolders">
 +<title>Compressed folders Support (OPTIONAL)</title>
 +
 +<para>
 +<title>Compressed folders Support (OPTIONAL)</title>
 +
 +<para>
@@ -630,7 +635,7 @@ diff -urN mutt-1.5.11/doc/manual.xml.head mutt-1.5.11-ro/doc/manual.xml.head
 +the compressed file will be removed if you delete all of the messages.
 +</para>
 +
 +the compressed file will be removed if you delete all of the messages.
 +</para>
 +
-+<sect3 id="open-hook">
++<sect2 id="open-hook">
 +<title>Open a compressed mailbox for reading</title>
 +
 +<para>
 +<title>Open a compressed mailbox for reading</title>
 +
 +<para>
@@ -663,9 +668,9 @@ diff -urN mutt-1.5.11/doc/manual.xml.head mutt-1.5.11-ro/doc/manual.xml.head
 +If the <emphasis>command</emphasis> is empty, this operation is
 +disabled for this file type.
 +</para>
 +If the <emphasis>command</emphasis> is empty, this operation is
 +disabled for this file type.
 +</para>
-+</sect3>
++</sect2>
 +
 +
-+<sect3 id="close-hook">
++<sect2 id="close-hook">
 +<title>Write a compressed mailbox</title>
 +
 +<para>
 +<title>Write a compressed mailbox</title>
 +
 +<para>
@@ -700,9 +705,9 @@ diff -urN mutt-1.5.11/doc/manual.xml.head mutt-1.5.11-ro/doc/manual.xml.head
 +<link linkend="close-hook">close-hook</link> is not called when you
 +exit from the folder if the folder was not changed.
 +</para>
 +<link linkend="close-hook">close-hook</link> is not called when you
 +exit from the folder if the folder was not changed.
 +</para>
-+</sect3>
++</sect2>
 +
 +
-+<sect3 id="append-hook">
++<sect2 id="append-hook">
 +<title>Append a message to a compressed mailbox</title>
 +
 +<para>
 +<title>Append a message to a compressed mailbox</title>
 +
 +<para>
@@ -744,9 +749,9 @@ diff -urN mutt-1.5.11/doc/manual.xml.head mutt-1.5.11-ro/doc/manual.xml.head
 +<link linkend="close-hook">close-hook</link>respectively) each time you
 +will add to it.
 +</para>
 +<link linkend="close-hook">close-hook</link>respectively) each time you
 +will add to it.
 +</para>
-+</sect3>
++</sect2>
 +
 +
-+<sect3>
++<sect2>
 +<title>Encrypted folders</title>
 +
 +<para>
 +<title>Encrypted folders</title>
 +
 +<para>
@@ -774,16 +779,17 @@ diff -urN mutt-1.5.11/doc/manual.xml.head mutt-1.5.11-ro/doc/manual.xml.head
 +decrypted in the /tmp directory, where it can be read by your system
 +administrator. So think about the security aspects of this.
 +</para>
 +decrypted in the /tmp directory, where it can be read by your system
 +administrator. So think about the security aspects of this.
 +</para>
-+</sect3>
 +</sect2>
 +</sect2>
++</sect1>
 +
 +
- <sect1 id="mimesupport">
- <title>Mutt's MIME Support</title>
+ </chapter>
  
  
-diff -urN mutt-1.5.11/doc/muttrc.man.head mutt-1.5.11-ro/doc/muttrc.man.head
---- mutt-1.5.11/doc/muttrc.man.head    2005-09-07 10:19:44.000000000 +0200
-+++ mutt-1.5.11-ro/doc/muttrc.man.head 2005-09-27 13:29:53.000000000 +0200
-@@ -316,6 +316,24 @@
+ <chapter id="mimesupport">
+Index: doc/muttrc.man.head
+===================================================================
+--- doc/muttrc.man.head.orig   2007-03-01 22:08:47.900082720 +0100
++++ doc/muttrc.man.head        2007-03-01 22:30:00.106677920 +0100
+@@ -316,6 +316,24 @@ specify the ID of the public key to be u
  to a certain recipient.  The meaning of "key ID" is to be taken
  broadly: This can be a different e-mail address, a numerical key ID,
  or even just an arbitrary search string.
  to a certain recipient.  The meaning of "key ID" is to be taken
  broadly: This can be a different e-mail address, a numerical key ID,
  or even just an arbitrary search string.
@@ -808,9 +814,10 @@ diff -urN mutt-1.5.11/doc/muttrc.man.head mutt-1.5.11-ro/doc/muttrc.man.head
  .TP
  \fBpush\fP \fIstring\fP
  This command adds the named \fIstring\fP to the keyboard buffer.
  .TP
  \fBpush\fP \fIstring\fP
  This command adds the named \fIstring\fP to the keyboard buffer.
-diff -urN mutt-1.5.11/hook.c mutt-1.5.11-ro/hook.c
---- mutt-1.5.11/hook.c 2005-02-03 19:47:52.000000000 +0100
-+++ mutt-1.5.11-ro/hook.c      2005-09-27 13:27:02.000000000 +0200
+Index: hook.c
+===================================================================
+--- hook.c.orig        2007-03-01 22:08:47.947075576 +0100
++++ hook.c     2007-03-01 22:30:00.107677768 +0100
 @@ -24,6 +24,10 @@
  #include "mailbox.h"
  #include "mutt_crypt.h"
 @@ -24,6 +24,10 @@
  #include "mailbox.h"
  #include "mutt_crypt.h"
@@ -822,7 +829,7 @@ diff -urN mutt-1.5.11/hook.c mutt-1.5.11-ro/hook.c
  #include <limits.h>
  #include <string.h>
  #include <stdlib.h>
  #include <limits.h>
  #include <string.h>
  #include <stdlib.h>
-@@ -92,6 +96,16 @@
+@@ -92,6 +96,16 @@ int mutt_parse_hook (BUFFER *buf, BUFFER
      memset (&pattern, 0, sizeof (pattern));
      pattern.data = safe_strdup (path);
    }
      memset (&pattern, 0, sizeof (pattern));
      pattern.data = safe_strdup (path);
    }
@@ -839,10 +846,11 @@ diff -urN mutt-1.5.11/hook.c mutt-1.5.11-ro/hook.c
    else if (DefaultHook && !(data & (M_CHARSETHOOK | M_ACCOUNTHOOK))
             && (!WithCrypto || !(data & M_CRYPTHOOK))
        )
    else if (DefaultHook && !(data & (M_CHARSETHOOK | M_ACCOUNTHOOK))
             && (!WithCrypto || !(data & M_CRYPTHOOK))
        )
-diff -urN mutt-1.5.11/init.h mutt-1.5.11-ro/init.h
---- mutt-1.5.11/init.h 2005-09-15 16:19:54.000000000 +0200
-+++ mutt-1.5.11-ro/init.h      2005-09-27 13:27:02.000000000 +0200
-@@ -3100,6 +3100,11 @@
+Index: init.h
+===================================================================
+--- init.h.orig        2007-03-01 22:20:35.279544696 +0100
++++ init.h     2007-03-01 22:30:00.108677616 +0100
+@@ -3155,6 +3155,11 @@ struct command_t Commands[] = {
    { "folder-hook",    mutt_parse_hook,        M_FOLDERHOOK },
    { "group",          parse_group,            0 },
    { "ungroup",                parse_ungroup,          0 },
    { "folder-hook",    mutt_parse_hook,        M_FOLDERHOOK },
    { "group",          parse_group,            0 },
    { "ungroup",                parse_ungroup,          0 },
@@ -854,10 +862,11 @@ diff -urN mutt-1.5.11/init.h mutt-1.5.11-ro/init.h
    { "hdr_order",      parse_list,             UL &HeaderOrderList },
  #ifdef HAVE_ICONV
    { "iconv-hook",     mutt_parse_hook,        M_ICONVHOOK }, 
    { "hdr_order",      parse_list,             UL &HeaderOrderList },
  #ifdef HAVE_ICONV
    { "iconv-hook",     mutt_parse_hook,        M_ICONVHOOK }, 
-diff -urN mutt-1.5.11/main.c mutt-1.5.11-ro/main.c
---- mutt-1.5.11/main.c 2005-09-07 10:19:43.000000000 +0200
-+++ mutt-1.5.11-ro/main.c      2005-09-27 13:27:02.000000000 +0200
-@@ -385,6 +385,12 @@
+Index: main.c
+===================================================================
+--- main.c.orig        2007-03-01 22:20:46.386856128 +0100
++++ main.c     2007-03-01 22:30:00.108677616 +0100
+@@ -404,6 +404,12 @@ static void show_version (void)
  #else
        "-LOCALES_HACK  "
  #endif
  #else
        "-LOCALES_HACK  "
  #endif
@@ -870,34 +879,35 @@ diff -urN mutt-1.5.11/main.c mutt-1.5.11-ro/main.c
              
  #ifdef HAVE_WC_FUNCS
        "+HAVE_WC_FUNCS  "
              
  #ifdef HAVE_WC_FUNCS
        "+HAVE_WC_FUNCS  "
-diff -urN mutt-1.5.11/Makefile.am mutt-1.5.11-ro/Makefile.am
---- mutt-1.5.11/Makefile.am    2005-08-11 23:27:28.000000000 +0200
-+++ mutt-1.5.11-ro/Makefile.am 2005-09-27 13:27:02.000000000 +0200
-@@ -18,7 +18,7 @@
+Index: Makefile.am
+===================================================================
+--- Makefile.am.orig   2007-03-01 22:20:46.454845792 +0100
++++ Makefile.am        2007-03-01 22:30:00.108677616 +0100
+@@ -18,7 +18,7 @@ BUILT_SOURCES = keymap_defs.h patchlist.
  bin_PROGRAMS = mutt @DOTLOCK_TARGET@ @PGPAUX_TARGET@
  mutt_SOURCES = $(BUILT_SOURCES) \
        addrbook.c alias.c attach.c base64.c browser.c buffy.c color.c \
  bin_PROGRAMS = mutt @DOTLOCK_TARGET@ @PGPAUX_TARGET@
  mutt_SOURCES = $(BUILT_SOURCES) \
        addrbook.c alias.c attach.c base64.c browser.c buffy.c color.c \
--        crypt.c cryptglue.c \
-+        crypt.c cryptglue.c compress.c \
+-      crypt.c cryptglue.c \
++      crypt.c cryptglue.c compress.c \
        commands.c complete.c compose.c copy.c curs_lib.c curs_main.c date.c \
        commands.c complete.c compose.c copy.c curs_lib.c curs_main.c date.c \
-       edit.c enter.c flags.c init.c filter.c from.c getdomain.c \
-       handler.c hash.c hdrline.c headers.c help.c hook.c keymap.c \
-@@ -67,7 +67,7 @@
-       crypt-gpgme.c crypt-mod-pgp-gpgme.c crypt-mod-smime-gpgme.c
+       edit.c enter.c flags.c init.c filter.c from.c \
+       getdomain.c group.c \
+@@ -67,7 +67,7 @@ EXTRA_mutt_SOURCES = account.c md5c.c mu
+       utf8.c wcwidth.c 
  
  
- EXTRA_DIST = COPYRIGHT GPL OPS OPS.PGP OPS.CRYPT OPS.SMIME TODO \
+ EXTRA_DIST = COPYRIGHT GPL OPS OPS.PGP OPS.CRYPT OPS.SMIME TODO UPDATING \
 -      configure account.h \
 +      configure account.h compress.h \
        attach.h buffy.h charset.h copy.h crypthash.h dotlock.h functions.h gen_defs \
        globals.h hash.h history.h init.h keymap.h mutt_crypt.h \
        mailbox.h mapping.h md5.h mime.h mutt.h mutt_curses.h mutt_menu.h \
 -      configure account.h \
 +      configure account.h compress.h \
        attach.h buffy.h charset.h copy.h crypthash.h dotlock.h functions.h gen_defs \
        globals.h hash.h history.h init.h keymap.h mutt_crypt.h \
        mailbox.h mapping.h md5.h mime.h mutt.h mutt_curses.h mutt_menu.h \
-diff -urN mutt-1.5.11/Makefile.in mutt-1.5.11-ro/Makefile.in
-diff -urN mutt-1.5.11/mbox.c mutt-1.5.11-ro/mbox.c
---- mutt-1.5.11/mbox.c 2005-08-02 09:08:00.000000000 +0200
-+++ mutt-1.5.11-ro/mbox.c      2005-09-27 13:27:02.000000000 +0200
-@@ -28,6 +28,10 @@
- #include "sort.h"
+Index: mbox.c
+===================================================================
+--- mbox.c.orig        2007-03-01 22:08:48.131047608 +0100
++++ mbox.c     2007-03-01 22:30:00.109677464 +0100
+@@ -29,6 +29,10 @@
  #include "copy.h"
  #include "copy.h"
+ #include "mutt_curses.h"
  
 +#ifdef USE_COMPRESSED
 +#include "compress.h"
  
 +#ifdef USE_COMPRESSED
 +#include "compress.h"
@@ -906,7 +916,7 @@ diff -urN mutt-1.5.11/mbox.c mutt-1.5.11-ro/mbox.c
  #include <sys/stat.h>
  #include <dirent.h>
  #include <string.h>
  #include <sys/stat.h>
  #include <dirent.h>
  #include <string.h>
-@@ -1014,6 +1018,12 @@
+@@ -1026,6 +1030,12 @@ bail:  /* Come here in case of disaster 
  int mbox_close_mailbox (CONTEXT *ctx)
  {
    mx_unlock_file (ctx->path, fileno (ctx->fp), 1);
  int mbox_close_mailbox (CONTEXT *ctx)
  {
    mx_unlock_file (ctx->path, fileno (ctx->fp), 1);
@@ -919,10 +929,11 @@ diff -urN mutt-1.5.11/mbox.c mutt-1.5.11-ro/mbox.c
    mutt_unblock_signals ();
    mx_fastclose_mailbox (ctx);
    return 0;
    mutt_unblock_signals ();
    mx_fastclose_mailbox (ctx);
    return 0;
-diff -urN mutt-1.5.11/mutt.h mutt-1.5.11-ro/mutt.h
---- mutt-1.5.11/mutt.h 2005-09-07 10:19:43.000000000 +0200
-+++ mutt-1.5.11-ro/mutt.h      2005-09-27 13:27:02.000000000 +0200
-@@ -157,6 +157,11 @@
+Index: mutt.h
+===================================================================
+--- mutt.h.orig        2007-03-01 22:20:43.625275952 +0100
++++ mutt.h     2007-03-01 22:30:00.109677464 +0100
+@@ -159,6 +159,11 @@ typedef enum
  #define M_ACCOUNTHOOK (1<<9)
  #define M_REPLYHOOK   (1<<10)
  #define M_SEND2HOOK     (1<<11)
  #define M_ACCOUNTHOOK (1<<9)
  #define M_REPLYHOOK   (1<<10)
  #define M_SEND2HOOK     (1<<11)
@@ -934,7 +945,7 @@ diff -urN mutt-1.5.11/mutt.h mutt-1.5.11-ro/mutt.h
  
  /* tree characters for linearize_tree and print_enriched_string */
  #define M_TREE_LLCORNER               1
  
  /* tree characters for linearize_tree and print_enriched_string */
  #define M_TREE_LLCORNER               1
-@@ -828,6 +833,11 @@
+@@ -882,6 +887,11 @@ typedef struct
    void *data;                 /* driver specific data */
  #endif /* USE_IMAP */
  
    void *data;                 /* driver specific data */
  #endif /* USE_IMAP */
  
@@ -945,13 +956,11 @@ diff -urN mutt-1.5.11/mutt.h mutt-1.5.11-ro/mutt.h
 +
    short magic;                        /* mailbox type */
  
 +
    short magic;                        /* mailbox type */
  
-   unsigned int locked : 1;    /* is the mailbox locked? */
-diff -urN mutt-1.5.11/Muttrc mutt-1.5.11-ro/Muttrc
-diff -urN mutt-1.5.11/Muttrc.head mutt-1.5.11-ro/Muttrc.head
-diff -urN mutt-1.5.11/Muttrc.head.in mutt-1.5.11-ro/Muttrc.head.in
-diff -urN mutt-1.5.11/mx.c mutt-1.5.11-ro/mx.c
---- mutt-1.5.11/mx.c   2005-09-07 10:19:43.000000000 +0200
-+++ mutt-1.5.11-ro/mx.c        2005-09-27 13:27:02.000000000 +0200
+   unsigned char rights[(RIGHTSMAX + 7)/8];    /* ACL bits */
+Index: mx.c
+===================================================================
+--- mx.c.orig  2007-03-01 22:08:48.223033624 +0100
++++ mx.c       2007-03-01 22:30:00.110677312 +0100
 @@ -30,6 +30,10 @@
  #include "keymap.h"
  #include "url.h"
 @@ -30,6 +30,10 @@
  #include "keymap.h"
  #include "url.h"
@@ -963,7 +972,7 @@ diff -urN mutt-1.5.11/mx.c mutt-1.5.11-ro/mx.c
  #ifdef USE_IMAP
  #include "imap.h"
  #endif
  #ifdef USE_IMAP
  #include "imap.h"
  #endif
-@@ -454,6 +458,10 @@
+@@ -454,6 +458,10 @@ int mx_get_magic (const char *path)
      return (-1);
    }
  
      return (-1);
    }
  
@@ -974,7 +983,7 @@ diff -urN mutt-1.5.11/mx.c mutt-1.5.11-ro/mx.c
    return (magic);
  }
  
    return (magic);
  }
  
-@@ -493,6 +501,13 @@
+@@ -493,6 +501,13 @@ static int mx_open_mailbox_append (CONTE
  {
    struct stat sb;
  
  {
    struct stat sb;
  
@@ -988,7 +997,7 @@ diff -urN mutt-1.5.11/mx.c mutt-1.5.11-ro/mx.c
    ctx->append = 1;
  
  #ifdef USE_IMAP
    ctx->append = 1;
  
  #ifdef USE_IMAP
-@@ -653,7 +668,12 @@
+@@ -656,7 +671,12 @@ CONTEXT *mx_open_mailbox (const char *pa
    }
  
    ctx->magic = mx_get_magic (path);
    }
  
    ctx->magic = mx_get_magic (path);
@@ -1002,7 +1011,7 @@ diff -urN mutt-1.5.11/mx.c mutt-1.5.11-ro/mx.c
    if(ctx->magic == 0)
      mutt_error (_("%s is not a mailbox."), path);
  
    if(ctx->magic == 0)
      mutt_error (_("%s is not a mailbox."), path);
  
-@@ -759,6 +779,10 @@
+@@ -762,6 +782,10 @@ void mx_fastclose_mailbox (CONTEXT *ctx)
      mutt_free_header (&ctx->hdrs[i]);
    FREE (&ctx->hdrs);
    FREE (&ctx->v2r);
      mutt_free_header (&ctx->hdrs[i]);
    FREE (&ctx->hdrs);
    FREE (&ctx->v2r);
@@ -1013,7 +1022,7 @@ diff -urN mutt-1.5.11/mx.c mutt-1.5.11-ro/mx.c
    FREE (&ctx->path);
    FREE (&ctx->pattern);
    if (ctx->limit_pattern) 
    FREE (&ctx->path);
    FREE (&ctx->pattern);
    if (ctx->limit_pattern) 
-@@ -816,6 +840,12 @@
+@@ -819,6 +843,12 @@ static int sync_mailbox (CONTEXT *ctx, i
    if (tmp && tmp->new == 0)
      mutt_update_mailbox (tmp);
  #endif
    if (tmp && tmp->new == 0)
      mutt_update_mailbox (tmp);
  #endif
@@ -1026,7 +1035,7 @@ diff -urN mutt-1.5.11/mx.c mutt-1.5.11-ro/mx.c
    return rc;
  }
  
    return rc;
  }
  
-@@ -1021,6 +1051,11 @@
+@@ -1020,6 +1050,11 @@ int mx_close_mailbox (CONTEXT *ctx, int 
        !mutt_is_spool(ctx->path) && !option (OPTSAVEEMPTY))
      mx_unlink_empty (ctx->path);
  
        !mutt_is_spool(ctx->path) && !option (OPTSAVEEMPTY))
      mx_unlink_empty (ctx->path);
  
@@ -1038,7 +1047,7 @@ diff -urN mutt-1.5.11/mx.c mutt-1.5.11-ro/mx.c
    mx_fastclose_mailbox (ctx);
  
    return 0;
    mx_fastclose_mailbox (ctx);
  
    return 0;
-@@ -1330,6 +1365,11 @@
+@@ -1329,6 +1364,11 @@ int mx_check_mailbox (CONTEXT *ctx, int 
  {
    int rc;
  
  {
    int rc;
  
@@ -1050,10 +1059,11 @@ diff -urN mutt-1.5.11/mx.c mutt-1.5.11-ro/mx.c
    if (ctx)
    {
      if (ctx->locked) lock = 0;
    if (ctx)
    {
      if (ctx->locked) lock = 0;
-diff -urN mutt-1.5.11/mx.h mutt-1.5.11-ro/mx.h
---- mutt-1.5.11/mx.h   2003-08-05 15:58:16.000000000 +0200
-+++ mutt-1.5.11-ro/mx.h        2005-09-27 13:27:02.000000000 +0200
-@@ -40,6 +40,9 @@
+Index: mx.h
+===================================================================
+--- mx.h.orig  2007-03-01 22:08:48.272026176 +0100
++++ mx.h       2007-03-01 22:30:00.110677312 +0100
+@@ -40,6 +40,9 @@ enum
  #ifdef USE_POP
    , M_POP
  #endif
  #ifdef USE_POP
    , M_POP
  #endif
@@ -1063,15 +1073,17 @@ diff -urN mutt-1.5.11/mx.h mutt-1.5.11-ro/mx.h
  };
  
  WHERE short DefaultMagic INITVAL (M_MBOX);
  };
  
  WHERE short DefaultMagic INITVAL (M_MBOX);
-diff -urN mutt-1.5.11/PATCHES mutt-1.5.11-ro/PATCHES
---- mutt-1.5.11/PATCHES        2005-08-15 10:16:00.000000000 +0200
-+++ mutt-1.5.11-ro/PATCHES     2005-09-27 13:30:25.000000000 +0200
+Index: PATCHES
+===================================================================
+--- /dev/null  1970-01-01 00:00:00.000000000 +0000
++++ PATCHES    2007-03-01 22:30:00.110677312 +0100
 @@ -0,0 +1 @@
 +patch-1.5.11.rr.compressed.1
 @@ -0,0 +1 @@
 +patch-1.5.11.rr.compressed.1
-diff -urN mutt-1.5.11/po/de.po mutt-1.5.11-ro/po/de.po
---- mutt-1.5.11/po/de.po       2005-09-15 16:23:50.000000000 +0200
-+++ mutt-1.5.11-ro/po/de.po    2005-09-27 13:27:02.000000000 +0200
-@@ -1262,6 +1262,48 @@
+Index: po/de.po
+===================================================================
+--- po/de.po.orig      2007-03-01 22:21:09.228383688 +0100
++++ po/de.po   2007-03-01 22:30:00.112677008 +0100
+@@ -1266,6 +1266,48 @@ msgstr "Prüfung des Absenders fehlgeschl
  msgid "Failed to figure out sender"
  msgstr "Kann Absender nicht ermitteln"
  
  msgid "Failed to figure out sender"
  msgstr "Kann Absender nicht ermitteln"
  
@@ -1120,7 +1132,7 @@ diff -urN mutt-1.5.11/po/de.po mutt-1.5.11-ro/po/de.po
  #: crypt.c:69
  #, c-format
  msgid " (current time: %c)"
  #: crypt.c:69
  #, c-format
  msgid " (current time: %c)"
-@@ -1882,6 +1924,10 @@
+@@ -1926,6 +1968,10 @@ msgstr ""
  msgid "Help for %s"
  msgstr "Hilfe für %s"
  
  msgid "Help for %s"
  msgstr "Hilfe für %s"
  
@@ -1131,29 +1143,30 @@ diff -urN mutt-1.5.11/po/de.po mutt-1.5.11-ro/po/de.po
  #: hook.c:246
  #, c-format
  msgid "unhook: Can't do unhook * from within a hook."
  #: hook.c:246
  #, c-format
  msgid "unhook: Can't do unhook * from within a hook."
-@@ -3336,18 +3382,10 @@
+@@ -3428,18 +3474,10 @@ msgstr "Lese %s..."
  msgid "Mailbox is corrupt!"
  msgstr "Mailbox fehlerhaft!"
  
  msgid "Mailbox is corrupt!"
  msgstr "Mailbox fehlerhaft!"
  
--#: mbox.c:662
+-#: mbox.c:670
 -msgid "Mailbox was corrupted!"
 -msgstr "Mailbox wurde zerstört!"
 -
 -msgid "Mailbox was corrupted!"
 -msgstr "Mailbox wurde zerstört!"
 -
- #: mbox.c:701 mbox.c:952
+ #: mbox.c:711 mbox.c:964
  msgid "Fatal error!  Could not reopen mailbox!"
  msgstr "Fataler Fehler, konnte Mailbox nicht erneut öffnen!"
  
  msgid "Fatal error!  Could not reopen mailbox!"
  msgstr "Fataler Fehler, konnte Mailbox nicht erneut öffnen!"
  
--#: mbox.c:710
+-#: mbox.c:720
 -msgid "Unable to lock mailbox!"
 -msgstr "Kann Mailbox nicht für exklusiven Zugriff sperren!"
 -
  #. this means ctx->changed or ctx->deleted was set, but no
  #. * messages were found to be changed or deleted.  This should
  #. * never happen, is we presume it is a bug in mutt.
 -msgid "Unable to lock mailbox!"
 -msgstr "Kann Mailbox nicht für exklusiven Zugriff sperren!"
 -
  #. this means ctx->changed or ctx->deleted was set, but no
  #. * messages were found to be changed or deleted.  This should
  #. * never happen, is we presume it is a bug in mutt.
-diff -urN mutt-1.5.11/po/POTFILES.in mutt-1.5.11-ro/po/POTFILES.in
---- mutt-1.5.11/po/POTFILES.in 2005-08-03 11:17:47.000000000 +0200
-+++ mutt-1.5.11-ro/po/POTFILES.in      2005-09-27 13:27:02.000000000 +0200
-@@ -8,6 +8,7 @@
+Index: po/POTFILES.in
+===================================================================
+--- po/POTFILES.in.orig        2007-03-01 22:20:56.152371544 +0100
++++ po/POTFILES.in     2007-03-01 22:30:00.112677008 +0100
+@@ -8,6 +8,7 @@ charset.c
  color.c
  commands.c
  compose.c
  color.c
  commands.c
  compose.c
@@ -1161,10 +1174,11 @@ diff -urN mutt-1.5.11/po/POTFILES.in mutt-1.5.11-ro/po/POTFILES.in
  crypt-gpgme.c
  crypt.c
  cryptglue.c
  crypt-gpgme.c
  crypt.c
  cryptglue.c
-diff -urN mutt-1.5.11/status.c mutt-1.5.11-ro/status.c
---- mutt-1.5.11/status.c       2005-02-03 19:47:53.000000000 +0100
-+++ mutt-1.5.11-ro/status.c    2005-09-27 13:27:02.000000000 +0200
-@@ -97,6 +97,14 @@
+Index: status.c
+===================================================================
+--- status.c.orig      2007-03-01 22:08:48.458997752 +0100
++++ status.c   2007-03-01 22:30:00.113676856 +0100
+@@ -97,6 +97,14 @@ status_format_str (char *buf, size_t buf
  
      case 'f':
        snprintf (fmt, sizeof(fmt), "%%%ss", prefix);
  
      case 'f':
        snprintf (fmt, sizeof(fmt), "%%%ss", prefix);