]> git.llucax.com Git - software/mutt-debian.git/blobdiff - debian/rules
mutt (1.5.14+cvs20070301-1) experimental; urgency=low
[software/mutt-debian.git] / debian / rules
index f685c0cd4b70dbfe4c927e937f5b5746068d1202..b7c71cd729fe90bcc36edd73b31834a9d2b9a3a4 100755 (executable)
@@ -23,7 +23,9 @@ confflags  =  --prefix=/usr                   \
                --enable-debug                  \
                --enable-fcntl                  \
                --enable-hcache                 \
                --enable-debug                  \
                --enable-fcntl                  \
                --enable-hcache                 \
+               --enable-gpgme                  \
                --enable-imap                   \
                --enable-imap                   \
+               --enable-smtp                   \
                --enable-inodesort              \
                --enable-pop                    \
                                                \
                --enable-inodesort              \
                --enable-pop                    \
                                                \
@@ -93,7 +95,7 @@ $(objdir)/configure-stamp:
        env LC_COLLATE=C sort PATCHES.unsorted >PATCHES
        
        # do not rebuild these files
        env LC_COLLATE=C sort PATCHES.unsorted >PATCHES
        
        # do not rebuild these files
-       touch configure.in aclocal.m4 Makefile.in configure stamp-h.in config.h.in
+       touch configure.in aclocal.m4 Makefile.in configure config.h.in
        
        -mkdir $(objdir)
        cd $(objdir) && \
        
        -mkdir $(objdir)
        cd $(objdir) && \
@@ -109,7 +111,7 @@ $(objdir)/configure-stamp:
 build: $(objdir)/build-stamp
 $(objdir)/build-stamp: $(objdir)/configure-stamp
        cd $(objdir) && \
 build: $(objdir)/build-stamp
 $(objdir)/build-stamp: $(objdir)/configure-stamp
        cd $(objdir) && \
-       $(MAKE)
+       $(MAKE) CFLAGS="$(CFLAGS)"
        
        touch $@
 
        
        touch $@
 
@@ -125,6 +127,7 @@ clean:
        # quilt cruft
        rm -f   patches
        rm -rf .pc
        # quilt cruft
        rm -f   patches
        rm -rf .pc
+       touch PATCHES
        
        # please dpkg-source
        rm -f po/*.gmo
        
        # please dpkg-source
        rm -f po/*.gmo
@@ -144,20 +147,21 @@ debian/tmp/install-stamp:
        dh_clean
        cd $(objdir) && $(MAKE) install DESTDIR=$(CURDIR)/debian/tmp
        
        dh_clean
        cd $(objdir) && $(MAKE) install DESTDIR=$(CURDIR)/debian/tmp
        
-       rm -rf debian/tmp/usr/share/doc/samples/iconv
-       rm -rf debian/tmp/usr/share/doc/samples/ca-bundle.crt
+       cd debian/tmp/usr/share/doc; \
+       rm -rf samples/iconv samples/ca-bundle.crt; \
+       mv NEWS NEWS.old; \
+       mv ChangeLog.old changelog.old; \
+       cp $(CURDIR)/UPDATING NEWS
        
        chmod +x debian/extra/lib/*
        chmod +x debian/header.awk
        debian/header.awk debian/patches/features/* >debian/tmp/README.Patches
        
        
        chmod +x debian/extra/lib/*
        chmod +x debian/header.awk
        debian/header.awk debian/patches/features/* >debian/tmp/README.Patches
        
-       cp $(objdir)/Muttrc.head debian/tmp/Muttrc
-       echo "# GnuPG configuration" >>debian/tmp/Muttrc
-       grep '^set' contrib/gpg.rc \
-               | sed -e 's#pgpewrap#/usr/lib/mutt/pgpewrap#' \
-               | sed -e 's#/usr/bin/gpg#gpg#' \
-               >> debian/tmp/Muttrc
-       cat debian/extra/rc/* >>debian/tmp/Muttrc
+       ( cat $(objdir)/Muttrc.head; \
+         echo "# GnuPG configuration"; \
+         grep '^set' contrib/gpg.rc; \
+         echo; \
+         cat debian/extra/rc/* ) > debian/tmp/Muttrc
        
        touch $@
 
        
        touch $@
 
@@ -169,9 +173,9 @@ binary-arch: build install
        dh_testdir
        dh_testroot
        
        dh_testdir
        dh_testroot
        
+       dh_installdirs
        dh_install
        dh_installman
        dh_install
        dh_installman
-       dh_installmime
        dh_installmenu
        dh_installdocs
        dh_installexamples
        dh_installmenu
        dh_installdocs
        dh_installexamples