]> git.llucax.com Git - software/mutt-debian.git/blobdiff - debian/patches/features/compressed-folders
upstream/548577-gpgme-1.2.patch: do not fail to open pgp signed message with libgpgme...
[software/mutt-debian.git] / debian / patches / features / compressed-folders
index 45e3922a82bfd3fba9efecf8bc2930f33e2d16c9..16baf3cfd2356084dc08ff9e7ae5d14aca72066b 100644 (file)
@@ -7,20 +7,20 @@ The home page for this patch is:
   http://www.spinnaker.de/mutt/compressed/
 
 * Patch last synced with upstream:
-  - Date: 2005-09-29
-  - File: http://www.spinnaker.de/mutt/compressed/patch-1.5.11.rr.compressed.1.gz
+  - Date: 2008-05-20
+  - File: http://www.spinnaker.de/mutt/compressed/patch-1.5.18.rr.compressed.1.gz
 
 * Changes made:
-  - filterdiff -p1 \
-    $(for f in Makefile.in config.h.in configure 'Muttrc*' doc/manual.txt \
-      doc/manual.sgml 'doc/manual*.html' doc/muttrc.man; do echo "-x $f"; done)
-  - adjust the init.h hunk to the presence of group & ungroup
+  - 2008-05-20 myon: refreshed to remove hunks in auto* files
+  - 2009-09-15 myon: refreshed for mutt-1.5.19
+                     status.c:103: add sizeof (tmp) to mutt_pretty_mailbox
+  - 2009-09-15 scotton: removed doc/Muttrc for mutt-1.5.19 (only patch doc/Muttrc.head)
+  - 2009-09-11 antonio: removed DefaultMagic, see 541360
 
 == END PATCH
-diff -urN mutt-1.5.11/compress.c mutt-1.5.11-ro/compress.c
---- mutt-1.5.11/compress.c     1970-01-01 01:00:00.000000000 +0100
-+++ mutt-1.5.11-ro/compress.c  2005-09-27 13:26:58.000000000 +0200
-@@ -0,0 +1,487 @@
+--- /dev/null
++++ b/compress.c
+@@ -0,0 +1,496 @@
 +/*
 + * Copyright (C) 1997 Alain Penders <Alain@Finale-Dev.com>
 + *
@@ -127,7 +127,19 @@ diff -urN mutt-1.5.11/compress.c mutt-1.5.11-ro/compress.c
 +  int magic;
 +
 +  if (is_new (path))
-+    return (find_compress_hook (M_CLOSEHOOK, path) ? 1 : 0);
++  {
++    char *dir_path = safe_strdup(path);
++    char *aux = strrchr(dir_path, '/');
++    int dir_valid = 1;
++    if (aux)
++    {
++      *aux='\0';
++      if (access(dir_path, W_OK|X_OK))
++        dir_valid = 0;
++    }
++    safe_free((void**)&dir_path);
++    return dir_valid && (find_compress_hook (M_CLOSEHOOK, path) ? 1 : 0);
++  }
 +
 +  magic = mx_get_magic (path);
 +
@@ -181,10 +193,10 @@ diff -urN mutt-1.5.11/compress.c mutt-1.5.11-ro/compress.c
 +}
 +
 +static const char *
-+compresshook_format_str (char *dest, size_t destlen, char op, const char *src,
-+                       const char *fmt, const char *ifstring,
-+                       const char *elsestring, unsigned long data,
-+                       format_flag flags)
++compresshook_format_str (char *dest, size_t destlen, size_t col, char op,
++                       const char *src, const char *fmt,
++                       const char *ifstring, const char *elsestring,
++                       unsigned long data, format_flag flags)
 +{
 +  char tmp[SHORT_STRING];
 +
@@ -215,8 +227,8 @@ diff -urN mutt-1.5.11/compress.c mutt-1.5.11-ro/compress.c
 +static char *get_compression_cmd (const char* cmd, const CONTEXT* ctx)
 +{
 +  char expanded[_POSIX_PATH_MAX];
-+  mutt_FormatString (expanded, sizeof (expanded), cmd, compresshook_format_str,
-+                   (unsigned long) ctx, 0);
++  mutt_FormatString (expanded, sizeof (expanded), 0, cmd,
++                   compresshook_format_str, (unsigned long) ctx, 0);
 +  return safe_strdup (expanded);
 +}
 +
@@ -242,7 +254,7 @@ diff -urN mutt-1.5.11/compress.c mutt-1.5.11-ro/compress.c
 +  COMPRESS_INFO *ci = set_compress_info (ctx);
 +  if (!ci->open) {
 +    ctx->magic = 0;
-+    FREE (ctx->compressinfo);
++    FREE (&ctx->compressinfo);
 +    return (-1);
 +  }
 +  if (!ci->close || access (ctx->path, W_OK) != 0)
@@ -287,7 +299,7 @@ diff -urN mutt-1.5.11/compress.c mutt-1.5.11-ro/compress.c
 +  {
 +    mutt_any_key_to_continue (NULL);
 +    ctx->magic = 0;
-+    FREE (ctx->compressinfo);
++    FREE (&ctx->compressinfo);
 +    mutt_error (_("Error executing: %s : unable to open the mailbox!\n"), cmd);
 +  }
 +  FREE (&cmd);
@@ -332,10 +344,7 @@ diff -urN mutt-1.5.11/compress.c mutt-1.5.11-ro/compress.c
 +
 +  set_path (ctx);
 +
-+  ctx->magic = DefaultMagic;
-+
 +  if (!is_new (ctx->realpath))
-+    if (ctx->magic == M_MBOX || ctx->magic == M_MMDF)
 +      if ((fh = fopen (ctx->path, "w")))
 +      fclose (fh);
 +  /* No error checking - the parent function will catch it */
@@ -355,8 +364,8 @@ diff -urN mutt-1.5.11/compress.c mutt-1.5.11-ro/compress.c
 +      fclose (ctx->fp);
 +    ctx->fp = NULL;
 +    /* if the folder was removed, remove the gzipped folder too */
-+    if ((ctx->magic > 0) 
-+      && (access (ctx->path, F_OK) != 0) 
++    if ((ctx->magic > 0)
++      && (access (ctx->path, F_OK) != 0)
 +      && ! option (OPTSAVEEMPTY))
 +      remove (ctx->realpath);
 +    else
@@ -435,7 +444,7 @@ diff -urN mutt-1.5.11/compress.c mutt-1.5.11-ro/compress.c
 +  if (! (ctx->append
 +       && ((append = get_append_command (ctx->realpath, ctx))
 +           || (append = ci->close))))
-+  { 
++  {
 +    /* if we can not or should not append, we only have to remove the */
 +    /* compressed info, because sync was already called               */
 +    mutt_fast_close_compressed (ctx);
@@ -508,9 +517,8 @@ diff -urN mutt-1.5.11/compress.c mutt-1.5.11-ro/compress.c
 +}
 +
 +#endif /* USE_COMPRESSED */
-diff -urN mutt-1.5.11/compress.h mutt-1.5.11-ro/compress.h
---- mutt-1.5.11/compress.h     1970-01-01 01:00:00.000000000 +0100
-+++ mutt-1.5.11-ro/compress.h  2005-09-27 13:26:58.000000000 +0200
+--- /dev/null
++++ b/compress.h
 @@ -0,0 +1,27 @@
 +/*
 + * Copyright (C) 1997 Alain Penders <Alain@Finale-Dev.com>
@@ -539,12 +547,9 @@ diff -urN mutt-1.5.11/compress.h mutt-1.5.11-ro/compress.h
 +int mutt_test_compress_command (const char *);
 +int mutt_check_mailbox_compressed (CONTEXT *);
 +void mutt_fast_close_compressed (CONTEXT *);
-diff -urN mutt-1.5.11/config.h.in mutt-1.5.11-ro/config.h.in
-diff -urN mutt-1.5.11/configure mutt-1.5.11-ro/configure
-diff -urN mutt-1.5.11/configure.in mutt-1.5.11-ro/configure.in
---- mutt-1.5.11/configure.in   2005-09-15 16:21:24.000000000 +0200
-+++ mutt-1.5.11-ro/configure.in        2005-09-27 13:26:58.000000000 +0200
-@@ -711,6 +711,11 @@
+--- a/configure.ac
++++ b/configure.ac
+@@ -805,6 +805,11 @@
                  AC_DEFINE(LOCALES_HACK,1,[ Define if the result of isprint() is unreliable. ])
          fi])
  
@@ -556,10 +561,9 @@ diff -urN mutt-1.5.11/configure.in mutt-1.5.11-ro/configure.in
  AC_ARG_WITH(exec-shell, AC_HELP_STRING([--with-exec-shell=SHELL], [Specify alternate shell (ONLY if /bin/sh is broken)]),
          [if test $withval != yes; then
                  AC_DEFINE_UNQUOTED(EXECSHELL, "$withval",
-diff -urN mutt-1.5.11/curs_main.c mutt-1.5.11-ro/curs_main.c
---- mutt-1.5.11/curs_main.c    2005-09-07 10:19:43.000000000 +0200
-+++ mutt-1.5.11-ro/curs_main.c 2005-09-27 13:26:58.000000000 +0200
-@@ -1091,6 +1091,11 @@
+--- a/curs_main.c
++++ b/curs_main.c
+@@ -1135,6 +1135,11 @@
          {
          int check;
  
@@ -571,14 +575,13 @@ diff -urN mutt-1.5.11/curs_main.c mutt-1.5.11-ro/curs_main.c
          mutt_str_replace (&LastFolder, Context->path);
          oldcount = Context ? Context->msgcount : 0;
  
-diff -urN mutt-1.5.11/doc/manual.xml.head mutt-1.5.11-ro/doc/manual.xml.head
---- mutt-1.5.11/doc/manual.xml.head    2005-09-06 18:46:44.000000000 +0200
-+++ mutt-1.5.11-ro/doc/manual.xml.head 2005-09-27 13:29:11.000000000 +0200
-@@ -4404,6 +4404,205 @@
+--- a/doc/manual.xml.head
++++ b/doc/manual.xml.head
+@@ -5678,6 +5678,205 @@
  
- </sect1>
+ </chapter>
  
-+<sect2 id="compressedfolders">
++<sect1 id="compressedfolders">
 +<title>Compressed folders Support (OPTIONAL)</title>
 +
 +<para>
@@ -607,9 +610,9 @@ diff -urN mutt-1.5.11/doc/manual.xml.head mutt-1.5.11-ro/doc/manual.xml.head
 +For example:
 +
 +<screen>
-+open-hook \\.gz$ "gzip -cd %f &gt; %t" 
++open-hook \\.gz$ "gzip -cd %f &gt; %t"
 +close-hook \\.gz$ "gzip -c %t &gt; %f"
-+append-hook \\.gz$ "gzip -c %t &gt;&gt; %f" 
++append-hook \\.gz$ "gzip -c %t &gt;&gt; %f"
 +</screen>
 +
 +You do not have to specify all of the commands. If you omit <link
@@ -630,7 +633,7 @@ diff -urN mutt-1.5.11/doc/manual.xml.head mutt-1.5.11-ro/doc/manual.xml.head
 +the compressed file will be removed if you delete all of the messages.
 +</para>
 +
-+<sect3 id="open-hook">
++<sect2 id="open-hook">
 +<title>Open a compressed mailbox for reading</title>
 +
 +<para>
@@ -657,15 +660,15 @@ diff -urN mutt-1.5.11/doc/manual.xml.head mutt-1.5.11-ro/doc/manual.xml.head
 +Example:
 +
 +<screen>
-+open-hook \\.gz$ "gzip -cd %f &gt; %t" 
++open-hook \\.gz$ "gzip -cd %f &gt; %t"
 +</screen>
 +
 +If the <emphasis>command</emphasis> is empty, this operation is
 +disabled for this file type.
 +</para>
-+</sect3>
++</sect2>
 +
-+<sect3 id="close-hook">
++<sect2 id="close-hook">
 +<title>Write a compressed mailbox</title>
 +
 +<para>
@@ -700,9 +703,9 @@ diff -urN mutt-1.5.11/doc/manual.xml.head mutt-1.5.11-ro/doc/manual.xml.head
 +<link linkend="close-hook">close-hook</link> is not called when you
 +exit from the folder if the folder was not changed.
 +</para>
-+</sect3>
++</sect2>
 +
-+<sect3 id="append-hook">
++<sect2 id="append-hook">
 +<title>Append a message to a compressed mailbox</title>
 +
 +<para>
@@ -723,7 +726,7 @@ diff -urN mutt-1.5.11/doc/manual.xml.head mutt-1.5.11-ro/doc/manual.xml.head
 +Example:
 +
 +<screen>
-+append-hook \\.gz$ "gzip -c %t &gt;&gt; %f" 
++append-hook \\.gz$ "gzip -c %t &gt;&gt; %f"
 +</screen>
 +
 +When <link linkend="append-hook">append-hook</link> is used, the folder
@@ -744,9 +747,9 @@ diff -urN mutt-1.5.11/doc/manual.xml.head mutt-1.5.11-ro/doc/manual.xml.head
 +<link linkend="close-hook">close-hook</link>respectively) each time you
 +will add to it.
 +</para>
-+</sect3>
++</sect2>
 +
-+<sect3>
++<sect2>
 +<title>Encrypted folders</title>
 +
 +<para>
@@ -774,16 +777,29 @@ diff -urN mutt-1.5.11/doc/manual.xml.head mutt-1.5.11-ro/doc/manual.xml.head
 +decrypted in the /tmp directory, where it can be read by your system
 +administrator. So think about the security aspects of this.
 +</para>
-+</sect3>
 +</sect2>
++</sect1>
 +
- <sect1 id="mimesupport">
+ <chapter id="mimesupport">
  <title>Mutt's MIME Support</title>
  
-diff -urN mutt-1.5.11/doc/muttrc.man.head mutt-1.5.11-ro/doc/muttrc.man.head
---- mutt-1.5.11/doc/muttrc.man.head    2005-09-07 10:19:44.000000000 +0200
-+++ mutt-1.5.11-ro/doc/muttrc.man.head 2005-09-27 13:29:53.000000000 +0200
-@@ -316,6 +316,24 @@
+--- a/doc/Muttrc.head
++++ b/doc/Muttrc.head
+@@ -29,6 +29,11 @@
+ macro index,pager y "<change-folder>?<toggle-mailboxes>" "show incoming mailboxes list"
+ bind browser y exit
++# Use folders which match on \\.gz$ as gzipped folders:
++# open-hook \\.gz$ "gzip -cd %f > %t"
++# close-hook \\.gz$ "gzip -c %t > %f"
++# append-hook \\.gz$ "gzip -c %t >> %f"
++
+ # If Mutt is unable to determine your site's domain name correctly, you can
+ # set the default here.
+ #
+--- a/doc/muttrc.man.head
++++ b/doc/muttrc.man.head
+@@ -345,6 +345,24 @@
  to a certain recipient.  The meaning of "key ID" is to be taken
  broadly: This can be a different e-mail address, a numerical key ID,
  or even just an arbitrary search string.
@@ -799,7 +815,7 @@ diff -urN mutt-1.5.11/doc/muttrc.man.head mutt-1.5.11-ro/doc/muttrc.man.head
 +"\fI\\\\.gz$\fP"). The commands tell Mutt how to uncompress a folder
 +(\fBopen-hook\fP), compress a folder (\fBclose-hook\fP) or append a
 +compressed mail to a compressed folder (\fBappend-hook\fP). The
-+\fIcommand\fP string is the 
++\fIcommand\fP string is the
 +.BR printf (3)
 +like format string, and it should accept two parameters: \fB%f\fP,
 +which is replaced with the (compressed) folder name, and \fB%t\fP
@@ -808,9 +824,8 @@ diff -urN mutt-1.5.11/doc/muttrc.man.head mutt-1.5.11-ro/doc/muttrc.man.head
  .TP
  \fBpush\fP \fIstring\fP
  This command adds the named \fIstring\fP to the keyboard buffer.
-diff -urN mutt-1.5.11/hook.c mutt-1.5.11-ro/hook.c
---- mutt-1.5.11/hook.c 2005-02-03 19:47:52.000000000 +0100
-+++ mutt-1.5.11-ro/hook.c      2005-09-27 13:27:02.000000000 +0200
+--- a/hook.c
++++ b/hook.c
 @@ -24,6 +24,10 @@
  #include "mailbox.h"
  #include "mutt_crypt.h"
@@ -831,33 +846,31 @@ diff -urN mutt-1.5.11/hook.c mutt-1.5.11-ro/hook.c
 +  {
 +    if (mutt_test_compress_command (command.data))
 +    {
-+      strfcpy (err->data, _("bad formatted command string"), err->dsize);
++      strfcpy (err->data, _("badly formatted command string"), err->dsize);
 +      return (-1);
 +    }
 +  }
 +#endif
-   else if (DefaultHook && !(data & (M_CHARSETHOOK | M_ACCOUNTHOOK))
+   else if (DefaultHook && !(data & (M_CHARSETHOOK | M_ICONVHOOK | M_ACCOUNTHOOK))
             && (!WithCrypto || !(data & M_CRYPTHOOK))
        )
-diff -urN mutt-1.5.11/init.h mutt-1.5.11-ro/init.h
---- mutt-1.5.11/init.h 2005-09-15 16:19:54.000000000 +0200
-+++ mutt-1.5.11-ro/init.h      2005-09-27 13:27:02.000000000 +0200
-@@ -3100,6 +3100,11 @@
+--- a/init.h
++++ b/init.h
+@@ -3504,6 +3504,11 @@
+   { "fcc-hook",               mutt_parse_hook,        M_FCCHOOK },
+   { "fcc-save-hook",  mutt_parse_hook,        M_FCCHOOK | M_SAVEHOOK },
    { "folder-hook",    mutt_parse_hook,        M_FOLDERHOOK },
-   { "group",          parse_group,            0 },
-   { "ungroup",                parse_ungroup,          0 },
 +#ifdef USE_COMPRESSED
 +  { "open-hook",      mutt_parse_hook,        M_OPENHOOK },
 +  { "close-hook",     mutt_parse_hook,        M_CLOSEHOOK },
 +  { "append-hook",    mutt_parse_hook,        M_APPENDHOOK },
 +#endif
+   { "group",          parse_group,            0 },
+   { "ungroup",                parse_ungroup,          0 },
    { "hdr_order",      parse_list,             UL &HeaderOrderList },
- #ifdef HAVE_ICONV
-   { "iconv-hook",     mutt_parse_hook,        M_ICONVHOOK }, 
-diff -urN mutt-1.5.11/main.c mutt-1.5.11-ro/main.c
---- mutt-1.5.11/main.c 2005-09-07 10:19:43.000000000 +0200
-+++ mutt-1.5.11-ro/main.c      2005-09-27 13:27:02.000000000 +0200
-@@ -385,6 +385,12 @@
+--- a/main.c
++++ b/main.c
+@@ -402,6 +402,12 @@
  #else
        "-LOCALES_HACK  "
  #endif
@@ -870,34 +883,31 @@ diff -urN mutt-1.5.11/main.c mutt-1.5.11-ro/main.c
              
  #ifdef HAVE_WC_FUNCS
        "+HAVE_WC_FUNCS  "
-diff -urN mutt-1.5.11/Makefile.am mutt-1.5.11-ro/Makefile.am
---- mutt-1.5.11/Makefile.am    2005-08-11 23:27:28.000000000 +0200
-+++ mutt-1.5.11-ro/Makefile.am 2005-09-27 13:27:02.000000000 +0200
+--- a/Makefile.am
++++ b/Makefile.am
 @@ -18,7 +18,7 @@
  bin_PROGRAMS = mutt @DOTLOCK_TARGET@ @PGPAUX_TARGET@
- mutt_SOURCES = $(BUILT_SOURCES) \
+ mutt_SOURCES = \
        addrbook.c alias.c attach.c base64.c browser.c buffy.c color.c \
--        crypt.c cryptglue.c \
-+        crypt.c cryptglue.c compress.c \
+-      crypt.c cryptglue.c \
++      crypt.c cryptglue.c compress.c \
        commands.c complete.c compose.c copy.c curs_lib.c curs_main.c date.c \
-       edit.c enter.c flags.c init.c filter.c from.c getdomain.c \
-       handler.c hash.c hdrline.c headers.c help.c hook.c keymap.c \
-@@ -67,7 +67,7 @@
-       crypt-gpgme.c crypt-mod-pgp-gpgme.c crypt-mod-smime-gpgme.c
+       edit.c enter.c flags.c init.c filter.c from.c \
+       getdomain.c group.c \
+@@ -57,7 +57,7 @@
+       bcache.h browser.h hcache.h mbyte.h mutt_idna.h remailer.h url.h
  
- EXTRA_DIST = COPYRIGHT GPL OPS OPS.PGP OPS.CRYPT OPS.SMIME TODO \
+ EXTRA_DIST = COPYRIGHT GPL OPS OPS.PGP OPS.CRYPT OPS.SMIME TODO UPDATING \
 -      configure account.h \
 +      configure account.h compress.h \
        attach.h buffy.h charset.h copy.h crypthash.h dotlock.h functions.h gen_defs \
        globals.h hash.h history.h init.h keymap.h mutt_crypt.h \
        mailbox.h mapping.h md5.h mime.h mutt.h mutt_curses.h mutt_menu.h \
-diff -urN mutt-1.5.11/Makefile.in mutt-1.5.11-ro/Makefile.in
-diff -urN mutt-1.5.11/mbox.c mutt-1.5.11-ro/mbox.c
---- mutt-1.5.11/mbox.c 2005-08-02 09:08:00.000000000 +0200
-+++ mutt-1.5.11-ro/mbox.c      2005-09-27 13:27:02.000000000 +0200
-@@ -28,6 +28,10 @@
- #include "sort.h"
+--- a/mbox.c
++++ b/mbox.c
+@@ -29,6 +29,10 @@
  #include "copy.h"
+ #include "mutt_curses.h"
  
 +#ifdef USE_COMPRESSED
 +#include "compress.h"
@@ -906,7 +916,7 @@ diff -urN mutt-1.5.11/mbox.c mutt-1.5.11-ro/mbox.c
  #include <sys/stat.h>
  #include <dirent.h>
  #include <string.h>
-@@ -1014,6 +1018,12 @@
+@@ -1048,6 +1052,12 @@
  int mbox_close_mailbox (CONTEXT *ctx)
  {
    mx_unlock_file (ctx->path, fileno (ctx->fp), 1);
@@ -919,10 +929,9 @@ diff -urN mutt-1.5.11/mbox.c mutt-1.5.11-ro/mbox.c
    mutt_unblock_signals ();
    mx_fastclose_mailbox (ctx);
    return 0;
-diff -urN mutt-1.5.11/mutt.h mutt-1.5.11-ro/mutt.h
---- mutt-1.5.11/mutt.h 2005-09-07 10:19:43.000000000 +0200
-+++ mutt-1.5.11-ro/mutt.h      2005-09-27 13:27:02.000000000 +0200
-@@ -157,6 +157,11 @@
+--- a/mutt.h
++++ b/mutt.h
+@@ -146,6 +146,11 @@
  #define M_ACCOUNTHOOK (1<<9)
  #define M_REPLYHOOK   (1<<10)
  #define M_SEND2HOOK     (1<<11)
@@ -934,9 +943,9 @@ diff -urN mutt-1.5.11/mutt.h mutt-1.5.11-ro/mutt.h
  
  /* tree characters for linearize_tree and print_enriched_string */
  #define M_TREE_LLCORNER               1
-@@ -828,6 +833,11 @@
-   void *data;                 /* driver specific data */
#endif /* USE_IMAP */
+@@ -882,6 +887,11 @@
+   int flagged;                        /* how many flagged messages */
  int msgnotreadyet;          /* which msg "new" in pager, -1 if none */
  
 +#ifdef USE_COMPRESSED
 +  void *compressinfo;         /* compressed mbox module private data */
@@ -945,13 +954,9 @@ diff -urN mutt-1.5.11/mutt.h mutt-1.5.11-ro/mutt.h
 +
    short magic;                        /* mailbox type */
  
-   unsigned int locked : 1;    /* is the mailbox locked? */
-diff -urN mutt-1.5.11/Muttrc mutt-1.5.11-ro/Muttrc
-diff -urN mutt-1.5.11/Muttrc.head mutt-1.5.11-ro/Muttrc.head
-diff -urN mutt-1.5.11/Muttrc.head.in mutt-1.5.11-ro/Muttrc.head.in
-diff -urN mutt-1.5.11/mx.c mutt-1.5.11-ro/mx.c
---- mutt-1.5.11/mx.c   2005-09-07 10:19:43.000000000 +0200
-+++ mutt-1.5.11-ro/mx.c        2005-09-27 13:27:02.000000000 +0200
+   unsigned char rights[(RIGHTSMAX + 7)/8];    /* ACL bits */
+--- a/mx.c
++++ b/mx.c
 @@ -30,6 +30,10 @@
  #include "keymap.h"
  #include "url.h"
@@ -963,7 +968,7 @@ diff -urN mutt-1.5.11/mx.c mutt-1.5.11-ro/mx.c
  #ifdef USE_IMAP
  #include "imap.h"
  #endif
-@@ -454,6 +458,10 @@
+@@ -415,6 +419,10 @@
      return (-1);
    }
  
@@ -974,7 +979,7 @@ diff -urN mutt-1.5.11/mx.c mutt-1.5.11-ro/mx.c
    return (magic);
  }
  
-@@ -493,6 +501,13 @@
+@@ -454,6 +462,13 @@
  {
    struct stat sb;
  
@@ -988,7 +993,7 @@ diff -urN mutt-1.5.11/mx.c mutt-1.5.11-ro/mx.c
    ctx->append = 1;
  
  #ifdef USE_IMAP
-@@ -653,7 +668,12 @@
+@@ -617,7 +632,12 @@
    }
  
    ctx->magic = mx_get_magic (path);
@@ -1002,7 +1007,7 @@ diff -urN mutt-1.5.11/mx.c mutt-1.5.11-ro/mx.c
    if(ctx->magic == 0)
      mutt_error (_("%s is not a mailbox."), path);
  
-@@ -759,6 +779,10 @@
+@@ -718,6 +738,10 @@
      mutt_free_header (&ctx->hdrs[i]);
    FREE (&ctx->hdrs);
    FREE (&ctx->v2r);
@@ -1013,10 +1018,10 @@ diff -urN mutt-1.5.11/mx.c mutt-1.5.11-ro/mx.c
    FREE (&ctx->path);
    FREE (&ctx->pattern);
    if (ctx->limit_pattern) 
-@@ -816,6 +840,12 @@
+@@ -770,6 +794,12 @@
+   
    if (tmp && tmp->new == 0)
      mutt_update_mailbox (tmp);
- #endif
 +
 +#ifdef USE_COMPRESSED
 +  if (rc == 0 && ctx->compressinfo)
@@ -1026,7 +1031,7 @@ diff -urN mutt-1.5.11/mx.c mutt-1.5.11-ro/mx.c
    return rc;
  }
  
-@@ -1021,6 +1051,11 @@
+@@ -1033,6 +1063,11 @@
        !mutt_is_spool(ctx->path) && !option (OPTSAVEEMPTY))
      mx_unlink_empty (ctx->path);
  
@@ -1038,7 +1043,7 @@ diff -urN mutt-1.5.11/mx.c mutt-1.5.11-ro/mx.c
    mx_fastclose_mailbox (ctx);
  
    return 0;
-@@ -1330,6 +1365,11 @@
+@@ -1355,6 +1390,11 @@
  {
    int rc;
  
@@ -1050,9 +1055,8 @@ diff -urN mutt-1.5.11/mx.c mutt-1.5.11-ro/mx.c
    if (ctx)
    {
      if (ctx->locked) lock = 0;
-diff -urN mutt-1.5.11/mx.h mutt-1.5.11-ro/mx.h
---- mutt-1.5.11/mx.h   2003-08-05 15:58:16.000000000 +0200
-+++ mutt-1.5.11-ro/mx.h        2005-09-27 13:27:02.000000000 +0200
+--- a/mx.h
++++ b/mx.h
 @@ -40,6 +40,9 @@
  #ifdef USE_POP
    , M_POP
@@ -1063,36 +1067,51 @@ diff -urN mutt-1.5.11/mx.h mutt-1.5.11-ro/mx.h
  };
  
  WHERE short DefaultMagic INITVAL (M_MBOX);
-diff -urN mutt-1.5.11/PATCHES mutt-1.5.11-ro/PATCHES
---- mutt-1.5.11/PATCHES        2005-08-15 10:16:00.000000000 +0200
-+++ mutt-1.5.11-ro/PATCHES     2005-09-27 13:30:25.000000000 +0200
-@@ -0,0 +1 @@
-+patch-1.5.11.rr.compressed.1
-diff -urN mutt-1.5.11/po/de.po mutt-1.5.11-ro/po/de.po
---- mutt-1.5.11/po/de.po       2005-09-15 16:23:50.000000000 +0200
-+++ mutt-1.5.11-ro/po/de.po    2005-09-27 13:27:02.000000000 +0200
-@@ -1262,6 +1262,48 @@
- msgid "Failed to figure out sender"
- msgstr "Kann Absender nicht ermitteln"
+--- a/po/de.po
++++ b/po/de.po
+@@ -2005,6 +2005,10 @@
+ msgid "Bad history file format (line %d)"
+ msgstr "Falsches Format der Datei früherer Eingaben (Zeile %d)"
  
-+#: compress.c:203 mbox.c:661
-+msgid "Mailbox was corrupted!"
-+msgstr "Mailbox wurde zerstört!"
++#: hook.c:96
++msgid "badly formatted command string"
++msgstr "Hook enthält nicht die Muster %f und %t"
++
+ #: hook.c:251
+ #, c-format
+ msgid "unhook: Can't do unhook * from within a hook."
+@@ -2766,7 +2770,7 @@
+ msgid "Mailbox is corrupt!"
+ msgstr "Mailbox fehlerhaft!"
+-#: mbox.c:678
++#: mbox.c:678 compress.c:203 mbox.c:661
+ msgid "Mailbox was corrupted!"
+ msgstr "Mailbox wurde zerstört!"
+@@ -2774,10 +2778,11 @@
+ msgid "Fatal error!  Could not reopen mailbox!"
+ msgstr "Fataler Fehler, konnte Mailbox nicht erneut öffnen!"
+-#: mbox.c:746
++#: mbox.c:746 compress.c:264 compress.c:246 compress.c:367 compress.c:443 mbox.c:706
+ msgid "Unable to lock mailbox!"
+ msgstr "Kann Mailbox nicht für exklusiven Zugriff sperren!"
++
+ #. this means ctx->changed or ctx->deleted was set, but no
+ #. * messages were found to be changed or deleted.  This should
+ #. * never happen, is we presume it is a bug in mutt.
+@@ -5378,3 +5383,32 @@
+ #~ msgid "Authentication method is unknown."
+ #~ msgstr "Authentifizierungsmethode unbekannt."
 +
 +#: compress.c:228 compress.c:253
 +#, c-format
 +msgid "Decompressing %s...\n"
 +msgstr "Entpacke %s...\n"
 +
-+#: compress.c:246 compress.c:367 compress.c:443 mbox.c:706
-+msgid "Unable to lock mailbox!"
-+msgstr "Kann Mailbox nicht für exklusiven Zugriff sperren!"
-+
-+#: compress.c:264
-+#, c-format
-+msgid "Error executing: %s : unable to open the mailbox!\n"
-+msgstr "Fehler beim Ausführen von %s : Kann die Mailbox nicht öffnen!\n"
-+
 +#: compress.c:350 compress.c:377 compress.c:423 compress.c:454
 +#, c-format
 +msgid "Compressing %s...\n"
@@ -1116,43 +1135,8 @@ diff -urN mutt-1.5.11/po/de.po mutt-1.5.11-ro/po/de.po
 +#, c-format
 +msgid " %s: Error compressing mailbox!  Uncompressed one kept!\n"
 +msgstr " %s: Fehler beim packen der Mailbox! Entpackte Mailbox gespeichert!\n"
-+
- #: crypt.c:69
- #, c-format
- msgid " (current time: %c)"
-@@ -1882,6 +1924,10 @@
- msgid "Help for %s"
- msgstr "Hilfe für %s"
-+#: hook.c:96
-+msgid "bad formatted command string"
-+msgstr "Hook enthält nicht die Muster %f und %t"
-+
- #: hook.c:246
- #, c-format
- msgid "unhook: Can't do unhook * from within a hook."
-@@ -3336,18 +3382,10 @@
- msgid "Mailbox is corrupt!"
- msgstr "Mailbox fehlerhaft!"
--#: mbox.c:662
--msgid "Mailbox was corrupted!"
--msgstr "Mailbox wurde zerstört!"
--
- #: mbox.c:701 mbox.c:952
- msgid "Fatal error!  Could not reopen mailbox!"
- msgstr "Fataler Fehler, konnte Mailbox nicht erneut öffnen!"
--#: mbox.c:710
--msgid "Unable to lock mailbox!"
--msgstr "Kann Mailbox nicht für exklusiven Zugriff sperren!"
--
- #. this means ctx->changed or ctx->deleted was set, but no
- #. * messages were found to be changed or deleted.  This should
- #. * never happen, is we presume it is a bug in mutt.
-diff -urN mutt-1.5.11/po/POTFILES.in mutt-1.5.11-ro/po/POTFILES.in
---- mutt-1.5.11/po/POTFILES.in 2005-08-03 11:17:47.000000000 +0200
-+++ mutt-1.5.11-ro/po/POTFILES.in      2005-09-27 13:27:02.000000000 +0200
+--- a/po/POTFILES.in
++++ b/po/POTFILES.in
 @@ -8,6 +8,7 @@
  color.c
  commands.c
@@ -1161,10 +1145,9 @@ diff -urN mutt-1.5.11/po/POTFILES.in mutt-1.5.11-ro/po/POTFILES.in
  crypt-gpgme.c
  crypt.c
  cryptglue.c
-diff -urN mutt-1.5.11/status.c mutt-1.5.11-ro/status.c
---- mutt-1.5.11/status.c       2005-02-03 19:47:53.000000000 +0100
-+++ mutt-1.5.11-ro/status.c    2005-09-27 13:27:02.000000000 +0200
-@@ -97,6 +97,14 @@
+--- a/status.c
++++ b/status.c
+@@ -96,6 +96,14 @@
  
      case 'f':
        snprintf (fmt, sizeof(fmt), "%%%ss", prefix);
@@ -1172,7 +1155,7 @@ diff -urN mutt-1.5.11/status.c mutt-1.5.11-ro/status.c
 +      if (Context && Context->compressinfo && Context->realpath)
 +      {
 +       strfcpy (tmp, Context->realpath, sizeof (tmp));
-+       mutt_pretty_mailbox (tmp);
++       mutt_pretty_mailbox (tmp, sizeof (tmp));
 +      }
 +      else
 +#endif