]> git.llucax.com Git - software/mutt-debian.git/blobdiff - debian/patches/debian-specific/use_usr_bin_editor.diff
Grab two patches from upstream that should also go into lenny
[software/mutt-debian.git] / debian / patches / debian-specific / use_usr_bin_editor.diff
index 402c86777c129f0c08c3cf653103fe9ff6906290..13baea5395c9596fdc07131d79416ea9fa2b5152 100644 (file)
@@ -1,6 +1,6 @@
---- mutt-1.5.11.orig/init.c
-+++ mutt-1.5.11/init.c
-@@ -2920,7 +2920,7 @@
+--- a/init.c
++++ b/init.c
+@@ -3114,7 +3114,7 @@ void mutt_init (int skip_sys_rc, LIST *c
    {
      p = getenv ("EDITOR");
      if (!p)
@@ -9,14 +9,14 @@
    }
    Editor = safe_strdup (p);
    Visual = safe_strdup (p);
---- mutt-1.5.11.orig/init.h
-+++ mutt-1.5.11/init.h
-@@ -547,7 +547,7 @@
+--- a/init.h
++++ b/init.h
+@@ -589,7 +589,7 @@ struct option_t MuttVars[] = {
    ** .pp
    ** This variable specifies which editor is used by mutt.
-   ** It defaults to the value of the VISUAL, or EDITOR, environment
--  ** variable, or to the string "vi" if neither of those are set.
-+  ** variable, or to the string "/usr/bin/editor" if neither of those are set.
+   ** It defaults to the value of the \fC$$$VISUAL\fP, or \fC$$$EDITOR\fP, environment
+-  ** variable, or to the string ``vi'' if neither of those are set.
++  ** variable, or to the string ``/usr/bin/editor'' if neither of those are set.
    */
    { "encode_from",    DT_BOOL, R_NONE, OPTENCODEFROM, 0 },
    /*