]> git.llucax.com Git - software/mutt-debian.git/blobdiff - debian/patches/debian-specific/use_usr_bin_editor.diff
Merge branch '1.5.20-1+fix533439-atime'
[software/mutt-debian.git] / debian / patches / debian-specific / use_usr_bin_editor.diff
index 402c86777c129f0c08c3cf653103fe9ff6906290..5c51a580cb6d349b3d687dd97430383081c37b28 100644 (file)
@@ -1,6 +1,9 @@
---- mutt-1.5.11.orig/init.c
-+++ mutt-1.5.11/init.c
-@@ -2920,7 +2920,7 @@
+Even if EDITOR is not set, mutt will always use /usr/bin/editor (which 
+is set by update-alternatives), rather than falling back to vi
+
+--- a/init.c
++++ b/init.c
+@@ -3115,7 +3115,7 @@
    {
      p = getenv ("EDITOR");
      if (!p)
    }
    Editor = safe_strdup (p);
    Visual = safe_strdup (p);
---- mutt-1.5.11.orig/init.h
-+++ mutt-1.5.11/init.h
-@@ -547,7 +547,7 @@
+--- a/init.h
++++ b/init.h
+@@ -686,7 +686,7 @@
    ** .pp
    ** This variable specifies which editor is used by mutt.
-   ** It defaults to the value of the VISUAL, or EDITOR, environment
--  ** variable, or to the string "vi" if neither of those are set.
-+  ** variable, or to the string "/usr/bin/editor" if neither of those are set.
+   ** It defaults to the value of the \fC$$$VISUAL\fP, or \fC$$$EDITOR\fP, environment
+-  ** variable, or to the string ``vi'' if neither of those are set.
++  ** variable, or to the string ``/usr/bin/editor'' if neither of those are set.
    */
    { "encode_from",    DT_BOOL, R_NONE, OPTENCODEFROM, 0 },
    /*