-diff -urN mutt-1.5.3.orig/Muttrc.head.in mutt-1.5.3/Muttrc.head.in
---- mutt-1.5.3.orig/Muttrc.head.in 2000-03-20 11:25:49.000000000 +0100
-+++ mutt-1.5.3/Muttrc.head.in 2003-01-12 17:16:41.000000000 +0100
+--- a/Muttrc.head.in
++++ b/Muttrc.head.in
@@ -6,6 +6,38 @@
#
ignore "from " received content- mime-version status x-status message-id
ignore sender references return-path lines
+ignore date delivered-to precedence errors-to in-reply-to user-agent
-+ignore x-loop x-sender x-mailer x-msmail-priority x-mimeole x-priority
-+ignore x-accept-language x-authentication-warning thread- priority
-+ignore domainkey-signature
++ignore x-loop x-sender x-mailer x-msmail-priority x-mimeole x-ms- x-priority
++ignore x-accept-language x-authentication-warning thread- priority importance
++ignore x-original-to domainkey-signature
+
+# emacs-like bindings
+bind editor "\e<delete>" kill-word
+#macro index \CW T!~s\(.*source.*\)\nWn^T~A\n "Weed out binary-only announcements"
# imitate the old search-body function
- macro index \eb '/~b ' 'search in message bodies'
-@@ -13,11 +44,20 @@
- # simulate the old url menu
- macro index \cb |urlview\n 'call urlview to extract URLs out of a message'
- macro pager \cb |urlview\n 'call urlview to extract URLs out of a message'
-+set pipe_decode
+ macro index \eb "<search>~b " "search in message bodies"
+@@ -14,7 +46,17 @@
+ macro index,pager \cb "<pipe-message>urlview<Enter>" "call urlview to extract URLs out of a message"
# Show documentation when pressing F1
--macro generic <f1> "!less @docdir@/manual.txt\n" "Show Mutt documentation"
--macro index <f1> "!less @docdir@/manual.txt\n" "Show Mutt documentation"
--macro pager <f1> "!less @docdir@/manual.txt\n" "Show Mutt documentation"
+-macro generic,pager <F1> "<shell-escape>less @docdir@/manual.txt<Enter>" "show Mutt documentation"
+macro generic <f1> "!zcat @docdir@/mutt/manual.txt.gz | sensible-pager\n" "Show Mutt documentation"
+macro index <f1> "!zcat @docdir@/mutt/manual.txt.gz | sensible-pager\n" "Show Mutt documentation"
+macro pager <f1> "!zcat @docdir@/mutt/manual.txt.gz | sensible-pager\n" "Show Mutt documentation"
+close-hook \\.bz2$ "bzip2 -c %t > %f"
+append-hook \\.bz2$ "bzip2 -c %t >> %f"
- # If Mutt is unable to determine your site's domain name correctly, you can
- # set the default here.
-@@ -28,7 +68,22 @@
+ # show the incoming mailboxes list (just like "mutt -y") and back when pressing "y"
+ macro index,pager y "<change-folder>?<toggle-mailboxes>" "show incoming mailboxes list"
+@@ -29,7 +71,22 @@
#
# set use_8bitmime